OpenSuse 11 has printer, want WXP box to be able to use

I have openSuse 11 & WXP (SP2) on my dual boot box, my wife has only WXP (SP3). I want her to be able to use my printer without changing out of Suse on mine. There is a lot of information in the forums but I am a noob to using this type of system and it doesn’t make much sense so far. I went to Swerdna’s tutorial (I couldn’t find anything for OS 11) and tried to follow the steps for the easier IPP Print Server. I get stumped at the entering password into the terminal. I cut & pasted “sudo lppasswd -a username” put in my root, put in a new pw twice and recieved this:

mech13@linux-8vsz:~> sudo lppasswd -a username
root’s password:
Enter password:
Enter password again:
lppasswd: Unable to open password file: Permission denied

I would appreciate any help (might have to dumb it down to a point I get it :slight_smile: Thank you in advance.

If you already have the printer working under SuSe it should all be doable trough the GUI instead of messing around with the commandline (something I tend to avoid as much as possible :)).

Here is how to:
Yast > Network Services > Samba Server (Identity tab)
Fill in the same workgroup as the XP is set to.

Yast > Network Services > Samba Server (Shares tab)
Make sure the entry with the name “printers” under “Available shares” is set to “Enabled”.

Hit finish and you’re done

On the XP box go Start > Configuration panel > printers > add network printer.
Follow the instructions on the screen and you should find the printer / be able to use it.

You most likely need to install the printer drivers before trying this, and if you change the workgroup of the XP box don’t forget to reboot the PC before attempting to find the printer.

Thanks Axeia,
That was a lot easier than I expected, 10 minutes I was done. It does seem to have a hard time keeping the settings as default on the XP box but that is no big deal, I just will teach my wife to set the properties each time she prints. Thank you for the reply and helping me out. Have a good week. :slight_smile:

You’re welcome… if you reboot the openSUSE box and you don’t have a static IP you might end up with a different IP every reboot, making the XP box unable to find the openSUSE box/printer. (Thus making you have to reconfigure it every time)

If that’s not the problem in XP just setting the printer as default with a right click > set default in the Control panel > Printers should do it.