Opensuse 11 goes to black screen on load, any advice?

Wish i could give some more information about what is going wrong but would need someone to tell me where to look for that.

Twice now i have installed opensuse11 and its been running well until i do the automatic updates that need to reboot the computer. after these updates have been done it loads up to where kde would usually start and stops at a black screen.

if i ctrl-alt-del it does bring up a box which is empty though. could it be to do with graphics drivers?

im running a core2duo with 4gb ram and an nvidia 7950gt on asus mboard.

any help on this issue would be much appreciated

the kernel update is breaking the video driver.

install the nvidia repo’s

for now you may be able to setup a basic driver to be able to login to a GUI by doing this:

type 3 (just the number - that’s it)
at the green boot screen on the default boot line, to get runlevel 3. - login as root at the prompt (this is a text login)

sax2 -r -m 0=vesa

this should enable a display using vesa

If this gets you in, go to add the above link to your repositories
then install the nvidia drivers
if you are not sure how to do all that - here is a OneClick link
you will just need your root password

so close yet, im still stumped.

i am now able to see my mouse cursor and move it, but everything else is still blacked out, no icons or menus, though it does seem if i click around a bit they are there behind this blackness.

are you using kde 4.0.4 or kde 4.1 ?

now i think its 4.0.4 but cant be sure sorry

I’m guessing you have auto-login enabled?

yep, yeah im totally new to linux, anything else you need to know?

I hope someone else can help, only I have to logout now.

It seems perhaps your graphics was ok and the problem was all to do with kde4.
You should disable auto-login in the future and have an alternate desktop like kde3 or gnome that you can switch to. kde4 is still a bit flaky for new users.

You could remove the folder /.kde4
it’s a hidden folder in /home/*user
it will start a new session of kde4 and all your settings will have gone.
Or manually disable auto login and then use a different desktop.
If you don’t know how to do all this - wait for a reply or start a new thread. Sorry I have to go.

thanks mate

have been able to get in the way you said after a few tries. installed the nvidia drivers. will disable autologin.

I suggest you install kde3
in software management go to patterns,
check kde3 desktop and kde3 base

later add this repo to your list
Index of /repositories/KDE:/KDE3/openSUSE_11.0

and update by that repo - all in the list

you can select login options at login screen, lower left