opensuse 11 final - Everex Laptop no keyboard or mouse click

After installing opensuse 11.0 (x86) on my Everex xt5000t, on first boot, the keyboard did not respond. No ctrl + alt + f1 to break into a terminal, or ctrl + alt + backspace to restart X. The mouse pointer moved when I move my microsoft wireless mouse, but did not respond to on mouse over actions or on any clicks. When attempting to use the tablet mouse portion of the laptop, there was noticeable lag, and it did not respond to clicks from those buttons either.

I did not have this problem with alpha 2 or any of the betas. I am trying now with “no acpi” in case it is a power management problem

I have similar problem on my Lenovo N100 (0768-BJG).
I’ve installed os.11.0 from liveCD - with KDE4.
Problem occurres after minutes of working in X, usually when i hold 1 key for longer period. Touchpad doesn’t respond, nor an key. If I conect usb-mouse I can still move the sursor around - I don’t have usb-keyboard so I can check what would happen.
If the ‘hang’ happens when I had pressed <Up A.> or <Down Arrow>, and I click on a icon/menu (with the 2nd, usb-mouse), I can see focus/selection bar runing (endlessly) thru popup-menu. I used 10.2 and 10.3 previously, hadn’t had this problem.
I’ve installed ‘x11-input-synaptics’ and keyboard set to ‘Microsoft Natural basic’.
Help please.

Can you take a look in the BIOS to see if there are any settings you can change that might help?

I know for an external USB wireless keyboard, I had to go in to the BIOS and change the USB setting to “legacy” to get her keyboard to work during boot.

I recall back in the openSUSE-10.0 days, in order to get SuSE to install on some laptops, one had to plug in an external monitor, and then do the install. For some reason with the external monitor plugged in, everything worked! VERY VERY bizarre, as who would think an external monitor would help a keyboard/mouse work?

Once SuSE was installed (thanks to the external monitor being connected) the user was then able to go into either Yast or sax2 and fix the keyboard mouse for their laptop.

Have you tried to get to a terminal when you enter “init 3” on the bootmenu as additional parameter?
Maybe so you get a chance to let sax2 run again (also try sax2-vesa if sax2 also crashes) and try to reconfigure your graphic system…

Otherwise you should post the file /var/log/Xorg.0.log here, if you could get it…

I have installed OpenSuse 10.3 on my laptop ( Fujitsu Siemens AMILO Pro V2010 - Celeron M 1.5 GHz 256 Mo 4 ) and I have the samed problem : USB mouse works, keyboard dont’t work at all.

After launching the command “sudo yast2 --install x11-input-synaptics” in safe mode and after rebooting, my keyboard works.