Opensuse 11, Dell 1720, 8600m GT - disappointing

Hey yall,

I have been a die-hard fan of Suse since 9.2 but i think it might be about time to try something else.

Installation went pretty well except for one thing: when we reach the partition stage shrinking a NTFS partition is a pain in the butt. Here is what happened:

  1. Have a 100gb hdd that hosts vista.
  2. I wanted to leave 70GB for vista (since i have a lot of software installed) and give 30GB to Suse.
  3. The partition manager automatically decided to shrink vista to 54GB which would have left the Vista partition with about 8GB free, which is frankly not enough.
  4. From this point on the only option is to go expert mode and tweak the partition table yourself.

What gives?? Why can’t you have a simple option (for newbies, for convenience, etc.) of how much you want to shrink the partition and that’s it??? Why is it forced?

Unhappiness doesn’t stop there though. I tried to change the partition table. If you just tried to resize the vista partition once its done it doesn’t automatically offset the starting points of the partitions following it (which would have been the suse partitions). The only way is to delete the proposed suse partitions, resize Vista, and redo the suse partitions… what are we in 19th century??

Nevermind that, though. So, installation after that was pretty flawless. I figured my Nvidia will work out of the box, i was hoping compiz-fusion would do too.
Well, it turned out i have to manually install the Nvidia driver. Before installing it of course the graphics were pretty sluggish. Also, for the life of me I couldn’t get the correct resolution on my screen (it always gave me 1600x1200 even thought the correct max resolution is 1920x1200).

So, I went ahead and installed the Nvidia drivers. Installation was fine. I enabled 3d effects. Everything went to hell. Graphics remained sluggish. Sometimes the desktop would lock up on me - mouse moves fine but no clicks register (actually i think they register since i could hear the sound effects but no change on the screen). Enabling or disabling more effects in the desktop effects section results in the above mentioned lockup.

So, since i have no time to play around to get my laptop to a working condition, i am finally going to try other distros that seem to work out of the box.

And i waited with such anticipation for suse 11 …

I hope you didn’t install KDE4 which is experimental still – what desktop did u install

The problem persist both with KDE4 and KDE3.5 - i installed both. Wasn’t the kde4 packed with suse 11 supposed to be rather stable though?

Stable? No.

From what I have read, many openSUSE-11.0 kde-4 users are immediately updating to kde-4.1.

Its not forced. I modified my install/partitioning details in the installer.

Not 100% I understand what you are saying, but if I do, then I think you have a point, and has been a pain in SuSE (and not just openSUSE) for as long as I can remember. BUT there are other ways to do this, and not just the one you noted.

I think you got it :slight_smile: and yes, it has been a pain.

I tried out the ubuntu 8.04 and i am happy to report that everything works with a few clicks:

  1. Resolution is set correctly to 1920x1200, automatically.
  2. Enabling desktop effects required the (automatic) installation of nvidia drivers - it took 5 mins plus a restart and i had compiz running.
  3. Tweaking compiz-fusion required installation of compiz-setting-manager package.
  4. Installation of video/audio support for restricted formats was a breeze - 2 prompts right after i tried to play an avi file and i was done.
  5. Dell media direct buttons work :slight_smile:

Somehow, with suse, it seems it could take me a good part of an evening to get to where i got with ubuntu in about 15 mins… thats for a laptop. I am still sticking with suse as a working environment in my lab.

So, to recap - dell lappie owners might want to give ubuntu a try (for convenience’s sake)

just my two centavos

oh also:

  1. Dell webcam works out of the box - just installed skype and webcam is alive and well! I have to say it took me a lot of work to get it going on suse 10.3

Same Deal here. I have been using Ubuntu for 2 years now. 7.10 was awesome in my Dell 1720. 8.04 Hary is not as good for me some how.System slowed down a great deal. Compiz is not working well with my videocard 8600 That is when I read SUSE is the Mercedez benz compared to Ubuntu which is corolla.

I was expecting a pleasant surprise when I saw the flawless Suse installer. Ubuntu should learn from that.

But from there it was slippery downhill. I am still figuring out Nvidia drivers and wireless. It did not share my Ubuntu Home partition very well.

Hope suse will be nicer to me soon !!

What you have encountered here is a significant philosophical difference between openSUSE and Ubuntu. The wireless and nVidia drivers are proprietary. Which means they (wireless manuf and nVidia) either will not reveal their souce code, or if they will reveal it, they have restrictions on it that are contrary to the Linux GPL.

Ubuntu will include proprietary drivers. openSUSE will NOT, as openSUSE is “open”, which means no proprietary drivers. …

There are 3rd party sites that provide instructions on how to do this, … and openSUSE Linux volunteers on this forum and on IRC freenode #suse will cheerfully help you on this.

I recommend you start 2 new threads to get help on this. The first for your wireless. And the second for your nVidia driver.

Good luck, and welcome to openSUSE.

Thanks for the welcome. It was not too bad afterwards. I was able to figure out the Nvidia Drivers and Wireless. People searching for this can go to this link

Nvida -Suse Nvidia (How stupid for me to complain earlier)
Wireless – b43 - Linux Wireless (Very Straight forward)

I need to accept that Suse is very powerful. I am looking for some tutorials where the difference of using both are listed. I am finding the way around pretty well. There are only 2 more issues.

  1. Media keys in Dell 1720
  2. Mouse moves very slow. Synaptics Touchpad Driver is not fine-tuned. I almost lost half my finger dragging the mouse around.

Edge for Ubuntu is the tons of how-to’s floating around and blogs dedicated to it . :slight_smile:

I can’t help with this, but you may find this very basic openSUSE Linux concepts of use, in that it has many Links to various openSUSE way of doing things:
Concepts - openSUSE

I recommend all new openSUSE users initially stick to having only 4 repositories in their software repository list, … those being OSS, NON-OSS, Update and Packman. The reason being not all of the other repositories have rpms that are 100% compatible with the 4 that I mentioned. And those 4 are IMHO the most important. You can add and remove others on an as required basis, but do not have any others in place on a permanent basis. There is guidance for doing this repository addition here for openSUSE-11.0:
Repositories/11.0 - openSUSE-Community

Indeed. … documentation is a bit of a pet peeve of mine, but its hard to find the time to sort the documentation. We are trying in openSUSE to improve what we have. … But most of us are volunteers, and family and work have priorities, as on occasion do other hobbies.

Good luck with your efforts.

you’re probably have the same case as me - default touchpad setting wanted to do ‘too much the best’: it simulated the mouse wheel too! so once your finger movement is considered as a ‘wheel’ - the pointer is not doing at all what you’re expecting :-))

So, check first all currently configured mouse(s) in your system (Yast2/Hardware/Mouse) and see if it’s not the same for you… My fix was to simply replace my touchpad by a ‘generic mouse’ (well, each one may have different preferences :-))


Thanks for your support. I was successful to get the issues ironed out,

  1. Media Keys Worked - I had to assign the Shortcuts to KWIN for Global Volume control. Amarok Global settings can be tweaked for next, previous, play/pause and stop.

  2. Mouse is better than earlier, but still sluggish. I can tweak it later when everything else is working.

Now I am searching for solutions to the following

  1. Integrated Web cam not working yet. It is listed on Kopete, but has not worked yet.

  2. The Wireless Network shows low strength unlike Windows or Ubuntu, which shows full strength. I have not noticed any major delay, but I would like to investigate.

  3. Integrated mic is recognized, but the volume is slow with ALSA. I am not sure if I have to do anything to make it better. I remember the same problem with Ubuntu 7.10. It was fixed when I installed gStreamer plugins (I guess).

Search is on… Help is appreciated. Let me conclude by saying “openSUSE is impressive” Definitely a candidate for mainstream Linux Distro.

Off topic, Why can we unite the efforts of main Distros , like Ubuntu,SUSE, Fedora. Won’t it give us a better chance against M$ ? We have KDE, Gnome and what not. I can guarantee that it is confusing for the n00bs :frowning:

Same with my HP Pavillion dv6000 (Broadcom 4311 wireless). Just put a wall between laptop and AP and the signal strength bar in knetworkmanager goes all down, but the connection (internet, didn’t try lan) remains as good as if both were in the same room.

Correction on the above:

turn on laptop in same room as AP - signal bar 100% and the tray icon histogram shows 4 blue bars (100%)
go to other room - signal bar all down and tray icom with 2 blue and two gray bars (50%)
back to AP room - no change in strength bar or histogram icon!
The connection remais the same however…

brunomcl wrote:
> subru77;1866278 Wrote:
>> 2) The Wireless Network shows low strength unlike Windows or Ubuntu,
>> which shows full strength. I have not noticed any major delay, but I
>> would like to investigate.
>> (
> Same with my HP Pavillion dv6000 (Broadcom 4311 wireless). Just put a
> wall between laptop and AP and the signal strength bar in
> knetworkmanager goes all down, but the connection (internet, didn’t try
> lan) remains as good as if both were in the same room.

I have written the wireless statistics section for 3 different
wireless devices - b43 is one of them. Believe me when I say that they
are qualitative, not quantitative. As long as the quality goes down as
you move further away from the AP, that is about as good as it gets.


For me the strength is only 2 bars even on the same room. But I have no complaints on performance yet. I am sure Larry is right.

In openSUSE, the NM applet is very poor at following and/or updating
the signal strength. I’m only 2 m from my AP with a BCM4311 and only
get 2 bars on the tray applet, but if I plug in one of my USB devices,
connect with it, and then return to the Broadcom device, suddenly, I
get 5 bars. The signal strength has not changed a bit.

When I boot Ubuntu Hardy, the Gnome applet shows 5 bars immediately.


Hey Subru77, can you please let us know in detail on how you got the media keys working? Where exactly did u change the shortcut keys. Much appreciated.