openSuse 11 D-Link DWL-G122 rev. c1

Well, this is not the first time that this question is asked, but how can I configure this adapter?
I have searched this forum and many others, google of course and everything I tried it hadn’t worked.
When I was installing this driver using ndiswrapper I found out that there is that rsu37 (or whate name it is) driver already installed, so how to make it work? I tried configuring it in yast but no luck, I’m not total beginner but this time I feel like one, I really don’t know where to start, because I don’t know if the problem is driver configuration or driver installation, or both, what I have to do?
Please help

Am I too late?

Don’t use ndiswrapper:
Install package
rt73-cvs-kmp-default (change default according to your kernel flavor) and package ralink-firmware
From this repo:
Index of /repositories/home:/schmolle1980/openSUSE_11.0
(you may also add it’s update repo:Index of /repositories/home:/schmolle1980/openSUSE_11.0_Update )

Don’t use packages from offical repos: they don’t perform well.

No you are not too late,
thank you very much I’m going to do that, I’m suse user for a long time, form version 9.3 professional (maybe not so long after all) and of course I wasn’t going to change it but without internet acces it was hard,
thanks, I will try

OK, I’ve tried,
now I have two options under module, rt73usb (which was before) and rt73.
So I configured it in yast (just default settings, seen somewhere that you can manage that later, like encryption key that you can leave it blank, while I have one) for both settings, first tried with rt73usb then with rt73, and nothing appears anywhere, I tried with rcnetwork restart to see some progress but nothing, actually, I don’t know what to do now…
please point me in the right direction if you can…this network configuration it’s just completly new area for me…

Are you under gnome or kde?
under gnome you have to use networkmanager applet, under kde it’s knetworkmanager.

Also: try:
rmmod rt73usd
modprobe rt73usb

I tried, rmmod gives me that device is in use, modprobe gives me nothing, in networkmanager there is no networks,
actually, I don’t have time for this, I’m not a user who just gives up and in any other situations I would solve this problem no matter what, but when I see that mandriva supports my D-link out of the box and it works just perfectly, and suse, which is newer, doesn’t, it just forces me to change distributions, and actually, I have more problems with suse 11 than I had with suse 10.3, I just can stand it, thanks for you help, but I will wait for 11.1 if I will,

Yes you are.:smiley:

11.1 wont bring anything, since the firmware is no-free. Of course mandriva support it out-of-the-box: they have always shipped no-free dirvers. So it’s not a problem of newer or older, it’s a problem of license.

You can also try the package: ralink-firmare from no-oss repo. It will work, but it will “work”, but performance, like in ubuntu and surely mandriva, will be mediocre.

If rmmod gives you device in use:
Go to yast and reconfigure wireless. As me I had to repeat the process a couple of time before networkmanager started to work.

Ok, I configured it and it works fine, thanks for the help, I reinstalled suse, and then installed more packages that are related to my adapter and then knetowrk manager automaticly added all my devices, I just have installed those drivers you gave me in the second post, and if works just fine, thank you very much

Yes you are.

No i’m not :smiley: but I was out of my mind, now everything is great, wouldn’t change suse for nothing because it’s great, this is the reason why I have fixed this :wink: :smiley:
But “suse” please don’t do something like this again :slight_smile:
thanks again

ralink-firmare made it work for me, thanks :slight_smile: