OpenSuse 11: Constant crashing

I’m a developer/architect who’s used Linux/Unix all through my professional career. I used Suse Professional 9.3 at home for years on my old PC. I installed 32-bit OpenSuse 11 but haven’t yet used it in anger. Different story at work though…

At work I installed 64-bit OpenSuse 11 on my (standard) Dell Optiplex 745. Initally all seemed well and I was pleased with KDE 4.0. I even managed to get some Java development done. However, it soon started to go down hill.

There are niggles such as icons not appearing on my KDE desktop. This is despite starting afresh by blowing away my home directory by deleting myself as a user, and creating myself again. I’ve even cleared out /tmp. (BTW, anti-aliased fonts look crap.)

But far and away the most annoying thing is the constant freeze ups. It’s like being back on Windows again. X can’t be restarted unless you pull the plug.

I’m back on Windows at work since I really haven’t got the time to find out why OpenSuse is constantly falling over. I’m the only developer here who wanted to use a proper OS (I recently changed jobs and Windows is the OS of choice here).

Sadly OpenSuse hasn’t delivered the goods. Moreover it’s behaviour is at odds with my evangilising :frowning:

What version of KDE are you using?

Ah, missed it. You are running KDE 4.0. That is most likely the source of your issues. Why not load up KDE 3.5.9 and see if that helps. Alternatively you can try the beta’s of 4.1 and see if that is any better.

I agree that you should use KDE3. I’m running 11.0 x86_64 on an HP laptop, and
it is completely stable - just in case I need to reiterate, I stayed with KDE 3.


I added the KDE community repositories and tried updating. However my disk seems to be corrupted now (must be from having to pull the plug when things freeze). During the online update I get errors from YAST dialogs such as:

Subprocess failed: Error: RPM failed: rpmdb page 83 illegal page type or format

I’ll probably re-install from fresh but that won’t be until next week. Meanwhile, my old 32-bit PC at home updated to KDE 4.1 beta without any issues so at least I can play at home :slight_smile:

Are you using Reiserfs, or ati fglrx drivers?
ATI fglrx drivers was causing that for me.
And there is a known bug with Reiserfs in openSuse11.


I had constant lockups on my home system (64 bit) and my work system (32 bit) until the first kernel update. Now both are stable.

I’m running 64 bit on my AMD X2 system. It’s solid as a rock. Plus all the 1-Click installs have made setting up video card and media a breeze.