OpenSUSE 11 ati driver

While in beta stage I found it impossible to install ati fglrx drivers. Installation crashed while compiling kernel module.

Currently I don’t anymore use ati card but for the interest has anyone been able to install fglrx drivers to opensuse 11 (64 bit or 32 bit)?

yes i have it working with 3d support cause they add the repo for ati and opensuse 11

I could install the ATI driver, but could not run effects. Now that the repo is active both run fine.

Add your card here…

HCL/ATI Video Cards - openSUSE

The driver in the repo is the 8.5 Catalyst driver, and should work with most ATI cards that support the “radeonhd” open-source (2D-only, for now) driver (X1K series and HD2000 series), as well as 9600/9700/9800-series cards that normally use the open-source “radeon” driver. I used this driver with 11.0 RC1 and had no driver-related issues with it (what conflicts I had were not related to the driver).

Before the repo was added I tried to get the Catalyst suite working and the best I could do was get it installed, after that I had 3D but my whole system was sluggish. No it works like a charm. What they did, I don’t know, the kernel I expect.

Nice nice. I was worried about ati was left for a while without proper driver. Well wouldn’t be the first time :slight_smile:

Works it with KDE4 enable the Desktop Effects ?
I have a HP COMPAQ 6820S notebook with a ATI Mobility Radeon X1350. No 3D support possible. KDE4 crashes with desktop effects.

Anton vd Haterd

I noticed the files in the ATI repo have changed this morning. There were just 2 yestaday, now I see 4.

Dear developers,

The best way to get the ATI drivers working is to do -all- updates first. Then you need to use a few ATI specific command line tools to get the right X file installed.

update SUSE:

  • open the control panel
  • update SUSE 11.0 from YAST (few update files)**

download ATI driver:

*** start a web browser

  • download ATI driver to /home/<yourhome>/ati-driver-script**

install ATI driver:

  • start a command prompt :frowning:
  • cd home/<yourhome>
  • su root
  • chmod 644 ./ati-driver-script
  • ./ati-driver-script**

With the drivers installed you will notice that the compiz does not function properly. You will also notice that the X control panel does not work together with the driver.

ATI default:

  • start a command prompt :#C
  • su root
  • cd /etc/X11/
  • rm xorg.conf
  • touch xorg.conf
  • aticonfig --initial --input=/etc/X11/xorg.conf
  • check ATI control panel
  • reboot**

This sets the ATI card in factory settings. Until the right X control panel is installed I do not know of another way to get ATI to work. Also check if software GL is installed since it interferes with the ATI hardware GL driver.

Some things that are of interest:

  1. installation from driver CD control applet
  2. click and install and new ATI control panel
  3. new X SUSE control panel for ATI or NVIDIA