OpenSuSE 11 and Xorg update

Hello, i intalled OpenSuSE 11 on my work station with KDE 4 and superkaramba, till yesturday all worked with no problems, but yesturday updater showed that new updates are available, there whas and Xorg update, i installed all updates. Today i arived to work and booted my work station, ws is very veryyyyyy veeerrryyyy slow, if i scrool webpage in FireFox down, then top shows that Xorg cpu usage come up to 82%. So question is, how to roll back older xorg that whas before update ?

Are you sure it’s an Xorg update? Yesterday I made one update from kernel-pae- to kernel-pae- and now Xorg consumes 20-25% CPU. And everything is very slow.

yes there was and kernel updates.

i downgraded kernet to kernel-pae-, but problem persist, so i gues ill try to downgrade to default kernel, and then will report result.

the problem is somewhere else, becouse i downgraded kernel to default ant xorg to default, but problem still exist.

Reinstall your nVidia drivers - if you’re using nVidia.

I have this problem too, with my intel X3100 graphics card.

If you compiled your own driver, then after a kernel update, it needs to be recompiled. You can also install the OpenSUSE 11.0 Nvidia or ATI drivers and walkthrough the 1-Click Installer. It is very easy to do, because YaST will guide you through it step-by-step. Once you install the driver, reboot. When you log back in, open a terminal window and issue the command su. When prompted, enter your root password. Now that you are logged in as root, issue the command init 3. This will drop you to the CLI (Command Line Interface). Now, enter your username and then your password to login, and then issue the su command again. After entering your root password, enter the command sax2 -r. After Sax2 loads and you configure the settings to your liking, press the OK button and then the Save button in the prompt. Once Sax2 closes, issue the exit command to logout of root (or you will be logged in as root when X-Server loads), and then issue the command startx to start the X-Server. Now the graphic desktop will load and should be back to normal.

I had no kernel update (am using default kernel), but did have an xorg update. Graphics card is Intel GMA 965 X3100 using default supplied drivers. System was slower after update.

same here. i’ve reformatted like 3 times assuming it was my own screw up, but on the last try, i checked the response before the update, and after the update, and i can pinpoint that the latest update has got to do with the jerkiness of the entire system

any updates?i can confirm this issue is due to either kernel update or xorg updates. as i just made a clean reformat, and upgraded everything but these 2, and it works fine.

this issue will only affect if compiz is enabled, at least for me.

I using Intel 945G video card, and default drivers, i made no changes and pc worked very good until i downloades and installed updates, so it looks like problem with some updates, and i see that most complaining people here is with intel video cards. So eny sugestions ?

Nubela, i downgraded kernel to default and xorg to default, but problem persist, i cant reinstall my workstation becouse i work on that pc.

YES :cool: performance is back, i downgraded all updated xorg packages and now pc works fine. So now i cant do research but if enyone can downgrade packade xorg video drivers and look then how pc works, if the problem exist then problem cousing some other xorg package.

robbkte: how did you downgrade your xorg packages?

also anyone know why this happens? and yes im using an intel GMA 950, which i think conflicts with the latest Xorg. can someone look into this?

fyi, using an intel 915g and the same thing happened in the same timeframe mentioned here. turning off desktop effects returns the machine to normal speed.

try adding these settings to your xorg.conf in the device section:

  Option       "AddARGBGLXVisuals" "True"
  Option       "XAANoOffscreenPixmaps" "true"
  Option       "DRI"        	"true"	
  Option       "AccelMethod"	"Xaa"	# Xaa old stable, EXA is new and better.

AccelMethod can be Xaa or EXA depending on the chipset…

Hope that helps,

Anyone tried this with an Intel graphics card? Can you confirm if it works?

No offense Magic, but I tried some suggestions like this once before and it borked my system. I believe (no evidence except anecdotal) that the Intel Graphics cards with shared memory are incompatible with the current xorg version and possibly with sax2 — if, desktop effects are turned on or you are using compiz as a window manager.

Before upgrading I suggest that you disable desktop effects and/or change the WM back to KWIN.

my .02

None taken as one should always take care mudding around in the system config files :wink:

If you are unsure first make a backup copy or the current xorg.conf… that way you can always revert by copying back the save keeping copy and rebooting.
The settings are quite safe as sync frequencies etc are not affected. Reverting is as easy as remarking/removing the entries and reloading X (or rebooting).
This file always has a place in my backup scheme…


> Option “AddARGBGLXVisuals” “True”
> Option “XAANoOffscreenPixmaps” “true”
> Option “DRI” “true”
> Option “AccelMethod” “Xaa” # Xaa old stable, EXA is new and better.

For me, It’s Works ! My graphic card is Intel 965 GM