openSUSE 11 and Samba/Ldap as PDC

Hi

Trying to upgrade to SuSE 11.0 (from 10.3), so I’ve built a SuSE 11.0 PDC using Samba/Ldap. I’ve done this in version 9 & 10, and always got it to work.

My WinXP box can join the domain without any problems, but when I try to log in with a domain account I get “Domain is not available”. When adding a domain user to the a local security group I get “Trust relationship Failed”

The problem is exactly the same as this thread: openSUSE 11 and Samba/Ldap as PDC - openSUSE Forums

I’ve tried the suggested fix (upgrading openldap2), but this has not worked for me.

Can anyone offer any advice?

Same issue here. Upgrading openldap didn’t help either.

Upgrading samba from the same repo did help though. Seems to be working fine now.

Hi mate. I’m glad you got your Suse PDC going.

I tried upgrading samba from the repo, but it didn’t work. Could you please post the steps you took to upgrade?

Thanks

I could solve the Samba LDAP PDC problem by updating Samba from,

Index of /repositories/network:/samba:/STABLE/openSUSE_11.0

Samba 3.2.3 has been released as an online update. Please update to this version.