opensuse 11 64-bit + firefox + real + flash

Hi All,

What should one do to get Flash and Real Player to work on Firefox3?

I’ve tried all the ides mentioned in this thread – but none worked.

The problem also seems to extend to Real Player.

I haven’t had any problems running Firefox 3 and java though.

Any help will be much appreciated. Thanks

My experience is that of the last post in the thread you referenced, it just worked for me, using OpenSUSE packages. I didn’t have to get any extra packages or install anything specially. All of Firefox, flash-player and nspluginwrapper packages are from OpenSUSE.

I’ve tried it, but without any success. Can you tell me which repositories you used?


Just accepted the standard ones in the default install. I didn’t choose any special configuration, just a KDE4 desktop. This was a vanilla installation. I didn’t use any of the third party repos until I did a one-click install of “restricted formats”. Flash was already working before then, and inspection of the installed RPMs show that they come from OpenSUSE, not any of the third party repos.

Flash works out of the box. Keep reading of issues with this, but can’t figure it out.

Real Player needs to be installed from the repo’s but that’s it. it just works.

Is Flash listed in your plugins for FF?

I have the KDE 3.5 version of openSUSE 11 installed as I prefer that over KDE 4. (I used the live cd mentioned in this thread)

i’ll enable only the official suse repositories and see if it works.


I’ve got Flash and Real Player working on my machine now. I followed the instruction given here

While installing the nspluginwrapper rpms from the command line, I got a message saying linux32 package was needed. I remember that Yast would not install this.

Installing this seemed to fix things.

Thanks for all the help chaps.

I mentioned one possible solution in this thread. Hope it helps someone.