openSUSE 11.4 Youtube doesn't work, other flash video does


I just install openSUSE 11.4. I also install Flash. I have tried 4 different web browsers, and none of them will display Youtube videos. It just shows a black square where the Youtube should be. It is stranger still, because when I watch a video on Google News which is also an embedded Youtube video, it works fine. Also flash radio (such as BBC radio) works fine. CNN video also works fine. I was using openSUSE 11.3 previously on this same system without any issues. I also tried booting up into VESA mode to rule out Intel driver problems, but it acts the same.

Any suggestions?


On 03/16/2011 08:06 PM, bummmm wrote:
> Any suggestions?

are you behind a proxy, or maybe on a school/business network…free

i’m thinking maybe someone or something has decided to block streaming, maybe…

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

  1. Open a Terminal
  2. Switch to root
  3. If you have an old Flash and nspluginwrapper:
    zypper rm flash-player nspluginwrapper
  4. Get Flash from the adobe Website
  5. Unpack and copy the file here: /usr/lib64/browser-plugins
  6. Restart any Browser and have Fun :stuck_out_tongue: !

Thanks everyone for the reply!

By the way I should have mentioned that I am running 32-bit openSUSE.

So, what I had to do was: delete the ~/.macromedia and ~/.adobe directories, and disable hardware rendering in the Flash configuration settings. It seems to be ok now. I hope.