OpenSuse 11.4 x64 Ardour not starting?

Hi, I recently upgraded from 11.2 to 11.4. All is well with most things except for Ardour, the one program I really wanted to keep using. I had Jack and qjackctl and ardour all working fine in 11.2. I did also install the newest qjackctl(0.3.8-19.2) Jack (1.9.6-5.1) and Ardour (2.8.11-3.20) versions.

Qjack seems to start ok,

“1:49:18.133 Patchbay deactivated.
21:49:18.375 Statistics reset.
21:49:18.390 ALSA connection change.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
21:49:18.413 ALSA connection graph change.
21:49:27.177 JACK is starting…
21:49:27.178 /usr/bin/jackd -P89 -t2000 -dalsa -dhw:0 -r96000 -p1024 -n16
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
21:49:27.201 JACK was started with PID=14219.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 89
Engine profiling activated, beware 247 MBytes are needed to record profiling points…
creating alsa driver … hw:0|hw:0|1024|16|96000|0|0|nomon|swmeter|-|32bit
Using ALSA driver ICE1724 running on card 0 - M Audio Audiophile192 at 0x4000, irq 96
configuring for 96000Hz, period = 1024 frames (10.7 ms), buffer = 16 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 16 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 16 periods for playback
21:49:29.480 JACK connection change.
21:49:29.481 Server configuration saved to “/home/vinoman/.jackdrc”.
21:49:29.482 Statistics reset.
21:49:29.497 Client activated.
21:49:29.508 JACK connection graph change.”

However, when I start Ardour, the little icon bounces for 10 secs or so and goes away with no windows or errors, but does not start. Any ideas? or am I just missing something. I thought I had seen other 11.4 users say they are using Ardour with 11.4 ok.

I just upgraded to 11.4 also, ardour works fine. Could you try running from a terminal and seeing if you get any errors printed there? I think the command name is “ardour2”. If you meant you did that and didn’t get any errors, then the only thing I can think of is trying the binary distributed version off the ardour website, its pretty easy and you should have gotten any dependencies from installing the zypper package. I think it’s maybe a minor version ahead from there, so maybe it’s a bug that got squashed.

I had the same problem once with Ardour on another distribution using KDE. The solution was, to change back the GTK Style (config->application appearance->gtk styles and fonts) from Oxygen-GTK to Raleigh. Then Ardour would start.

Sorry for the late response. Have been busy. I finally tried the command line prompt to start it. Ardour2. Below is the response. Not sure which error is the problem here. Any ideas?
I did try the style change with no help there. Raleigh in there now. Still no go.

"WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with ‘ulimit -l’, and it
is normally controlled by /etc/security/limits.conf

Ardour 2.8.11
(built using 7387 and GCC version 4.5.1 20101208 [gcc-4_5-branch revision 167585])
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/vinoman/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
ardour: [INFO]: Ardour will be limited to 16384 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/vinoman/.ardour2/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
librdf error - Failed to find any Raptor parsers - Raptor may not be initialised correctly
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
librdf error - Failed to find any Raptor serializers - Raptor may not be initialised correctly
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
librdf fatal - rdf_query_rasqal.c:1297:librdf_query_rasqal_constructor: fatal error: failed to initialize rasqal
Aborted"

Yeah I don’t know. That doesn’t mean there isn’t a work around though, I just have no idea what it would be. How is your librdf? Actually I think it’s liblrdf, isn’t it? Oh wait I have a librdf too. Don’t know where that came from. Make sure you have those, maybe something didn’t get updated. Use YAST to check liblrdf, libraptor, libredland0, librasqal2 and make sure those are checked, just search yast for rdf they should all come up.

Also I think that has to do with plugins, you might want to try using the -d option with ardour to disable plugins to see if that works. Probably not acceptable functionality without plugins, but maybe worth a try, the command would be “ardour2 -d” or “ardour2 --disable-plugins”.