OpenSuse 11.4 unable to partition disk

HP 6930 laptop

It had Win7 64bit installed across the whole drive (100MB sys reserved and C: taking up the rest) , I was successfully able to shrink the C: partition to 60GB. So I know have a working copy of Windows 7 on 60GB with 60GB or free space.

I boot to 11.4, the installer works great so far and is real fast, I get to the spot where I choose my partitions for nix(tried both auto and manual) then I click OK at the warning to start writing to the disk and …error 1007, the installer is unable to create the partitions.

Any ideas?

Boot from a live CD, issue the command fdisk -l and post output here. (Any other version or other distro live CD will do it too.)

I figured it out, been making so many dumb mistakes lately. I really need to cut back on the beer:\

Figured that must be the case

Could you tell what you did to solve the problem? I’m getting the same error and cannot see what I can do to fix it. Thanks

From installer try going to the root console CNTRL-ALT-F2 you should see a “#” prompt.
Then “fdisk -l” to list the current partitions, I had a disk drop out due to chipset/disk/driver errors and then it became invisible, though the GUI still showed the information it had collected previously. Checking the error log CNTRL-ALT-F10 could show you something to.

To get back to “WIMPS” mode CNTRL-ALT-F7 for the first graphics (X) console.