OpenSuse 11.4 startup problems

Just a little disappointed. I downloaded the 11.4 Gnome by about midnight, checked the CD for integrity,and started the Live CD, and it worked quite well. Installed it, but troubles started. OpenSuse 11.4 won’t boot up in the normal mode, but would boot up in the safe mode only. I am now writing from the safe mode, but would like to boot up normally. It get stuck after the first verbose page. And not a move from there.

Can anyone help?

The laptop is Lenovo T400, Core2Duo with 4GB RAM, screen 1440x900. No problem with any other distros up to now.

You say it gets stuck
What does it stop at in the verbose?

Can you confirm the graphics device?

Post result of:
/sbin/lspci -nnk

Its like this;
the splash screen comes up once then goes away in a second and then comes up with stuck screen with lot of lines (words, numbers, etc) and no more movement from there, I have to reboot and get into the safe mode, which i am in right now.
This is in the menu.lst

title openSUSE 11.4
root (hd0,10)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-HITACHI_HTS723216L9SA60_090311FC1220NCGPYLXC-part11 resume=/dev/disk/by-id/ata-HITACHI_HTS723216L9SA60_090311FC1220NCGPYLXC-part6 splash=silent quiet showopts vga=0x367
initrd /boot/initrd-

and this is in the safe mode one;

title Failsafe – openSUSE 11.4
root (hd0,10)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-HITACHI_HTS723216L9SA60_090311FC1220NCGPYLXC-part11 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x367
initrd /boot/initrd-

I am trying to think what should I change here…

But the last bit of the verbose may be important in understanding the problem.

And the info I asked for too, is important, as it may inform us of missing drivers.

The boot arguments in failsafe that may help, and you could try adding them individually, to try each one, by editing the boot menu at boot (press ‘e’)
I would try these:

some of those are not in failsafe, but try them

I my case, with the 64bits, I get stuck as soon I click enter. At this point there is nothing we can do I think. The problem is this release that is not stable at all.

Googling for Lenovo T400, brings up this as GPU:
Integrated Intel® GMA 4500 MHD
ATI Switchable business graphics with 256MB
IF I am not mistaken!

That aside, you may wish to try whether adding


to the ‘normal’ bootline fixes your problem. You can do this either when your are Grub bootscreen (works only for that boot), or in YaST’s Bootloader.

Not true
Have you even posted a thread with your system spec to try and work through it?

Thanks both of you! I’ll try what you said.
How do I change the YaST’s Bootloader?

By the way, this is what I see in the screen (and of course lot of lines and words)
[3.117474] BUG: unable to handle kernel paging request at ffffc90415d81ffc (one of the lines)

it sounds like ur problem is likely caused by the kms module
as far as i know, opensuse 11.4 comes with kms enabled by default

failsafe option has nomodeset, which disables it
which prbly explains why u can boot up using failsafe :wink:

try adding nomodset to ur kernel line and see if that solves the problem

You can edit at boot by pressing ‘e’ when on the default boot

or when in failsafe login, use yast
ImageBam - Fast, Free Image Hosting and Photo Sharing

What I meant was to start YaST and use the Bootloader module to make changes to your bootloader, such as adding arguments to the bootline. Of course you can also manually edit menu.lst. Almost the same thing.

ETA: I see caf4926 has pictures.

yast -> bootloader -> select the kernel entry (should be something like opensuse 11.4)

now click edit, and then find the text field where it says Kernel Command Line Setting (or something like that)
add nomodeset to the end of the line

reboot, see if it solves the problem for u

Something strange happened and I am in OpenSuse 11.4 normally!
I hope it will stay like this!
Let me explain;
I tried what you suggested, all 5 ways, together and separately. All I got was a muddled up screen every time. I read somewhere in this forums that someone could boot up with the Live CD in the laptop, so I pushed it in and started the laptop. Voila! It booted up normally! It sees the 1440x900 resolution too

Now, I am at a loss to understand this. Do I have to push the Live CD in every time I start or has the OS corrected itself, or should I download the 32bit version…

It is not really a big matter, if the 64 bit won’t work in my laptop, and if the 32 bit works, I will be quite happy to have it. Any suggestions???

Umm, did u choose boot up from harddrive on prompt screen, or did u boot up from livecd?
if ur in livecd right now, that doesnt rlly help with the situation, as ur system that is installed on the harddrive may still have some porblem


No, I pushed the Live CD in just after the grub2 stage came in. The OpenSuse 11.4 booted up from the hard drive. I tried this thrice now, and it worked that way. I didn’t push the CD once and again it didn’t boot up. Only with the CD in it works and it has to be pushed in just as the Grub2 stage starts.It could be OK for now, but would be annoying, so I am downloading the 32bit Gnome Live CD too (It’d take 3 hours to download.)

Maybe this is a bug of some kind and the developers should know. Anyway, Thanks for helping out to all!

BTW, I installed the system twice too…same problem…

Hi all,

Last night I installed 11.4 KDE with high hopes, turned out to be a complete nightmare!

Checked the md5 & performed the media check, all’s well there.

After installation had completed I rebooted, only to be greated with the openSUSE KDE screen (green & fuzzy) without any icons or windows.

I’m guessing it’s graphics card related, so am wondering how to enable to nVidia repo via bootup.

The failsafe setting showed the same as normal login.

Any help/advice greatly appreciated!


With the Live CD pushed in after the boot splash screen come in, Open Suse 11.4 boots up nicely, and then I can take the CD out. There must be something that asks the Live CD to be there when booting up. Only I can’t find where it is , so I am downloading the Live CD gnome 32 bit. My problem could be a 64 bit one, but I am not going to say no to 11.4!

Having the same problems here installing openSUSE 11.4 KDE 64 bit. Machine is a lenovo t400 with 2gb ram. ATI graphics card.

Adding nomodeset to kernel options didn’t help.

Earlier, the boot screen would freeze and display many lines of text. Now, I just get a screen that has green bands across it. Login seems to be occuring though - I can hear the KDE startup sounds.

Help please. Thanks

Did you try booting to level 3 and start Yast
And nvidia from the community repo list
Boot to Level 3, then Yast and More…

Check these settings too
nVidia Driver via Repo in 11.3 - Guide

I would like to help, but I need to know more as to EXACTLY what ATI graphics. There are dozens of different ATI graphic devices, and the behaviour CAN be different.

Did FailSafe or Safesettings work ?