OpenSuse 11.4: SCPM there, SUMF where? Alternatives?


May I ask for help with the below-described problem.

On my new (hardware + software) laptop, I’d like to have different system profiles, i.e., system settings that change with locations (home, work, road etc.); this is much more than only network connection stuff, this is printer management, mail delivery etc. In OpenSuse 11.2, I used SCPM + SUMF (the graphic interface) which worked great together, could change profiles at boot or later on as (non-root) user.

My system info:

Laptop computer, fresh network install OpenSuse 11.4, the five recommended repositories (OSS/Non-OSS/Update/Packman/libdvdcss), all updates installed, desktop KDE 4.6.0


In Yast - Software - Software Management, did find SCPM package, yet no SUMF. Tried to use Yast Package Search (webpin), yet apparently that does not work (yet) in OpenSuse 11.4, which is bad (but that’s a different story; would you know a solution anyhow?).


Where and how can I find the SUMF package? If system profiles are done differently in OpenSuse 11.4, what do I have to install in order to have system profiles available?

Thanks in advance for your help.


PS: The following you may safely ignore if you like, but I have to blow off some frustration. – “Never change a winning team!” So who then decided to drop SUMF from the distribution? How do these decissions come to pass anyways? I understand that I can expect some hiccups when installing a new Linux version just a couple of days after a new release, driver issues especially on newly purchased hardware, security updates etc. Actually, that wasn’t an issue at all with the OpenSuse 11.4 install, it seems to be a nice release, fast, good installation guidelines incl. for media players on the website, even hibernatio seems to work for me etc. - But I do NOT understand that a package just disappears without proper replacement. I also do NOT understand that a fundamental tool such as webpin (NB, part of Yast) does not work from the start. I lost count of how many packages and tools I found and installed through it in OpenSuse 11.2 from some of the “home” repositories. – Okay, that’s it for now. Thanks for your patience. Maybe this motivates someone to do a great job. Unfortunately, I am not capable of “hacking”.

Where and how can I find the SUMF package?

Here sumf Downloads - Linux Packages Search

and here

The first one isn’t for opensuse 11.4, not sure what version the second one is for, so I went looking around and found something in the opensuse build service for this (I’m also interested in managing different xorg configurations based on whether my laptop is docked or not, etc):

Index of /repositories/home:/lemmy04:/profilemanagement/openSUSE_11.4


Thank you for all your comments. I have now both SCPM and SUMF installed and they seem to work - great!

To summarize:

Since my initial post I learned that the broken webpin (meaning possiblity to search for packages) has a kind of a workaround by searching at Search Results. Supposedly, there is also but at the time of this posting the latter was not responding.