OpenSUSE 11.4 - Plastique or Oxygen?!

I like when my environment looks nice so I don’t understand why is half of system dialogs using Plastique theme and half Oxygen. For example when I run KpackageKit manually, it has Oxygen theme, but when it appears automatically to perform some updates, it has Plastique theme. It’s really ugly. Is it somehow possible to unify it?

You did not indicate if this is in KDE or GNOME. IN KDE you have three things to check (at least):

  1. menu / Personnel Settings / Application Appearance / Style / Widget Style
  2. menu / Personnel Settings / Application Appearance / GTK Styles and Fonts
  3. menu / Personnel Settings / Workplace Appearance / Window Decorations

And there may be others within each application, but you do need to look through the Personnel Settings option in KDE first.

Thank You,

I’m sorry, I didn’t mention that, I’m using KDE.

I tried what you recommended but nothing helped. I actually tried to run systemsettings using kdesu. According to the settings, oxygen is properly set to be used, however the whole root ui (systemsettings, yast, mentiond KpackageKit) is using Plastique. I tried to change the theme to something else but it had no effect - still Plastique not matter what I did.

I’m having the same problem. KDE uses Oxygen, YaST uses Plastique. In openSUSE 11.3, YaST did correctly use the Oxygen theme.

Running “qtconfig” in a terminal as root will let you change this. If you select “desktop settings” it will mimic your current user theme/color settings. You can also change the fonts that yast uses here also.

Awesome :slight_smile: Actually I had to force oxygen style (“desktop settings” didn’t work) but it works like a charm now, thank you!

Strangely it didn’t work the first time with me either. I tried “desktop settings” to clone my qtcurve theme, and it still used plastic for root. The second time I chose qtcurve (which didn’t work the first time), and it correctly cloned the theme to root/yast. Maybe something has changed for KDE 4.6???

I tried the fix. I use QtCurve. Though it will change to the default it will not use my modified Agua2 pattern/theme (check out QtCurve to see what I’m talking about. It seems that things running as root can’ assume the desktop default. Could I put a symlink somewhere to give root programs access to the full modified theme?

Thanks for the tip! It works!