openSuSE 11.4 on Lenovo X220

I wanted to post on HCL, but I’m lacking privilege to edit it. So I hope people who need it will be able to find/google it here.
I would certainly love to know this before getting the laptop.

Laptop: Lenovo Thinkpad x220, Intel i7-2620M, webcam, USB 3.0, 12.5" Premium HD (1366x768-IPS) LED Backlit Display, Intel® HD Graphics 3000, No Fingerprint Reader, Intel Centrino Advanced-N 6205 (2x2 AGN)

  1. Install was flawless including working dual boot with included Win7 Pro 64
    I did SW update during the install which solved one or two glitches later.
    Though on-line update was not necessary to get the laptop working
  2. Both ethernet a wlan works out of the box
  3. Login to KDE works - though KDE eventually crashes on me - disabling Desktop Effects in System Settings solves the crashes (guaranteed)
  4. graphics - The system works and it is usable for common tasks. There are serious performance and driver quality issues mainly related to Flash playback and transparency/overlay functions - at times this makes it unusable, but it does not crash the system with the exception of KDE. Maybe not all API is implemented/working yet.
  5. Sound works out of the box, though it could be louder
  6. Touchpad - its button is useless although it is great to have for pointing. I use track pad buttons instead - they work like mice buttons should including middle button. So … bless Lenovo/IBM for the treackpad
  7. Screen (IPS in my case) is brilliant in terms of viewing angle colour depth/rendering. Out of the box colour calibration/accuracy is not bad. I calibrated mine and I did see slight difference, but not in the colour tome/perception as is common. The resolution could/should be better than a bit arcane 1366x768. I’d recommend this screen definitely.
  8. Boot times:
    320GB,7200rpm,Hitachi - about 1 minute to login screen + additional 1 minute to usable KDE
    300GB,Intel SSD - about 15 seconds to login screen + about 40 seconds to working KDE
    KDE boot time is really bad - probably result of graphics/driver issues mentioned above.
  9. Battery life - ThinkPad Battery 29++ (9 cell) - between 6-9 hours depending on what is running and the screen brightness. I disabled suspend on closed screen (closing screen will power the display panel) and got about 9 hours playing streaming web radio over Wi-Fi using mplayer with closed screen.
  10. Power usage in KDE Power Saving mode:
    [size=]Cn Avg residency P-states (frequencies)
    C0 (cpu running) (13.9%) Turbo Mode 11.6%
    polling 0.0ms ( 0.0%) 1.60 Ghz 0.7%
    C1 mwait 0.4ms ( 4.5%) 1200 Mhz 0.6%
    C2 mwait 0.8ms ( 1.7%) 1000 Mhz 1.0%
    C3 mwait 0.9ms ( 0.5%) 800 Mhz 84.1%
    C4 mwait 2.7ms (79.4%)
    Wakeups-from-idle per second : 454.1 interval: 10.0s
    Power usage (ACPI estimate): 10.9W (11.0 hours)

Top causes for wakeups:
70.5% (727.6) [i915@pci:0000:00:02.0] <interrupt>
9.4% ( 97.4) alsa-sink
9.3% ( 95.8) npviewer.bin
2.6% ( 26.6) [iwlagn] <interrupt>
2.3% ( 23.3) ksysguard
1.9% ( 20.0) knotify4
1.0% ( 10.7) [Rescheduling interrupts] <kernel IPI>
0.5% ( 5.2) kded4
0.3% ( 3.0) kworker/0:0
0.3% ( 2.7) Xorg
0.2% ( 2.5) mysqld
0.2% ( 2.4) plasma-desktop
0.2% ( 2.3) [acpi] <interrupt>
[/size]As you can see CPU is in turbo mode almost for 12% of the time because of lousy graphics driver. This could dramatically improve battery live if addressed.

Overall all, I feel that all good and more or less working. I’m not disappointed. And if Intel improves the driver - I would be over the moon.

I hope it helps, T

On 11. Power usage, 4 gfx and 9. boot times
With suggestion from “oldcpu”, I tried to Ctrl+Alt+F2 & Ctrl+Alt+F7 while waiting for KDE start up. It cut the startup time from over minute to 15 seconds and it reduced time spent in turbo mode from 12% to about 8% this improving battery live by about 2 hours according to powertop.

Strange, but encouraging …

Thanks for posting this thread. My wife spent some time looking at Netbooks on Friday and Saturday this week (with me checking for GNU/Linux compatibility in parallel for each Netbook she considers) and your post was helpful. She is thinking of purchasing the Lenovo X220.

There is also a useful ThinkWiki page here: Category : X220 - ThinkWiki

Did you have success with the webcam ? I’m curious if it is a UVC webcam.

Could you check that by sending these commands:

lsmod | grep uvc

and post here the output ?

I found a Gentoo thread with this for lspci:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family HECI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
0d:00.0 System peripheral: Ricoh Co Ltd Device e823 (rev 04)

of course thats not all that useful. More helpful would be: ’ lspci -nnk ’ , but it typically takes users to be using GNU/Linux a while before they learn that the " nnk " option makes a BIG difference in understanding the PCI hardware.

And also on the same Gentoo link this for lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 004: ID **04f2:b217 Chicony Electronics Co., Ltd** 

I think the 04f2:b217 is the webcam and it is ‘certified’ to work with Ubuntu GNU/Linux (Components for Video | Ubuntu) what ever that means. … I’ve also read a post of a Fedora user who has this working: Laptops running Fedora report - Page 29 - (post#432) .

If this is a UVC webcam (and I’ve read some sites that claim it is) then it is not yet reflected in the Linux UVC driver & tools list of webcams.

But I did stumble across this log file of an Ubuntu GNU/Linux user: New ThinkPad in the Test Lab - Storage Forums - Page 2

16.854047] udev[2755]: starting version 163
   17.260882] Linux video capture interface: v2.00
   17.283735] **uvcvideo: Found UVC 1.00 device Integrated Camera (04f2:b217)**
   17.285927] input: Integrated Camera as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input5
   17.286038] usbcore: **registered new interface driver uvcvideo**
   17.286040] USB Video Class driver (v0.1.0)

and that indicates the UVC driver loading for the webcam ! :slight_smile:

So it appears likely this IS a uvc compatible webcam.

Hello, I have currently just ordered the X220 and I’m curious about the progress you are making, is the X220 running 11.4 without problems? Everything working?

My wife had some hiccups in ordering the Lenovo X220 which have now been sorted. But it won’t be September until she gets the netbook, so it will likely be end September or early October before she allows me to install openSUSE GNU/Linux on it. Dependent on what I read about the SandyBridge graphics and 12.1 milestones, I may just install Tumbleweed-11.4 or openSUSE-12.1 RC version on it instead of 11.4 (where the schedule for 12.1 in that timeframe has):

  • Thu, Sep 22 2011, openSUSE 12.1 Milestone 6
  • Thu, Oct 13 2011, openSUSE 12.1 RC 1
  • Fri, Oct 27 2011, openSUSE 12.1 RC 2
  • Thu, Nov 03 2011, openSUSE 12.1 Goldmaster
  • Fri, Nov 11 2011, openSUSE 12.1 Public Release

I’ve read Sandbridge graphics on GNU/Linux can be a finicky beast, which is why I have not yet decided what openSUSE version to install on the laptop.

I posted my ordering considerations on my blog: Purchase considerations for a new netbook - Blogs - openSUSE Forums

I’m also hoping user tkuchta chimes in with some more of their openSUSE experience on the X220.

There is an openSUSE thread here on Sandybridge hardware: 11.4: Issues with Intel Sandybridge graphics driver - i915 (i7-2620M) and in that thread I noted Phoronix have an article that the 3.1 GNU/Linux kernel is anticipated to have superior Sandybridge support. Now we likely will not see the 3.1 in openSUSE-12.1 but we may see it in Tumbleweed-12.1 and openSUSE-12.2. Phoronix article is here: [Phoronix] Intel Sandy Bridge Speeds Up On Linux 3.1 Kernel]( where Phornoix note:

For the Intel DRM graphics driver in the Linux kernel there is frame-buffer compression clean-ups, high color support, ring frequency scaling, shared LLC support, and hang-check module disabling. Compared to the Linux 3.0 kernel, the driver improvements significantly boost the open-source graphics performance for Intel Sandy Bridge hardware.

I also note improvements in Mesa are anticipated to improve Sandybridge support from this Phoronix article: [Phoronix] Mesa 7.11 Brings Much-Needed Linux Graphics Driver Improvements]( which notes:

  • Mature Intel Sandy Bridge support. The Intel Sandy Bridge (HD 3000) graphics support has been improved a lot since its January launch. Intel SNB graphics are much faster and more stable in Mesa 7.11, as a number of Phoronix articles have shown in recent months.

… however that is earmarked for Mesa-7.11 and even though just released, I am skeptical that will make openSUSE-12.1 and we may need to wait for openSUSE-12.2. Because of the potential impact of a Mesa update on Tumbleweed, I would be a bit skeptical if we see Tumbleweed-12.1 having a different Mesa version than openSUSE-12.1.

Will be getting a Thinkpad X220 and found this thread.

One question***, the X220 is using Intel HD Graphics 3000,
Will openSUSE 11.4 automatically get the best driver for the job or do you have to manually select the correct package (like in Nvidia)?

There is no proprietary driver to install ‘like’ nVidia and AMD/ATI. There is some practical graphic card theory that I put together on Intel graphics and openSUSE here: openSUSE Graphic Card Practical Theory Guide for Users

openSUSE will automatically come with the xorg-x11-driver-video rpm that has a recent Intel tarball with the latest open source graphic driver for intel inside. However for best graphic performance, one also typically needs the latest Mesa, which may need the latest X and a very recent kernel. openSUSE may not come with the latest Mesa nor the latest X which may mean one may not have the best graphical performance on openSUSE for the Sandybridge HD 3000 graphic hardware in a Thinkpad X220.

The question as to what Mesa version would be included in openSUSE-12.1 (which is under milestone development) was raised on the factory mailing list, and thus far it appears to be a bit tight and problematic for that Mesa version to make it in openSUSE-12.1. Updating to the the latest X and latest Mesa in openSUSE-11.4 is difficult for an average user to accomplish successfully, with there being a significant risk that that average user may break their system in doing any such update. Its also not the sort of update that would be easily part of Tumbleweed due to the large possibility of significant system graphics breakage in any such update.

To a large extent the above is all IMHO.

Hi there,

just wanted a bit of info on my experience with x220 here.
I got a Lenovo Thinkpad x220, Intel i7-2620M, webcam, USB 3.0, 12.5" Premium HD (1366x768-IPS) LED Backlit Display, Intel® HD Graphics 3000, With Fingerprint Reader and Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01) Wi-Fi adapter.

On a vanilla Suse 11.4 wifi didn’t work and KDE4 graphics had glitches (like random transparent regions or stripes here and there). After I’ve update to Thumbleweed everything started to work as intended, except the Wi-Fi which was unreasonably slow. I had to compile and install latest driver from Realtek site (Realtek). After doing this wi-fi started to work perfectly well.

Oh, after some additional testing it turned out that wi-fi speed drops down drastically after some time. Just after reboot it’s totally o.k., but after some load on wi-fi ti goes down to approximately 1MBit/second. For example if I go to and start the download, first several seconds it goes on 20Mbit/second and then drops to 1Mbit/s permanently. Any help appreciated.

My wife picked up a Lenovo Thinkpad x200 while on vacation (shipped to my sister’s place), but in our case (at my suggestion) she ordered one with an Intel Centrino Advanced N-6205 AGN wireless. I have not yet installed openSUSE on it (my wife is still struggling a bit with tuning Windows 7 on it so she does not want to let me use it yet until she is happy with all her Windows7 apps (this could take a while)). When I get the chance I’ll try openSUSE with wireless on it. Although from what I have read, the Intel Centrino Advanced N-6205 AGN wireless should work well.

When I search the Think wiki for the X220 the Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01) Wi-Fi adapter is not mentioned as an X220 option. I also searched the Lenovo Canada site and the RTL8188CE is not an option for new Lenovo X220s.

I then searched the Thinkwiki site for the 10ec:8176 and found some information on it. That site suggested that the RTL8188CE is only on the ThinkPad Edge 13 series of Thinkpads and it needs the 2.6.38 kernel (which explains why you needed Tumbleweed).

It does appear to me that your X220 is unusual in its configuration.

Is yours an early or late model version of the X220 ? Is the ThinkWiki site not up to date ? Or do you have a ThinkPad Edge 13 ?

I definitely have x220 as a label below screen says that. I think the ThinkWiki just lack the info. Here is the driver page on lenovo support site (ThinkPad 1x1 11b/g/n Wireless LAN PCI Express Half Mini Card Adapter for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP - ThinkPad). It turns out that ThinkPad Wirelest LAN is in fact a Realtek adapter. I’ve even tried the windows driver with ndiswrapper, no luck here (driver install successfully, but ndiswrapper is unable to start wifi then).

I’m more then sure that Intel based wi-fi would work flawlessly, never had problems with those. Still need a solution for the Realtek **** :frowning: I guess it’s a driver issue?

Tested it on 12.1 Milestone 5 Live USB. The issue is there. Filed a bug here

I believe this is the bug report you filed:

Does this happen only when using battery, or does it happen when also using a wired/plug-in electrical connection ?

Oh, thank you for the correction. Indeed the report is here

It happens regardless of connection type, I’ve tried both battery only and plug-in electrical connection.

Another flaw I’ve noticed is that I can’t get bluetooth mice working. They pair and connect just fine and appear in list of connected devices, but cursor doesn’t move for some reason. Here is dmesg output I get when mice are getting connected:

5440.310392] input: Razer Orochi as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/bluetooth/hci0/hci0:11/input24
5440.310898] generic-bluetooth 0005:1532:0014.000C: input,hidraw2: BLUETOOTH HID v5.01 Mouse [Razer Orochi] on CC:AF:78:EA:D3:A1
5445.797385] input: Bluetooth Laser Travel Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/bluetooth/hci0/hci0:12/input25
5445.797479] generic-bluetooth 0005:046D:B008.000D: input,hidraw3: BLUETOOTH HID v3.14 Mouse [Bluetooth Laser Travel Mouse] on CC:AF:78:EA:D3:A1

I experienced a similar (same?) problem. I had a cheapish bluetooth mouse that suddenly stopped responding and I just assumed it had given up on me and settled for the using the Trackpoint for the time being. However, I recently bought a new Thinkpad Bluetooth Laser mouse and that one did not work either. It paired and connected perfectly but did nothing. I tried it on a friends Mac book and the mouse came to life.

After finding nothing in error logs (or anywhere) I went back to 11.4 (from Tumbleweed) i.e. went to kernel 2.6.37 from 3.0.4 and now Bluetooth is flawless again.

System: Lenovo Thinkpad X61s