openSUSE 11.4 on Dell Inspiron DUO

Hey all… Im looking at getting a Dell Inspiron DUO convertible laptop/tablet. I really dislike Windows products but I think Dell has something good going on with the whole convertible thing… anyone put 11.4 on the new DUO? Does all the functions within the DUO operate?

I would appreciate your help before I make the purchase…


I would like to find that out as well.

So did any of you get this thing to work with OpenSuse. I am also considering a purchase. Even though I really don’t like the idea of paying another unused MS license.

Ok, well I have 12.1 running on my Dell Inspiron (1090) Duo, most things are working after a little research. Right out of the install most things worked in netbook mode. The touch pad works, sound works. blue tooth works, wifi works, screen resolution is 1366 x 768 as it should be. Mine is setup to dual boot between Win-7 and openSuSe 12.1 64 bit. I shrunk the Win-7 partition and gave linux about 120 gig which is way more than I needed. The install was from external DVD drive and I put almost all of the distribution on, I just left the games off. I have both Gnome and KDE installed and am currently using the KDE Plasma Netbook interface which I really like.

Things that are not working quite right are:
Accelerometer / Magnatometer for auto screen rotation
On screen keyboard, it works but I am not satisfied with it yet.

Everything else is working, at least what I have used is working.

There is an issue with crashing linux if you plug in the power supply or place it in the sound dock while linux is running. This problem seems to exist in other versions of linux as well, I hope to be able to isolate the problem or find out that it is a hardware issue that can be fixed by Dell.

I will try to post more as I work out the final configuration.

how did you get the touch calibrated i have 12.1 just in gnome and my touch screen is inverted when i touch top it goes to the bottom etc i tried calibrating it and writing changes to xorg.conf.d 52-egalax…conf but no change still inverted

Ok this is an easy fix I think. I installed the eGTouch driver after downloading it from the eGalax site. By editing the /etc/eGTouchd.ini file and setting direction to 2 it corrected the problem with the Y axis being inverted. That is the only change I made to the original configuration file.

John G.

thanks man worked like a charm now my suse works 100%