openSUSE 11.4 on Acer Aspire One D255E netbook; any issues?

Hi all

I am intending to wipe the preinstalled OS on a new Acer Aspire One D255E and install openSUSE 11.4.

The question is: are there any difficulties to be expected during this installation process from external (USB) DVD?

I remember that there was some guidance material available on the opensuse website back in the old times when 11.1 was current, but that is gone now. Does this mean: no problems at all?

On 06/16/2011 02:06 PM, vodoo wrote:
> Does this mean: no problems at all?

i put openSUSE 11.4, 32 bit, KDE4 on this Acer Aspire One D255 about a
month ago…using a md5sum checked DVD in the absolute cheapest USB DVD
player/burner in the shop (LiteOn brand)…

the only ‘problem’ i had/have is i’ve not yet gotten the mic (internal
or external) to work (but, so far i’ve only spent about 45 seconds
“fixing it”)

just worked items included: webcam, wireless, chrome, ff, thunderbird,
ethernet>ADSL/DCHP>internet, multimedia (flash, java, codecs, etc), all
the Fn keys, including ability to have netbook AND external monitor OR
either alone…OH Fn+F3 turns off wireless great, but won’t turn it
back on!..lid close = sleep works, and it wakes up nice and quickly
with a short power button push…

skype works to chat, and i can hear the test call, but i can’t talk

don’t know what the E at the end of your D255 might bring!

i’m REAL happy with mine…


Thanks a lot. So I go ahead. The remaining lifetime of that other OS on the hard disk is at most 5 minutes now.

Replying to myself here …

I am absolutely impressed. Installation of openSUSE 11.4 i586 went smooth on the Acer Aspire One D255E; not the slightest glitch so far. Hardware was auto-detected and all laptop extensions included automagically. I have not yet been into the finer details of configuration, but there is - at first glance - a working system “out of the box”. SUSE rocks!

If I can help with getting the mic to work, please just post and ask and I’ll do my best to help.

On 06/16/2011 05:06 PM, oldcpu wrote:
> If I can help with getting the mic to work, please just post and ask and
> I’ll do my best to help.

thanks…i already knew you would ('cause you are a naturally nice guy)…

when i find a round-to-it with sufficient patience attached, i intend to
read your existing helpful posts on the subject and see if i can’t learn
something as you fix it without being asked again

i will try to stop short of murdering my system


On 06/16/2011 05:06 PM, vodoo wrote:
> a working system “out of the box”. SUSE rocks!

and, i suggest you give this a try:

it makes my machine run cooler and quieter…

try it…i’ve been running it for about a week now, and guess you
might notice a very slight hesitation sometime, but if you turn off
desktop effects that will more than make up the difference, AND you get
more battery life and less fan noise/heat!!



Hi, I did and it works perfectly.

No need CD/DVD for installation.

Use SUSE Studio Imagewriter to write your distro on a USB stick.

Then to optimize power autonomy use powertop! (I get approx 7 hrs with a 6 cell battery)

On 06/16/2011 05:06 PM, oldcpu wrote:
> If I can help with getting the mic to work, please just post and ask and
> I’ll do my best to help.

[SOLVED] it was simple–in Skype i went Options > Sound Devices and saw
three topics / selections:

Microphone / Default device (default)
Speakers / Default device (default)
Ringing / Default device (default)

i looked at the offerings for the microphone: four were very obviously
for speakers and the others:

  1. “HDA Intel, ALC272X Analog Default Audio Device (Default:CARD=Intel)”
  2. "HDA Intel, ALC272X Analog (hw:0.0)
  3. “HDMI (unknown)”

selected the first, and the test call had no audio out…
selected the second, and it worked great!!

my acer is 100% ready out of the box with almost no user intervention
(type in wireless password and flip to the correct mic entry–done!)


An addition to an old thread to record my experience. First, thanks to DenverD for solving my Skype microphone problem.

I installed openSUSE 11.4 on an Acer Aspire One D250. It uses the Broadcom B4312 wireless chipset, with the b43 kernel module as driver. After I remembered to installed the firmware, it worked immediately, but wouldn’t reconnect after sleep or hibernate. My solution, after several false leads, is to force reload of the b43 module using pm-utils.

To do this, create (as root) a file


(It may require a reboot to make this effective.)