openSUSE 11.4 no X

Dear people,

I just installed OpenSUSE 11.4 x64. After installing yast2-online-update-configuration and the updates, I just rebooted to be sure I wouldn’t get in trouble. First I boot ubuntu, because I didn’t want openSUSE to install a bootloader. In ubuntu I gave the command: sudo update-grub. There are now two entries in my grub. Only the first one works, so I started it up. I see a long list of code appear in the wrong resolution. It flies by with such a high speed, I can not do anything with it. Two seconds later I get code in the right resolution (1920 * 1200). Then it asks me to login. I do so. No X? Well, I’ll just enter startx. Result: error :frowning: (see picture).


works, but I hate it to be in the account of Root. When I log out, I come back into the console.](

P.S. the Root’s X doesn’t have internet.

i think that i know the solution but i am not sure…

go to ur grub console and then type

find /boot/grub/menu.lst
//the find command will give u ur root partition

There’s no menu.lst, because I didn’t install GRUB.

XXXXX@XXXXX-XXXXXX:/media/openSUSE/boot$ cd grub/
XXXX@XXXXX-XXXXXX:/media/openSUSE/boot/grub$ ls -l
totaal 200
-rw-r--r-- 1 root root   8608 2011-02-19 04:46 e2fs_stage1_5
-rw-r--r-- 1 root root   7872 2011-02-19 04:46 fat_stage1_5
-rw-r--r-- 1 root root   7136 2011-02-19 04:46 ffs_stage1_5
-rw-r--r-- 1 root root   7136 2011-02-19 04:46 iso9660_stage1_5
-rw-r--r-- 1 root root   8576 2011-02-19 04:46 jfs_stage1_5
-rw-r--r-- 1 root root   7296 2011-02-19 04:46 minix_stage1_5
-rw-r--r-- 1 root root   9632 2011-02-19 04:46 reiserfs_stage1_5
-rw-r--r-- 1 root root    512 2011-02-19 04:46 stage1
-rw-r--r-- 1 root root 102026 2011-03-02 12:42 stage2
-rw-r--r-- 1 root root   7456 2011-02-19 04:46 ufs2_stage1_5
-rw-r--r-- 1 root root   6688 2011-02-19 04:46 vstafs_stage1_5
-rw-r--r-- 1 root root   9288 2011-02-19 04:46 xfs_stage1_5

I am having a similar problem after upgrading from 11.3 to 11.4 with zypper dup. The error message is identical, though in my case the console has the green-themed openSUSE background.

I found some instructions with google, and tried out the tips given in this mailing list. That allows me to use “startx” with non-root user, but still won’t enable the login manager. This is a multi-user computer, so the login manager is really needed.

I would be grateful for any advice on the issue.

I was able to get the login screen by killing the currently running kdm and running it again as su. The login screen doesn’t show any user icons except for root, but I can log in with all users just fine.

The missing user list in the login screen was just due to misconfiguration in login screen settings. However, I still have to kill and re-run kdm if I reboot the computer.

Reïnstalled openSUSE, this time with grub. It works. But I don’t have a login screen nor a fast network connection. I’ve got Gigabit, but KDE updates with 1,01kB/s, to slow for me…

I too have this issue. Few days back simillar problem occured but after rebooting twise things went on fine. Now after updating system it refuses to start x. My problem is exactly same as posted in post 1.

Any help is appriciated.

you have to use

init 5

there’s no startx as of 11.4

now does anyone know how to get from grub to opensuse console login. i have no gdm. and i need to get to console login to fix it. but how from grub only. tried adding “3” to boot options…doesn’t work. any ideas will be gladly attempted!

Just type a 3 and then enter