[opensuse 11.4] no more /var/log/messages

Greetings !!

Since I tried to install an application to handle my ipod under linux (that implied installation of many libs) I got many issues (applications that won’t launch anymore)
I removed the last applications/libs using rpm -qa --last and strictly removed those installed the interval I tried to install this ipod application (3rd party, from source code)

As many applications (not so many but they were useful for me) won’t launch anymore I was searching for messages in /var/log → in the var/log/messages files the last message sent was for 22 feb 4:07 am (since I rebooted many times and did things with my system).

So the problem is: there is no more logs in /var/log/messages some other logs are still updated (http://susepaste.org/66878478).
I set my /etc/sysconfig to use syslog-ng to log.

I checked the syslog-ng.conf file and remembered I disabled the redirection of logs on console 10

# Most warning and errors on tty10 and on the xconsole pipe:
#destination console  { file("/dev/tty10"    suppress(30) owner(-1) group(-1) perm(-1)); };
#log { source(src); source(chroots); filter(f_console); destination(console); };

#destination xconsole { pipe("/dev/xconsole" suppress(30) owner(-1) group(-1) perm(-1)); };
#log { source(src); source(chroots); filter(f_console); destination(xconsole); };

but this directive is still enabled

# All messages except iptables and the facilities news and mail:
destination messages { file("/var/log/messages" suppress(30) owner(-1) group(-1) perm(-1)); };
log { source(src); source(chroots); filter(f_messages); destination(messages); };

…so I expect the messages telling something is going wrong to be added to /var/log/messages

Is the syslog service actually enabled?

chkconfig syslog
chkconfig earlysyslog

Is syslog-ng actually installed? Maybe you removed it by accident?
But I guess another syslog implementation would be pulled in automatically in that case, which should write to /var/log/messages as well.

You’re right, I changed the sysconfig to use rsyslog and now I got writes in /var/log/messages.

[root]antares:/var/log # more /etc/sysconfig/syslog | grep SYSLOG_DAEMON

[root]antares:/var/log # chkconfig -l | grep syslog
earlysyslog               0:off  1:off  2:on   3:on   4:off  5:on   6:off
syslog                    0:off  1:off  2:on   3:on   4:off  5:on   6:off

I just wonder why syslog-ng stopped suddenly to log…

You can’t install rsyslog and syslog-ng (or any other syslog implementation) at the same time as they conflict. (at 13.1 at least, not sure if that was the case already in 11.4 but I think so)
I’m pretty sure therefore that syslog-ng is not installed at all (the config files stay even when you uninstall it) and that’s why it doesn’t work. :wink:

So just install syslog-ng in YaST (rsyslog should be removed automatically then) and it should work.
Or use zypper:

sudo zypper in syslog-ng