opensuse-11.4 milestone6 unofficial comments thread

So it appears openSUSE-11.4 milestone6 will be build 1034.

I downloaded and burned the 64-bit version of openSUSE-11.4 M6 (build 1034) KDE-4.4.4 iso file for a liveCD, and burned it to a CD and then booted my 64-bit Intel P8400 w/4GB RAM (64-bit Dell Studio 1537 Laptop), w/ATI Radeon 3450HD graphics [age ~2+ years].

Strangely enough, it took 3 attempts to boot the liveCD. The first 2 attempts the laptop kept ejecting the liveCD, but on the 3rd attempt it booted ok.

I obtained a strange error upon the KDE desktop coming up. I assume it is specific to being unable to write to a directory on the liveCD, but it was most bizarre to me as to why it would want to do this. Note the error:
http://thumbnails26.imagebam.com/11700/f0aaf3116997669.jpg](http://www.imagebam.com/image/f0aaf3116997669)
[click on the above for larger image]

Wireless worked with an Intel WiFi Link 5300 AGN (but I was careful to use kwallet having learned there are hiccups if one ignores kwallet).

04:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
        Subsystem: Intel Corporation Device [8086:1121]
        Kernel driver in use: iwlagn

Sound worked with output of /sbin/alsa-info.sh script here noting this laptop has a IDT 92HD73C1X5 hardware audio codec.

The Radeon graphic driver worked well (and special desktop effects worked with the cube rotation … etc …)

Internet worked (I’m typing from this laptop now).

To get flash player working on this liveCD I had to install flash-player into ram which meant the download of a couple dozen packages ! Presumably an indication that this is indeed still ONLY a milestone release.

I need to do some more testing, but this far it seems to work.

Here is the ‘sysinfo’ from this boot:
http://thumbnails28.imagebam.com/11700/700aa4116997673.jpg](http://www.imagebam.com/image/700aa4116997673)
[click on the above for larger image]

I too have downloaded the KDE x64 iso and burned the Live CD. On booting everything seemed to work well on a Toshiba Equium L40-156. I shall now install to the hard disk and overwrite 11.2 while keeping 11.3. So far well done all.

Downloaded and installed the KDE 64-bit live disk and installed to Virtualbox. All seems smooth so far.

It should probably be noted that one of the issues listed in most annoying bugs for Milestone 6 is that the DVDs are too big to burn.

Do you get a lot of fan noise with the open source ati driver? I love the performance it gives with 11.3, but the fan almost drowns out the TV. You can’t even hear he fan with the fglrx driver.

Indeed, and the work around “use NET iso” is not especially appealing for those of us who dislike using NET iso ! :frowning:

Most the time, no fan noise. But on occasion the fan would switch ON high (fairly loud) for a handful of seconds, and then lower itself to a lower setting that was not noticeable.

I can honestly say the small amount of noise on my Dell was not annoying.

Thanks for the info. I had read that the 2.6.37 kernel had more power management support for the radeon driver. This sounds encouraging. My Dell Studio’s fan was unbearable with 11.3 and the 4570HD Radeon. I’ll grab the M6 iso tomorrow and try it.

Downloaded 11.4-M6, build 1034-i586 yesterday.
md5sum check: ok, burn+verify (using K3b): ok
boot from dvd, check installation media: ok.
But… on installation, at the “expert partitioner” page - needed because I want to specify which partition to install into, there is a problem.
When I select by right-clicking one of the partitions and select “Edit” nothing happens. That is, I cannot uncheck the “Format” box, nor change anything else. On other installs there never was a problem. Have I regressed to total-noob or has something been changed or (maybe) is this a bug?
But it is fun, regardless.

It may be a bug. Here is the link with guidance as to how to raise bug reports: openSUSE:Submitting bug reports - openSUSE

I tried 1034 and 1035, both gnome 32 bit live cd’s

Both install OK, but there is a icon problem:
SUSE Paste

Yes, noticed the icon problem… currently the three year old is on pbskids.org on the netbook… need to boot him off and investigate some more, but am trying sort of concentrating on unity :wink:

I downloaded the 32-bit openSUSE-11.4 M6 KDE-4.4.4 liveCD (build 1034) and booted my sandbox PC to that liveCD, where my sandbox PC is a :

  • 32-bit AMD Athlon-1100
    w/1GB RAM (MSI KT3 Ultra motherboard) w/AGP nVidia GeForce FX5200 graphics [age ~10-years] with an atheros wireless

The PC booted to the nouveau driver to a 1440x900 resolution, as opposed to the anticipated 1920x1200 resolution this graphic card/monitor is capable of. Still, that is superior to the nv driver’s 1024x768 resolution which has a bug for this FX5200 graphic card (where that bug was announced NOT to be fixed). I plan to later reboot this PC to the 32-bit 11.4 M6 DVD and install LXDE, and then install the proprietary nVidia graphic driver, so I’m not particularly bothered by this 1440 x 900 resolution.

Sound worked after I went to YaST, chose the correct sound card, and activated it (this PC has more than one sound device).

Wireless with KDE was actually easy to setup , as long as I remembered to use kwallet. My wireless details on this PC:


00:0a.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
        Subsystem: D-Link System Inc AirPlus DWL-G520 Wireless PCI Adapter (rev. B) [1186:3a13]
        Kernel driver in use: ath5k

Internet worked.

Graphic card details on this PC:


01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
        Kernel driver in use: nouveau

and output of alsa-info.sh audio script from this PC : http://www.alsa-project.org/db/?f=d1c5a761176d460a456801d0499f151bd8b2d655

and finally “Mycomputer” from KDE desktop:
http://thumbnails34.imagebam.com/11714/642fa8117130497.jpg](http://www.imagebam.com/image/642fa8117130497)

I eventually (either tonight or tomorrow) plan to install 32-bit 11.4 M6 LXDE on this PC.

I installed the 32-bit openSUSE-11.4 Milestone-6 DVD (Build-1034) LXDE destkop to our Linux Users Group (LUG) NC4010 laptop.

This laptop is a relatively ancient HP Compaq NC4010 notebook, with 1.6 GHz CPU (Intel Pentium M Processor 725), 500MB RAM and 4xAGP Radeon IGP 350M [1002:4337] graphic hardware. It has a 12.1-inch TFT XGA display, where the specs note it is capable up to 1024x768.

When installing I obtained an error message indicating the /dev/sda1 (NTFS for winXP) partition could not be mounted at this point:
http://thumbnails32.imagebam.com/11715/719eab117145649.jpg](http://www.imagebam.com/image/719eab117145649)
[click on image for larger view]

with this error:
http://thumbnails15.imagebam.com/11715/291a15117145651.jpg](http://www.imagebam.com/image/291a15117145651)
[click on image for larger view]

Ultimately that mean the winXP was not in the grub boot menu, nor mounted in the fstab. Neither was a problem, as it was easy after the install was complete, to go to YaST to add the /dev/sda1 back to the fstab, and it was easy with YaST to add a winXP entry back into grub (I have other PCs in the house which provide a good example as to what to put in the yast boot gui config menu). But I think that might stump some new users.

Another error was about 25% into the install being asked to insert the CD !! I note I was installing from an external DVD read/writer which might be causing the problem (an HP/compaq 049f:0081) External MultiBay Series PPE001. I obtained the error at this point:
http://thumbnails15.imagebam.com/11715/970da7117145655.jpg](http://www.imagebam.com/image/970da7117145655)
[click on image for larger view]

With this error message:
http://thumbnails26.imagebam.com/11715/ca1f83117145662.jpg](http://www.imagebam.com/image/ca1f83117145662)
[click on image for larger view]

I worked around it before by pressing <CTL><ALT F2> then <CTL><ALT><F1> and typing “df -Th”, “fdisk -l” and then <CTRL><ALT><F7> followed by selecting EJECT, re-inserting the DVD, and then again <CTL><ALT F2> then <CTL><ALT><F1> and typing “df -Th”, “fdisk -l” after which RETRY finally worked, and the install continued. Again, that might stump/block some new users.

After the install the PC booted with the radeon driver to a 1024x768 resolution. Wifi with the “atheros” hardware (and ath5k driver) worked.

Some hardware details:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon IGP 330M/340M/350M [1002:4337]
	Subsystem: Compaq Computer Corporation Device [0e11:005a]
	Kernel driver in use: radeon

00:09.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
	Subsystem: Compaq Computer Corporation Device [0e11:00e6]
	Kernel driver in use: ath5k

Sound worked. Here is output of /usr/sbin/alsa-info.sh script:
http://www.alsa-project.org/db/?f=5e130a965b6a8ea1bef8ede8b493e3b960918243

LXDE runs nice and reasonably fast on this rather ancient laptop. Its not my laptop PC (it belongs to our user group) but if it was, I would be very happy to continue working with this LXDE desktop on this laptop. Very nice.

Just finished installing openSUSE 11.4 64-bit Milestone 6 KDE on my Desktop (Intel Core 2 Duo E6750 2.66GHz, 8GB RAM, NVIDIA GTX 260) on my second Hard Drive (Old 160GB SATA drive). I was happy to see that Desktop Effects in KDE worked OOTB without having to install the NVIDIA closed source drivers.

I installed the 32-bit openSUSE-11.4 M6 LXDE desktop from the 32-bit DVD on my sandbox PC (which I referred to in post#12 above). Yes, this DVD burns fine ! Its only the 64-bit that is too large.

PC details:

  • **32-bit AMD Athlon-1100 **
    w/1GB RAM (MSI KT3 Ultra motherboard) w/AGP nVidia GeForce FX5200 graphics [age ~10-years] with an atheros wireless

Graphics

The PC booted to the ‘nouveau’ driver to a 1440x900 resolution (which is not the 1920 x 1200 resolution this graphic-card/monitor combination is capable of displaying). xrandr had 1440x900 as the top resolution. But I note from previous openSUSE (and other distro) tests that with the ‘nv’ driver, 1024x768 is the top resolution one can get with the ‘nv’ driver with this graphic-card/monitor combination due to a ‘nv driver’ bug:

The graphic card is:

01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
	Kernel driver in use: nvidia 

I note “PRINT SCREEN” key did NOT work with the nouvea driver in use (ie the application mtPaint did nto run). Later when I switched to the proprietary nVidia graphic driver the ‘PRINT SCREEN’ key DID work (launching the application mtPaint for a screen capture). So there is a minor bug there.

As noted I installed the proprietary nVidia 173.14.28 graphic driver ‘the hardway’ (which is not hard) and it worked ok. It did give me one error while building “exceeded threshold - WARNING: Number of errors: 1, skipped probes: 0” but the driver still worked. The default resolution with the proprietary nVidia graphic driver was 1600x1200 (still short of the 1920x1200 possible). xrandr indicated a problem with ‘gamma’ :


oldcpu@stonehenge02:~> xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
   1600x1200      50.0* 
   1440x900       51.0  
   1400x1050      52.0  
   1280x1024      53.0  
   1280x960       54.0  
   1280x800       55.0  
   1024x768       56.0  
   800x600        57.0     58.0  
   640x512        59.0  
   640x480        60.0     61.0  
   512x384        62.0  
   400x300        63.0  
   320x240        64.0 

**Wireless **

Wired ethernet/internet ‘just worked’. I did NOT try to configure the wireless during the install, so after the install, by going into YaST > Network Devices > Network Settings and under ‘global options’ selecting ‘user controlled with network manager’ I note network manager than was launched and it was a trivial matter to setup the wireless network. This PC has an atheros wireless:


00:0a.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
	Subsystem: D-Link System Inc AirPlus DWL-G520 Wireless PCI Adapter (rev. B) [1186:3a13]
	Kernel driver in use: ath5k

**Sound **

Sound worked, although this PC does have two sound devices (motherboard sound and a soundblaster compatible card). I use the motherboard sound and the openSUSE installer instead automatically configured the sound blaster PCI card (makes sense to pick that) so I had to go to YaST and reconfigure to use the motherboard sound device. Details as to the PC’s sound hardware/software configuration: http://www.alsa-project.org/db/?f=8a9b60abc063fcf81b838e780e53fd075a7a64d1

I do note that sound did not initially work in Firefox, even though test sound worked in YaST.

I noted in the mixer that the correct control for volume (in my case) is nominally “VIA 8233A (Alsa mixer)” which is the YaST control.
But to get sound working in Firefox I had to select “Playback: Internal Audio Analog Stereo (PulseAudioMixer)” :
http://thumbnails30.imagebam.com/11720/f0d9ee117190450.jpg](http://www.imagebam.com/image/f0d9ee117190450)

which gave this dialog, where I had to unmute the Master volume and raise the volume bars.
http://thumbnails14.imagebam.com/11720/986e39117190458.jpg](ImageBam)

So it appears that Pulse Audio by default had this audio setting muted.

**Desktop **

A minor ‘bug’ in the LXDE desktop : The icon “application launchbar” in the panel would not resize when other icons were resized.
http://thumbnails20.imagebam.com/11720/78ca16117190465.jpg](http://www.imagebam.com/image/78ca16117190465)

**Misc … **

Thus far the LXDE desktop works well. Subjectively speaking, LXDE is very fast on this PC, which is nice :slight_smile:

As a quck test (briefly when my wife was away at work) I booted my wife’s PC to the 64-bit openSUSE-11.4 M6 KDE4 liveCD. Her PC specs:

  • 64-bit Core i7-860
    w/6GB RAM (Asus P7H55-M, H55 motherboard) w/GeForce G210 graphics [age ~2 months].

The PC booted ok to the liveCD KDE4 desktop.

**Graphics **

It booted to the nouveau driver to 1280x1024 (which is all that my wife’s older 19" TFT monitor supports). Details:


01:00.0 VGA compatible controller [0300]: nVidia Corporation GT218 [GeForce 210] [10de:0a65] (rev a2)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8334]
        Kernel driver in use: nouveau 

**Sound **

Sound worked immediately (start up sound heard). Sound in firefox also immediately worked.

Details on the sound configuration with 11.4 M6 on her PC: http://www.alsa-project.org/db/?f=08111825fc2f6ff474d84e66a4d0914fe5f819bd

ethernet

Wired Ethernet ‘just worked’ (she does not have a wireless in this desktop) and I’m typing this from her PC now. Her wired ethernet hardware details:


02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8432]
        Kernel driver in use: r8169

**Misc **

Overall, the basic functionaly of the KDE desktop (that I briefly tested) ran well. This KDE4 liveCD was much smoother (on this new hardware) than the very mild glitches I noted on the PCs with older 32-bit hardware, and I am now wondering if this might be the advanced sign of a trend to be repeated over the upcoming years, where 64-bit will be more smooth/superior to 32-bit.

The ‘sysinfo’ from her PC with 11.4 M6:
http://thumbnails37.imagebam.com/11720/6f9359117199783.jpg](http://www.imagebam.com/image/6f9359117199783)

I raised bug report Access Denied

I raised bug report: Access Denied

My experience running the KDE live CD, so far:

On the desktop, which uses an NVIDIA GeForce 6150SE chipset, the screen in X windows is completely garbled and unreadable unless I use the “nomodeset vga=79x” (in my case, vga=795) kernel parameters at startup. The system still uses the nouveau driver for X.

On my old laptop, with a Broadcom BCM43xx wireless chipset, which isn’t supported by the kernel (why not? newer Linux kernels now support it), using “modprobe ndiswrapper” crashes the machine to hardware reset.

Regarding the error message about the permissions for the ~/.local/share directory, change the directory’s permissions and you won’t get the error message any longer.

I first booted, then installed, 11.4 M6 (x64 KDE) on the sandbox/testing setup (Celeron DC E1200, 3 GB RAM, AMD HD5450 PCIe) which previously dual-booted 7 x64 and 11.4 M5 x64 (M6 directly replaced M5).

The live CD booted up at 1440x1050 (default for the VESA framebuffer driver, which is the live media’s default driver). All hardware was detected properly otherwise and was usable - including the Tenda Ralink-based wireless-N USB stick I have in place for wireless-driver testing. Both audio-output devices (AMD Manhattan HDMI audio-out and Sound Blaster X-Fi audio-out) are detected; the HDMI-out is the default. (NOTE: This is, surprisingly, not a bug; this is by design and, believe it or not, mirrors Windows’ default behavior.) Installation from the live CD was flawless.

The first-time bootup/configuration screen post-install holds no surprises compared to previous versions of openSuSE. The arrival at the KDE desktop, however, did hold a surprise, and a welcome one. One of the first tasks i run post-install is to do a quick check via a Konsole window of which drivers the desktop is using. While Mesa’s software rasterizer does support DRI (and has since Mesa 7.9), it’s still not as fast as hardware supported DRI; however, that has been all AMD HD5xxx hardware permitted without going to the binary blob - until now.

Nutshell dump:

OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (CEDAR 68F9) 20090101 TCL DRI2
OpenGL version string: 2.1 Mesa 7.10

I have no idea whether this is R600c or R600g - and, except for gearheads, most users won’t care, either. The mere fact that either is there, and by default, is far more than has been the case for over a year. That also means that anything that relies on Mesa (which includes 3D desktop acceleration and most Linux-native/FOSS-native gaming beyond casual) will work, at full capability, right away.

Everything else works as it should, including printer detection (HP DeskJet 940C connected via USB is still showing off how Plug and Print is supposed to work).

More after I log out and back in.

The desktop post-install is at 1920x1080 (the Acer H233H FP display’s default - this is the plain H233H model with both the built-in speakers and triple-inputs selectable from a touch-switch in the display’s bezel), which is as it should be. As I gleefully pointed out in part 1, OpenGL acceleration (and therefore, KDE desktop acceleration) is in full effect. M6 defaults with RC2 of KDE 4.6, with the released 4.6 available as an upgrade. I have had no problems with playback of media files on my Windows partition; for the most part, even Flash playback from the Web is flawless as well.

Things are shaping up to be much better than before with 11.4!