openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

Open terminal and type: alsamixer -c 0. You should see all the channels.

So, now I restartet WITH PulseAudio support enabled and guess what? All channels I had before are gone. I think I’m going to understand how this PulseAudio thing works.

I adjusted the microphone a bit in pavucontrol and I think the voice output is now OK. I’ll see it later.
Thank you guys; I probably had no bug at all (except for that bug STurtle openSUSE 11.4, KMix too few channels (probably due to PulseAudio) posted). I just didn’t understand how to configure it correctly.

Sounds weird with sound detection for opensuse 11.4.:
I just installed 11.4 with xfce 4.8 on a P4 1.7 ghz 6 year old machine.
Sound detected as 82801BA/BAM AC’97, driver intel ICH and pulseaudio enabled.
First boot no sound was detected, second boot sound appears and in gmixer lots of channels appeared like master,pcm, line-in, line-out, auxiliary,microphone, 3d sound,
head phone, capture and some others which I didn’t see on the newer machine with 11.4 xfce 4.8.

That’s interesting, it looks as if PulseAudio and openSUSE/KDE needs some workout by the users (even if the devs didn’t do that).:slight_smile:

Did you need “pavucontrol” for that?

Yes, I added pavucontrol before commencing with the installation. I can’t use it for now cause it’s connected to the tv and someone is watching right now. When done pruning the backyard trees I will play with it and see. It’s kinda good cause I am planning to use it for entertainment purposes only like listening to music in the family room where it is setting now.

I had same problem with kmix … just one channel for playback devices and none for capture. I’ve uninstalled kmix via Yast–>Software management, rebooted and installed kmix again via yast. It solved my problem. Now all channels are here :slight_smile:](

Forgot to mention … I’ve also uninstalled pulseaudio together with kmix

Hello fellas,

i got trouble with my sound, too.

my Problem:
I only hear music from my front speakers, nothing from rear or subwoofer.

Iam running opensuse 11.4 KDE

I have 4 boxes and one subwoofer.
Soundcard is an onboard one and supports up to 8 channels.
My MB is >Asus AT3IONt-I< and the soundcards name is >nVidia MP79 HD Audio<
installed driver are noted as >HDA Intel< (kerneldriver: snd_hda_intel)

tried solutions:

  • deinstalled PulseAudio -> some more channels available
    (i see now Master|Line|RearMix|RearMicBoost|Capture|Capture2|PCM|FrontMic)
  • KMIX deinstalled and reboot and installed
  • KMIX updated and reboot

Btw: i get sound from my front-audio, but that not the solution.

Any help would be really appreciated. If you need further infos, don’t hesitate to ask me!
I’ve googled already and read through different posts and forums.
I don’t know if that:
opensuse- nforce2- kein5.1 - – User helfen Usern
could be a solution. But it seems to be outdated, so I don’t tried it yet.

I hope anyone can help me out.
Greetings Sebastian

(Excuse my bad englisch)

Before you decided to remove PulseAudio, did you go to System Settings>Mutimedia>Phonon>Speaker Setup tab where you could have tried to achieve your speaker configuration?

thanks a lot, for your fast reply,

I remember that I steped into that menu. In the middle of that window where two heads. There was also no possible choice for an 4.1 system or anything like that.
I have had tested my soundsystem and the results were the same as I wrote above. Only front speakers worked fine.
Do I need to work out some config-file or something like that. I read something about such things in other posts.

Thanks a lot for any help!
Greetings SoundHarvester

Thanks for that information. I’m on Gnome at the moment, but I recall KDE’s Phonon>Speaker Setup on my notebook presented Analogue Surround 4.0 and it’s the same here on both Gnome Sound Preferences and pavucontrol. I believe that’s correct for my sound chip, along with the basic Analogue Stereo configuration, but that’s all with PulseAudio enabled. I’m assuming you haven’t seen any Surround Sound configuration types, is that right?

With P/A disabled, you should be back to Alsa support as indicated by the different KMix view of channels. KDE is still using Phonon but the panel’s content may have changed, and Phonon will use Alsa (through the backends). With P/A gone, do you still get the Speaker Setup tab on Phonon’s panel? If so, what’s on it?


thanks again. I hope I get what u mean.
To be clear I’ve done a screenshot to fullfill your request.
Here we go: - KMIXbe4bc.jpg

Is that all correct?

Greetings SoundHarvester

Thanks for the picture. Yes that is the Phonon panel. The new Speaker Setup tab has gone with P/A removal (to be expected) on KDE 4.6. The additional P/A support in KDE was added to KMix and Phonon. The tab was inserted to the left of Phonon’s Backend tab. BTW did you consult the stickies heading up the multimedia forum and this guide:
SDB:Audio troubleshooting - openSUSE

On my desktop PC there is an onboard chip with 5.1 channel surround sound. For KDE, I can give you some idea of how it configures with and without PulseAudio enabled. I will limit the examples to audio output devices only.

However, from your picture of KMix and Phonon settings, I see no evidence of surround sound being configured for your card.

Without P/A (i.e. just Alsa): KMix (and alsamixer) shows lots of channels, including extra surround playback channels e.g Master Surround, Surround, Centre, LFE. Phonon shows only one output device for the internal chip, and does not have a “Speaker Setup” tab so there is little scope for configuration there.

With P/A enabled: KMix (and alsamixer) shows one Playback Device channel with adjustable volume. There are no indications there of surround sound. Phonon shows two output devices: “Internal Audio Analog Stereo”, and “Internal Audio Analog Surround 5.1”. One of those devices is inactive (greyed out) depending on what is configured on the “Speaker Setup” tab. Under “Speaker Setup”, each card (one here) shows several “profiles” in a dropdown list. For example, on selecting the “Analog Surround 5.1 Output” profile, “Output” settings are automatically updated, and the “Speaker Testing and Placement” sub-panel is automatically re-configured with buttons for 5 speakers and a sub-woofer. In addition, “Internal Audio Analog Stereo” output device, back on the main Phonon panel, is deactivated (greyed out). It’s all done with a couple of clicks.

As you see, PulseAudio offers easier configuration for surround sound via the DE.

With no surround sound channels showing in Alsa, I think you need to establish whether your card features surround sound. If you are sure it does, then your card may not have been correctly detected by kernel/alsa drivers and/or changes to alsa configuration file(s) are required. :slight_smile:

hi consused,

its me again. THanks for the URL. I have had read through it, but its seems as it is a more basic troubleshooting help. Its for somebody who doesn’t hears any sound. So I would see my problem in a more advanced way.
I have visited also this “troubleshooting”-page from Phonon, which is complete rubbish in my eyes.
But anyway, I tried some commands from your url:
for example to find out the codec and look it up in the soundDocumentation of my kernel. the input and output was:

# head -n 1/ proc/asound/card0/codec*

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC887

==> /proc/asound/card0(codec#3 <==
Codec: Nvidia MCP79/7A HDMI

But it doesn’t appear in that Documentation. Does this means my soundcard is not (yet) supported by this kernel?

What do you think of installing pulseaudio again, and uninstalling KMIX?
Give it a try?

Thanks again and have a good night.

Hmm just running though that page .asoundrc - ALSA wiki](
and tried

aplay -L

which comes up with this output:

    Discard all samples (playback) or generate zero samples (capture)
    HDA NVidia, ALC887 Analog
    Default Audio Device
    HDA NVidia, ALC887 Analog
    Front speakers
    HDA NVidia, ALC887 Analog
    4.0 Surround output to Front and Rear speakers
    HDA NVidia, ALC887 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA NVidia, ALC887 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA NVidia, ALC887 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA NVidia, ALC887 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA NVidia, ALC887 Digital
    IEC958 (S/PDIF) Digital Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output

Does this mean, there is some solution on the way, or is that just standard output?

Thanks again, for your donating your time.

Not sure what codec you searched with, but using alc887 I get this search result, so the codec has been supported through several releases of Alsa.

Once we establish your card is supported and configured correctly for Alsa, then it might be worth trying to restore P/A.


He my helper, did u read my last post about those aplay -L command and his result?

Greetings SoundHarvester

Its me again,

Ive deinstalled KMIX, and installed PulseAudio, where should I find those settings for surround sound u mentioned?
Or is something else needed?

Personal Settings > Multimedia > Phonon
(‘kcmshell4 kcm_phonon’)

You have seen this before, as it is on the screenshot that you showed in post #32. However, as opposed to a configuration that uses Alsa, with Pulseaudio there should be an additional tab, ‘Speaker Setup’.