openSUSE 11.4, KMix too few channels (probably due to PulseAudio)


today I installed openSUSE 11.4 (32bit) on my machine. So far, nice work. But I have some problems with KMix. When I open it, there are is only one Playback and one Capture device.
When I open “alsamixer” and click F5 to show all bars, it shows only two: “Master” and “Capture”.

But I need something more. Something like the Microphone boost. Without it, trying to use the microphone is useless… :confused:

Any ideas how I can activate it?

My sound chip:

24: PCI 07.0: 0403 Audio device
[Created at pci.318]
Unique ID: M71A.14Q3JWBTiv4
SysFS ID: /devices/pci0000:00/0000:00:07.0
SysFS BusID: 0000:00:07.0
Hardware Class: sound
Model: “nVidia MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0774 “MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio”
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x8346
Revision: 0xa1
Driver: “HDA Intel”
Driver Modules: “snd_hda_intel”
Memory Range: 0xf7e78000-0xf7e7bfff (rw,non-prefetchable)
IRQ: 21 (8166 events)
Module Alias: “pci:v000010DEd00000774sv00001043sd00008346bc04sc03i00”
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: “modprobe snd_hda_intel”
Config Status: cfg=yes, avail=yes, need=no, active=unknown

Did you try a recording with the single capture channel (master volume/level) at max level in KMix? What application are you using to make the recording? When you activate it, you should get an application (volume) channel appear on KMix’s Capture Streams tab where you can adjust the level.

I am trying to use Mumble. (Installing Mumble - Mumble)
When Mumble is open, I have an extra channel in KMix’s Playback tab, but not in Capture ->](
Uploaded with

On 03/29/2011 10:06 PM, Ctwx wrote:
> Any ideas how I can activate it?

-close running copies of KMix
-left click on the KMix icon
-left click on the button “Mixer”
-mine has a menu: File, Settings, Help
-click Settings then click Configure Channels…
-available channels on the left, visible channels on the right
–move those on the left which you want to see, to the right
–move those you don’t want to see to the left
-click ok

other settings are available via Settings > Configure KMix

Tried LibreOffice? Do that and help at
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

There are none except for the “Internal Audio Analog Stereo”.](
Uploaded with

In Settings -> Configure KMix I can’t do anything that has to do with the channels. :confused:

On 03/30/2011 09:36 AM, Ctwx wrote:
> In Settings -> Configure KMix I can’t do anything that has to do with
> the channels. :confused:

then i’m pretty sure you have found a bug, please begin here:

after the report please return here and put the bug report number/URL
here so others that google into your thread can find the bug and add
their info to it (bugs on only ONE system don’t get looked at as
quickly as a bug on 1000 computers!)

Tried LibreOffice? Do that and help at
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

There are comments elsewhere on the forum about the initially empty Configure KMix panels so that appears to be normal, as it is on mine. Although I noticed for example, an entry appears in the right hand panel when an application’s capture channel appears on the Capture Streams (eg using Audacity). BTW that Capture Stream channel’s level for Audacity is at 50% on slider initially. I was able to increase it to get a good recorded volume level with my notebooks built-in mic, whereas on 11.3 I used Mic Boost.

However I can’t recommend Audacity for recording, as it doesn’t yet have native support for PulseAudio. It relies on the alsa plug-in for P/A, and I read that it isn’t very reliable according to Audacity. I eventually get latency problems and error messages. At least it proves the connectivity with P/A and recording level. Before testing I checked my mic using this at the command line (normal user):

arecord -d 10 myrecording.wav

For 10 seconds recording to wav file with any chosen name.

It seems that Mumble is not packaged by openSUSE and not in the standard repos or packman. I guess you sourced it from an OBS user’s home repo, so that makes it difficult to get support for it. I am not familiar with it. Does it have native support for PulseAudio?

BTW, you can install the package “pavucontrol”. It appears (to me at least) to offer similar features to KMix and Phonon (KMix>Settings>Audio Setup). There are slight differences when it comes to reporting status of streams.

If you can live without it, you could aslo disable Pulse Audio.

That is an option, but it’s one that stifles progress in terms of learning and contributing to further resolution of problems.

Were you connected to a server at this point in your testing?

Great tool. I could choose another Mic. with out and now it works. Mumble can use my micro. But the audio quality is really bad! If you want to hear the record (by a friend) see: zSHARE - - Free File Hosting Service | Audio and Video Sharing | Image Uploading | Web storage

So, I probably have to reconfigure PulseAudio. Any ideas how to do that? I’m not really familiar with PulseAudio and I haven’t found a GUI / Tool to do fine adjustments.

Yes, I already thought about that. But first I wanted to it “the SuSE way”.^^ Since I’m a Slackware user, I’m more familiar with ALSA. I wanted to test Mumble on another distribution, because Mumble caused some trouble on my Slackware.

I haven’t send a bug report yet. I’m not sure, if one can say that’s a bug for sure. I want to give it some more tries.

Yes and no. I tried both.

Glad you like it. As it’s a gtk app, I guess the KDE devs didn’t :D. For recording quality, best first check the FAQ and forum via the main Mumble web page for any issues.

So, I probably have to reconfigure PulseAudio. Any ideas how to do that?

No, I wouldn’t attempt that. You are already using the main user tool(s). If it comes to a bug report, the devs could advise on that as appropriate.

Did you try a test recording with “arecord” via the command line as I mentioned. If not, you should. It didn’t register on P/A, as it’s probably a much lower level operation using basic sound drivers. If that gives good quality, then it may point to a P/A bug, and Mumble may not provide adequate “evidence”. If arecord gives poor quality, then it’s either your hardware, or openSUSE doesn’t handle your sound device properly and that’s a bug report.

I wanted to test Mumble on another distribution, because Mumble caused some trouble on my Slackware.

openSUSE Gnome used P/A by default all through 11.3, and now 11.4, and I believe ubuntu uses it as its default sound server.

Yes and no. I tried both.

Ok. On Mumble’s web pages, I came across this statement in a blog about the new recording feature of their latest release:

“Recording is only possible while you are connected to a server and you can only record what you hear or say.”

What did you mean by the words in red? Was “another Mic” a second hardware device? I only have one buit-in mic, but pavucontrol can also show a montor entry.

Since it looks almost like a native Qt app, I’m satisfied. But that doesn’t matter. As long it does it’s work, I’d also use an Application that uses Motif. :stuck_out_tongue:

Once I had problems with PulseAudio. I had signal noise and delayed output due to a mis-configured PulseAudio. But it’s already about 2 years ago.

Not yet. I think I’ll try it tomorrow.
I disabled (not deinstalled) PulseAudio for testing ALSA. With ALSA no problems at all. OK, KMix still doesn’t show anything useful since it seems to use PulseAudio. (I think that, because there is only PulseAudio listed in the dialog KMix -> Configuration -> Audio setup)

If I come to the conclusion that it doesn’t work the way I want it to, I’ll go with ALSA.

Now with ALSA, my friends says I have a clear voice – and they say I’m really loud. ^^ I probably have to decrease the Mic Boost.

I can select 3 different ports in this dialog:](
Uploaded with
Microphone 1, Microphone 2 and Line. Mic1 and Line doesn’t work; Mic2 work.
I also have only one built-in microphone. Maybe by mic1 is “Front Mic”… :S

To the “Was “another Mic” a second hardware device?”… I think there is a part missing of my sentence. :S Hmm…

There seems to be a bug in Kmix as of 4.6.0: Bug 264835 - tabs in kmix are removed after login, and cannot be readded

Closing KMix, deleting config files and restarting KMix can offer some relief, but soon the controls are missing again for me.

This difference between the number of Mic entries shown (one in KMix v three in pavucontrol) may indicate that KMix only shows active devices, and not ports without connected devices.

I tried a restart with “connected” headset. Nothing happened.

I’m guessing. You rebooted? The headset showed up connected in pavucontrol and KMix? You ran a recording application “arecord” or Mumble? It failed to record? :slight_smile:

LOL! What happened?! My KMix is filled with channels! It’s title changed to “HDA Nvidia”. It like I selected “HDA Nvidia” in alsaconfig by clicking F6 and selecting it.
Í’ll test a few things… Maybe I can find out how I did it. :slight_smile: