openSUSE 11.4 KDE: How to set up mouse right click for deletion?


OS: OpenSUSE 11.4 KDE x86_64

Mouse: MS Notebook Optical 3000, with left, right buttons and a vertical scroll wheel in the middle

How do I configure or set up mouse action such that an option to delete or move to trash is also included when hitting the right mouse button? As shown below, the “standard menu” does not include this action:

Right clicking desktop > Desktop Settings > Plasma Desktop Shell

Middle button: Paste

Left button: Standard Menu (std. menu/application launcher/paste/switch windows/switch activity/switch desktop)

Vertical scroll: Switch desktop

Right button: Standard Menu

I appreciate your suggestions. I have looked all over but can’t seem to find the answer.

Hang on
You want right click > delete

But are you meaning in dolphin.

Because you seem to be suggesting the plasma desktop, and they can vary depending on the activity type you use, and delete what exactly? Everything on a desktop activity is a widget and itself has a delete button if the widgets are unlocked. Even the desktop activity is really a widget.

Hi caf4926,

What I am still trying to achieve is to delete or move to trash a few wallpaper images from Desktop Settings - Views. In any other application I can right click an item/object to delete or move it to trash. As an alternative I also tried to select a wallpaper and hit the DELETE key but failed. I also wish to see options or menu choices to move and to copy, not just paste. I know how to configure the mouse action but cannot find either Delete, Move or Copy.

Basically plasma desktop makes it way harder to use than necessary, in my humble opinion (IMHO)!

In the settings here
SUSE Paste

Hover your mouse on the top left corner of an image

Hello caf4926,

My Desktop -View is not the same as the one you are showing, and it only has 2 items: View & Mouse Actions. When I hover my mouse over the top left of the “Icy Tree” wallpaper to get rid of it, I don’t see any red X. So can you show me how to set this up?

Thanks a lot for your help.

Unlock widgets
Go to the top right corner cashew and click > configure shortcuts
That may help

But What activity type are you using, I have Folder View
Let me try some others

Yes, I just tried the plain desktop and it’s like you.
Let me see if I can figure a setting

I can’t see it

Try switching to Folder View Activity
(applications open in the current activity will not be in view, so close them first in case you forget about them)

You can delete icons on the folder view desktop if you like, it’s an activity that is meant to represent the traditional type ‘Desktop’ most are familiar with.

Hi caf4926,

I switched to Folder View Settings and got the same image you just posted. However, no matter whatever option I selected using the “wrench” to the right of Right-Mouse Button, the mouse actions remain unchanged, i.e. still the same as in my first post. I cannot delete “Icy Tree” wallpaper. Delete button doesn’t work, so does the key combination “ALT-D, R”.

You still can’t hover the image as shown here

Hi caf4926,

I now got the same screen image as yours after selecting Folder Views, but when I select the Icy Tree wallpaper image and hover the mouse cursor over its top left corner I don’t see the red X. Clicking on the “cashew” at the top right of the screen does not show configure shortcuts, but rather a menu that include shortcut settings.

Right click desktop > Shortcut settings > Configure shortcuts - Plasma Desktop Shell

Left-hand Column: Actions: …(Red)X = Remove this activity
Right-hand Column: Shortcut: Alt+D, Alt+R

Somehow I still cannot make the red X appear on the right side of “Right Mouse Button”. Perhaps I would try another keyboard.

You can’t remove system wallpaper images, only ones you have manually added

Hi caf4926,

I did try a different keyboard and manually added 2 other wallpapers, but still no luck, i.e. unable to delete using ALT+D or ALT+R, or the DELETE key. I think the problem lies in how to correctly configure shortcuts such that when I right click an image or wallpaper object I should be able to remove it (Red X = Remove this activity).

I think maybe we are talking about different things?
Now I’m not sure where you are coming from

IMHO the problem is that you are trying to use the desktop settings application to perform a file managment task. If you want to delete something, open dolphin, navigate to the folder where the thing is, right click, and delete it. Wallpapers are in /usr/share/wallpapers.

Just my 2 ¢