opensuse 11.4 kde 4.7 desktop freezes

Hi. Since last few days plasma desktop randomly hangs up when I start kick-off launcher. Screen just freezes, I cant switch between running programs using task manager on panel, cant click on anything in kickoff. I can switch between apps using alt+tab, alt+f2 also works to start new apps. I tried to restart plasma using
ps -e | grep plasma
kill -9 process_id
kstart plasma-desktop
But it does not help. Plasma is restarted, but still cant click. Here is log from console after restarting plasma
:~> ps -e | grep plasma 3002 ? 00:13:51 plasma-desktop :~> kill -9 3 -](
What can I do about it?
Thanks in advance.

Still happens with kde 4.7.2.
Also, logout+login does not help, only full reboot.

On 10/05/2011 11:16 PM, vania z wrote:

> What can I do about it?

have you installed the best video driver for your graphics set? see

have you turned off desktop effects to see if it is stable then?

i have none of the troubles you mention but i am using the KDE version
which shipped with 11.4, why not backlevel to KDE 4.6.0 and be stable aslo??

openSUSE®, the “German Automobiles” of operating systems

@vania_z: there’s a couple of things you can do:

  • Create a new user, login as that new user and see if the problems exist for that user.
  • If not, the problem could be in your plasma config files, i.e. remains of widget settings etc. This can be “solved” by removing the plasma config files, do this while being logged out of the user’s KDE desktop. Logout, hit Ctrl-Alt-F1 to get to the console, login as the user and do

rm ~/.kde4/share/config/plasm*

Then hit Ctrl-D to logout, Ctrl-Alt-F7 to get back to the login screen. Log in as the user, and you’ll see the default KDE desktop appearance. Please note that your application settings will remain untouched. Then reapply the desktop appearance preferences.

  • Another thing could be the recent changes to KDE packaging. In Yast, select the KDE 47 repo and look for “red” packages. An uninstall of those should force the install of the new packages.

I have latest stable nvidia drivers, worked good for a long time to me.
Kde 4.6 is fine, but 4.7 is much faster and has a lot of useful features, like face recognition in digikam.
Already tried to login as new user after plasma froze. Logged in into console using alt + f3, stopped x with init 3, after that started xserver as root. Plasma was still inaccessible.
There are no red packages:( I remember one month ago there was some bug in qt, to fix it users had to add another qt repository, without it kde showed just black screen. Can it be a new bug in qt?

I had a similar issue as you described, but with 11.4 SUSE and 4.6 KDE. the issue turned out to be hardware related, in that after I turned of my laptop’s trackpad from the BIOS, everything has been fine…

Perhaps it’s a similar issue?

Well, maybe, but I’m on desktop. Don’t know what to disable:)
Noticed another thing - if I leave it for ~10 minutes without restarting plasma, plasma will become responsive again. It happens now twice a day, quite annoying:(

In task manager plasma status is “disk sleep”. I think issue is somewhere there.
It seems this is the same issue. I disabled nfs share in yast, if it helps I’ll let you know.

Solved. Nfs share causes plasma to hang sometimes.

Thanks for reporting that. I had the exact same problem. In version 11.4 using KDE 4.6x and nor in 12.1 with KDE 4.7x. I saw that kdeinit had a disk sleep status. Now I need to figure out if it’s possible to solve the problem wihout disabling the network connection. My connection BTW was not NFS but via Samba to my Windows Laptop. Whenver the laptop sleeps the connection sleeps as well and thus eventually KDE.