openSUSE 11.4 Install Problem

Hello, my name is David and I am new to openSUSE, I am switching from Kubuntu 10.10. I am running openSUSE 11.3 KDE. I love the KDE better than Gnome, but anyway. Yesterday I was trying to install openSUSE 11.4 KDE, and I would get halfway through the install and the whole screen would go black, all I could see was my mouse and it was frozen, I let it sit for a while and nothing happened, I tried about 10 times to install and this happened every time… why is this happening. I just went ahead and went to openSUSE 11.3 KDE. Anyone else having this problem? Thanks

Did you do this and it was OK

No I did not do that! I tried to install from a CD, I do not have a DVD drive, then I tried to install from a flash drive, neither worked. Is there a way I can upgrade from within openSUSE 11.3? Without using a CD or Flash Drive?

Try text mode
Text mode install from liveCD

Thank you very much, I shall try this!

I would check the media. it is known that sometimes the burn didn’t go through well and the CD is bad.
When you boot from the live cd, there is an option to check the installation media.

you can never know…