openSuse 11.4 graphical artifact on HP nx9420


I am a newbie, just started using Linux a couple of months ago. I first installed Ubuntu, then switched to openSuse 11.3, and now I have been struggling with this problem in 11.4 for a few days.

I have a 5 year old HP nx9420 laptop, with an ATI mobility Radeon x1600. I am using Gnome desktop. 11.4 installation was problem-free, every device was recognized from the start, however, when I install and run new application (such as Opera, vlc, etc), and as far as I can tell, for the first time I run one of them, I get this seriously messed up graphical artifact. It’s like the whole desktop image is cut into diagonal pieces and placed horizontally (I don’t know how to best describe it). I tried taking a print screen, but when I check the picture it’s perfect, no graphic problem. So I took a camera picture of my screen. It happens also after some time elapses, such as I listen to music, browse the internet, and then all of a sudden, when I open a new webpage, or when I switch a new song, this thing happens again.

In the beginning I didn’t know what to do, so I just restarted. I really want to learn how to use Linux, so I did a bit of searching around the net, and came up with the following workaround. Ctrl + Alt + F1, then init 3 then init 5. And the glitch is gone, however I lose the status of all my applications when I do this (from my understanding it’s basically a restart of the X11 no?)

I don’t know what to do anymore, and thought maybe I should get some help. I’m thinking that probably my old video card is acting up. There are also some minor artifacts, such as when I scroll down on a page, the last row of writing appears smaller, or when I select a chunk of text, only the letters are selected, and some white space appears between them, instead of the whole row of text being solid colored for instance.

Sorry for the long text story, if you need additional hardware / software details, I’ll be happy to comply. Just to mention, this is a fresh install of openSuse 11.4, on a newly formatted drive, and I think almost all applications are installed via YaST.

Thank you in advance for your patience and eventual answers!


Sabin, i have the same laptop and i also have the same problems in debian 6 & opensuse, the problem is driver of the videocard (after searching in many hours in google); but i dont have a solution yet, do you?