openSuse 11.4: Firefox 8.0 crashes

Hi,

Since Firefox 8.0 came on my openSuse 11.4 computer, it (firefox) keeps crashing on almost every webpage. Running in an xterm, I see the following error message:

GLib-GIO-ERROR **: Settings schema ‘apps.gecko-mediaplayer.preferences’ is not installed

aborting…

Does anyone know how I can get rid of the error?

Kind regards,
Svend Tollak Munkejord

Hi Svend!

Are you able to start Firefox from xterm in safe mode?

firefox -safe-mode

If you are, check your plugins.

Is Gecko-Mediaplayer installed on your system?
Is Gnome-Mplayer installed on your system?

Hi,

Thanks for your quick reply.

I can start Firefox in safe mode, but it still crashes, e.g. on openSUSE.org

Both Gecko-Mediaplayer and Gnome-Mplayer are installed.

Kind regards,
Svend

Back up this directory to be on the safe side:

/usr/share/glib-2.0/schemas

I found this Issue 547 and somebody suggested running this command as root should do the trick.

glib-compile-schemas /usr/share/glib-2.0/schemas/

Is it versions 1.0.4 you’re running?

Hi,

Sorry for my late reply, I wasn’t able to get online.

I did the glib-compile-schemas, but the error remains.

What do you mean by versions 1.0.4? In any case, I have the /usr/share/glib-2.0 directory.

Kind regards,
Svend

Ah, regarding version 1.0.4 I suppose you meant the gmplayer version. It seems to be 1.0.2:

Name : gnome-mplayer Relocations: (not relocatable)
Version : 1.0.2 Vendor: PackMan :: Startseite
Release : 1.4 Build Date: Sun 16 Oct 2011 10:22:09 PM CEST

This seems to be a bug related to gnome-mplayer.

There should be newer versions available of both gecko-mediaplayer and gnome-mplayer in the packman repos. Have you tried upgrading them?

PackMan :: Package details for gecko-mediaplayer
PackMan :: Package details for gnome-mplayer

Hi,

It turned out I had the latest gecko-mediaplayer, but not gnome-mplayer. There was a gnome-mplayer-lang package installed, which prevented gnome-mplayer from being updated automatically. I deinstalled the -lang package and updated gnome-mplayer.

Now it works! Thanks a lot!

Regards,
Svend

Thanks a lot too. This solution also worked for me.