openSUSE 11.4 + Firefox 4 - anyone running with hw acceleration?

I was really looking forward to Firefox 4, especially to trying the hardware acceleration. I’m using nvidia proprietary driver which is the combination which should work, according what I’ve read. However it doesn’t. Firefox doesn’t even recognize my graphics card, when I type about:support, there is no information about my graphics. So I wonder, is there anyone who got this working?

I have just tried about:support - and mine reports “0/1”. I am using the default 11.4 (64bit) installation with open source ATI drivers.

I have an old Nvidia GeForce6200. I’ve tried with drivers 173 and 260 and it doesn’t work. When trying to force hardware acceleration (in about:config or by exporting MOZ_GLX_IGNORE_BLACKLIST=1), with the 173 drive nothing happens and with the other one Firefox always crashes. KDE doesn’t crash with driver 260, all desktop effects are pretty. I have 11.4, standard install.

With 9800GTX (latest drivers) openSUSE x64 Firefox 4 RC and webgl.force.enabled and layers.acceleration.force both set to true I am getting about 25 FPS … with them false/off more than 60+ FPS. So I guess I am better off with’em turned off (0/1).

I have just tried about:support - and mine reports “0/1” also on FF4/32bit

According to Mozilla, you enable it like this:

  1. Set “layers.acceleration.force-enabled” to true
  2. Set “layers.acceleration.disabled” to false.
  3. You can use about:support to see whether you’re getting GL-accelerated rendering after that.

I have 64-bit openSUSE 11.4, Radeon HD2400 and fglrx drivers (somehow it only says 2D is fglrx and 3D is ATI). I changed webgl.force.enabled to true, but many WebGL demos still refuse to play.

Well and did it work for you? I tried to force hw acceleration just after upgrading to Firefox 4 and I got no results. I guess my card has to be at least recognized first.

Don’t really no what it means, Mine is 0/2, Is that good or bad.

My is also 0/2 and that’s not good I guess. You should see some information about your graphics card, it should look something like this: (screenshot comes from Windows, but it doesn’t matter).

NVidia graphic card with proprietary drivers are supposed to by supported in Linux and many Ubuntu users can confirm that. I hope this will be available on OpenSuse soon…

I’m also using 64_bit 11.4 with a Radeon HD4250 and the latest ATI fglrx drivers. I can get acceleration to work if I start firefox with the MOZ_GLX_IGNORE_BLACKLIST=1 firefox command and then set the webgl and layer options on the configuration page. This does get me acceleration. However, when I do this, I get only 6 FPS, down from an already miserable 13 fps.

If I disable the layer and webgl force options, and restart firefox, still with the MOZ_GLX_IGNORE_BLACKLIST=1 command, fps goes back to 13, but webgl does work on sites that require it. It does not without the MOZ_GLX… command.