OpenSuSE 11.4 fails to boot properly.

After upgrading to openSuSE 11.4 from 11.3 my system failed to boot into GUI mode. KDM did not start and the network did not start as well. ifconfig revealed that only “lo” was started. Looking through the posts here did not produce any answers. I used “zypper up” to apply the current patches and it still failed. Finally out of desperation I added “sleep 10” to /etc/init.d/boot.local to see if I could slow things down a bit and lo and behold everything started working fine. I have two other test partitions on this machine that acted in the same manner (one of which is 64 bit). I have an ATI HD 3200 graphics adapter integrated into the motherboard of an AMD Phenom Triple-Core Processor with 4G of ram. If anyone knows what the real problem is, please respond, otherwise I’ll just leave the “sleep 10” command in place.

The ATI problem could be easy to solve:
Easy install of ATI proprietary driver in the console
But you have to fix the network issue first. What about:

ifconfig -a


And what netcard do you have?

hwinfo --netcard | grep -i -e model -e driver

Well … you should not boot in failsafe. You should boot in runlevel 3. Then you will have network. To boot in runlevel 3, add a 3 at the end of the options line. BTW, also add ‘nomodeset’. Then you might have both, network and GUI… or just add ‘nomodeset’ first.

Thanks for the replies. Here is the info you asked for:

ifconfig -a:
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:273 errors:0 dropped:0 overruns:0 frame:0
TX packets:273 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29149 (28.4 Kb) TX bytes:29149 (28.4 Kb)

hwinfo --netcard | grep -i -e model -e driver:
Model: “Marvell 88E8071 PCI-E Gigabit Ethernet Controller”
Driver: “sky2”
Driver Modules: “sky2”
Driver Info #0:
Driver Status: sky2 is active
Driver Activation Cmd: “modprobe sky2”

I did not boot to “Failsafe Mode.” Entering runlevel on the command line after the boot reveals “N 5” indicating we are at run level 5, however, no GUI, kdm did not start.

When the failure occurs I can start the network by issuing “/etc/init.d/network restart” and I can go into GUI mode by issuing a “init 3” then issuing an “init 5” and all is well.

I tried the “radeon” driver and the ATI proprietary driver “flgrx” and both fail in the same manner. The only thing that worked was putting “sleep 10” in "/etc/init.d/boot.local.

Thanks again

I had the same problem this morning after a reboot with an nVidia and IMHO I don’t see video driver as a cause. In my case, openSUSE booted to the Gnome desktop init 5.
Rgioux’s issue and my are network not starting. In addition, I’ve lost my br0 devices. But when I switched Network devices to networkManager, it started the eth0 and DHCP for me.

I just started my analysis and found this thread, so I updated my /etc/init.d/boot.local adding the sleep 10 command. Haven’t rebooted yet or changed it back to manual configuration ifup/ifdown. Hopefully, ifup/ifdown will bring up eth0 and br0.

I am having the same problem here with two computers. One was just upgraded to 11.4 and one is still 11.3. Switched between G01 and G02 Nvidia drivers, no luck.

On the 11.4 box changed displaymanager (/etc/sysconfig/displaymanager) to xdm. same thing. Installed gnome, then xdm started to work. Switching to gdm also works.

On both computers if I logged in and did startx I would get a desk top. This tells me that the nvidia driver is working.

Since gdm, xdm, and startx all show that the nvidia driver is working the problem must be kdm.

Dave W

That can definitely not work. Both drivers are intended for different models of nvidia cards.

I switched the driver because in the past nvidia released a driver that changed which devices were supported. 6000 card support went from G02 to G01 then back to G02 on the next driver update. We have seen this on 6800 and 6200 cards.

GDM, XDM, startx with kde desktop works, kdm with the nv driver works. Why is KDM failing with the nvidia driver? Is kdm also failing with ATI? I dont have an ATI system to test.

Dave W.

If you refer to the problem described along this thread (on of the most popular ones) : NVIDIA 260.19 Issues, this is a well known issue.

Im confirming this.
Sometimes randomly system boots properly to kdm and network works etc.
But usually I just see “Runlevel 5 has been Reached” and login prompt.
When I login and start kdm, i dont have network devices defined so I have to YAST -> Network Settings and change something. After that network works but many services like Apache and mysql are not running. This is starting to be kinda annoying to crank the system up manually every day.

In kde I have some issues too, like the panel not updating… time is not running and window buttons not appearing to task manager… but I guess this is not the time to cry about these.

I have nvidia card but that very much has nothing to do with anything I believe.
Proecssor is AMD 2x something 64bit.
system version also 64bit.
4gb ram.

Very same here, after update from 11.3 at random it says “Runlevel 5 has been Reached” while it’s obvious from the console output no initscript for the runlevel has been actually run. Going down to S and back to 5 seems to start services properly.

Additionally, it hangs after resume from suspend, but that is another issue.

Just curious, did the “sleep 10” in “/etc/boot.local” workaround work for anyone else besides me?


On 2011-03-19 21:36, wmlele wrote:
> Very same here, after update from 11.3 at random it says “Runlevel 5 has
> been Reached” while it’s obvious from the console output no initscript
> for the runlevel has been actually run. Going down to S and back to 5
> seems to start services properly.

You could log a bug. I think they will want a detailed boot log, which is
obtained by removing the keyword “quiet” from the kernel boot parameters
(grub menu.lst) - a log of a failed boot, obviously.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

It didn’t hurt (eth0 starts at boot) but it doesn’t boot my bridge connect. I can’t blame 11.4 because this also happened in 11.1.
I’m was using 11.1, it worked perfectly after install of 11.4, but reboots after that my bridge connection doesn’t start at boot, I use Gnome and have an nVidia card, nVidia MCP67 eth0.

IMHO, I’ve been thinking there’s some update change that affected NetworkManager or in your case KnetworkManager that’s carried over into 11.4.

Not so sure about the “sleep 10” in “/etc/boot.local” it worked once when I did full power down. But when I just reboot it does nothing. init s and then init 5 seems to do the trick and system boots as expected. But it is kind of frustrating to repeat this every time I reboot.

It seems like there are some service-starting problems with parallel boot in 11.4. i had similar issues and this
Re: [opensuse] 11.4 Probelems
helped me ( RUN_PARALLEL =“no” in /etc/sysconfig/boot )

Had same issue and removing the parallel start did work for me as well.

( RUN_PARALLEL =“no” in /etc/sysconfig/boot )

Thanks Nilsh

( RUN_PARALLEL =“no” in /etc/sysconfig/boot ) worked for me as well. I removed the “sleep 10” from /etc/init.d/boot.local and everything is working fine. Apparently for me the “sleep 10” allowed just enough time for whatever was running in parallel to complete and for the system to boot normally. However, I assume there still must be a bug somewhere for systems not to boot properly when running boot scripts in parallel.

I edited my /etc/sysconfig/boot with the “no” parallel and I get a 25 s wait for the networkmanager to connect. Is this what everyone else is getting? I don’t know ? can I “init s, init 5” in less than 25 seconds?
I’m a bit of a newbie so this may sound stupid but I also tried editing /etc/sysconfig/displaymanager to other options (kdm,kdm4) and it gave me an outdated login then dumped me into gnome with a lot of errors. So I left it at gdm…seems to like that one. But I thought gdm was gnome and kdm was KDE ? why do I only get to kde with gdm?
oh and another note…I do blame 11.4 cause I’ve never had this happen to me. (the not booting into gui problem)

It depends some what on what you installed first if yopou have both KDE and gnome. But you can switch them and also there is a xdm. Just to add to your confusion :slight_smile: