Opensuse 11.4 - displays blank login screen - Please help

Hi,
I have opensuse 11.4 installed with both gnome and kde.
These are the things I did before the problem:

  1. changed the login screen to oxygen login screen
  2. Then I logged off and when again logging in, I chose the session as Metacity.

But unfortunately, the the blank splash screen appeared and it didnt get into the desktop. Then I did a hard restart (By pressing the power button).
Since then, I cannot login. The login screen is blank left only a active mouse pointer. Even booting into failsafe also didnt work.

By the way, I have chosen the option of directly logging in without password prompt at login. (during installation)

Please help asap. Only a week before i did a clean install since i corrupted the grub, dont wanna install again.

Thanks in advance.

What happens if you press a “3” in the initial grub/boot manager (with the menu selection) such that a “3” (no quotes) appears in the options line? Then do a regular boot and login to the full screen text mode as a regular user. Then type ‘su’ to switch to root permissions and enter root password. Then type ‘yast’ (no quotes) to launch a text/ncurses version of YaST. You can use the TAB, Spacebar, Arrows, and < enter> keys to navigate in YaST (ncurses version).

In YaST go to Security and Users > User and Group Management and then create a new user. Ensure you set this up so that it does not automatically log in to the old user account.

Then exit YaST, and restart from the text mode (with root permissions) by typing


shutdown -r now

note you can always halt instead with the command


shutdown -h now

will it allow you to log in as a new user ?

Another approach, in case it is compositing causing this, is to switch OFF compositing:

For that, again boot to the full screen text mode, and login as the user who has this problem (ie your original user). Then type ‘su’ to obtain root permissions, and then install the program midnight commander (mc) [with root permissions] by typing:


zypper in mc

then type ‘exit’ to exit root permissions.

And then as your regular user type


cd .kde4/share/config

and type


mc

and then edit ~/.kde4/share/config/kwinrc changing


[Compositing]
Enabled=false

then save that, and type ‘su’ to get root permissions and restart, by typing:


shutdown -r now

and again test that user’s account.

I should add you could also look at this thread in case it is related: Setting of new login screen for kde dysfunctional

Thankyou oldcpu for your valuable advice and quick response I will try out the methods suggested by you and post.
Mean while, when i was left with the empty screen, I was randomly pressing the keyboard. In that case, I pressed ctrl+alt+F10, i got some error messages, I will post it here, please diagnose it if you can.


Linux-7vvd Kernel: [23.451627] audit_printk_skb: 30 callbacks suppressed
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘Language’ in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘ShowUsers’ in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘Theme’ in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘UseBackground’ in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘UseTheme’ in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘AllowShutdown’ in section [X-:*-Core] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘AutoLoginEnable’ in section [X-:0-Core] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd Kdm_config[1235]: Multiple occurrences of key ‘AutoLoginUser’ in section [X-:0-Core] of /usr/share/kde4/config/kdm/kdmrc
Linux-7vvd mcelog: failed to prefill DIMM database from DMI data
Linux-7vvd audispd: No plugins found, exiting
Linux-7vvd bluetoothd[1365]: Parsing /etc/Bluetooth/input.conf failed: No such file or directory
Linux-7vvd bluetoothd[1365]: Parsing /etc/Bluetooth/audio.conf  failed: No such file or directory
Linux-7vvd NetworkManager[1263]: supplicant_interface_acquire: assertion ‘mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE’ failed
Linux-7vvd bluetoothd[1365]: /etc/Bluetooth/serial.conf failed : No such file or directory
Linux-7vvd bluetoothd[1365]:  input-headset driver probe failed for device 00:18:8D:6F:2A:35
Linux-7vvd bluetoothd[1365]:  input-headset driver probe failed for device 00:1D:6E:00:7C:14
Linux-7vvd bluetoothd[1365]:  input-headset driver probe failed for device B8:F9:34:45:1D:59
Linux-7vvd NetworkManager[1263]: error. [1313303157.966587] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name ‘org.freedesktop.NetworkManagerUserSettings’: no such name
Linux-7vvd NetworkManager[1263]: error. [1313303157.966931] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name ‘org.freedesktop.NetworkManagerUserSettings’: no such name
Linux-7vvd NetworkManager[1263]: error. [1313303157.967212] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name ‘org.freedesktop.NetworkManagerUserSettings’: no such name
Linux-7vvd NetworkManager[1263]: error. [1313303168.259843] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name ‘org.freedesktop.NetworkManagerUserSettings’: no such name


I am sorry for the long message, I cant find the spoiler!
Thank you.

And yeah… this worked…Thankyou Verymuch bhai…Thankyou.
Now, I can even login into my old account(which was corrupted) without any problem. So, whats the big deal about this problem.
Please answer these:

  1. Now I can login to my old account itself howz that?
  2. Now, fonts appear somewhat missing i.e: in browsers where we type in login details, the cursor never appears but when i type, the letters appear but not the first letter. for example, if i type linux, it appears as inux. still the box contains linux “l” is hidden! I hope you understand my way.
  3. some letters in the icon names of the filemanger half appear. Example : “n” appears as r (only the first half) - is this a display issue? when i restart, it becomes normal… But again in someother login attempts, it reappears as same.
  4. Why wont touch pad tap (i mean performing a click by taping on the touchpad in laptop) dont work in login screen?

Thanks a lot for your previous help.

I do not know. I speculate that by creating a NEW user account, it replaced a corrupted configuration file ?

I don’t understand, but then I typically do not understand fonts issues.

A couple of questions: Is this true in BOTH user accounts (old and new) ?

Has your graphic driver changed?

Same questions as in item #2.

I have no idea.

Was that problem in place before ? Is this a new problem ? Is this problem for both users.

IMHO if you want help on a ‘touch pad tap’ then a thread entitled “Opensuse 11.4 - displays blank login screen” is NOT going to garner the attention of those who know about touch pad taps.

Is this true in BOTH user accounts (old and new) ?

Yeah, even for the root account.

Has your graphic driver changed?

I dont know, but this is not a problem when i used ubuntu.

Was that problem in place before ? Is this a new problem ? Is this problem for both users.

Yeah, ever since i installed. Touch pad tap didnt work even in my desktop. But i changed it in the control centre>mouse options. Now in desktop, touchpad tap works but not in login screen.

Thanks. :slight_smile:

Then this is a problem for a new thread with an appropriate title. Most likely the problem that caused this thread was not the cause of the earlier problem. AND a title that states “Opensuse 11.4 - displays blank login screen” is unlikely to garner the attention from the people who may be able to help you.

It appears that the problem that started THIS thread is mostly solved, and I suggest you also start a new thread for this font issue.