openSUSE 11.4 Dead-Locks On Boot On a VirtualBox VPS

Hello,
I installed openSUSE 11.4 x86_64 on a new VirtualBox-based VPS and upon booting after installation it dead-locks at “mounting mandatory file systems…” or when it’s applying the sysctl settings (which is the step right after mounting the file systems). I do not have much more information, however my VPS provider says that the VirtualBox version is 4.0.8, so it is NOT affected by an old Intel E1000 Ethernet bridging bug which caused a similar problem.

Does anyone have any ideas? In the many of years that I’ve used openSUSE I’ve never seen anything like this. :frowning:

Failsafe kernel also has the issue as well as kernel 3.0.4 (from Tumbleweed)!

https://lh3.googleusercontent.com/-dGLMrmLOy_M/TovW74x8oWI/AAAAAAAABdE/VDl7n4urOnE/s720/Screenshot%252020111004%2520000.png

On 10/05/2011 06:06 AM, nbetcher wrote:
>
> Does anyone have any ideas?

just a hunch: corrupt install media, maybe?
you probably did this <http://tinyurl.com/455hbml> prior to installing,
right?

if not do that first…

then lets scratch heads while wondering how/why the (virtual) disk
partitions got so affected that fdisk had to clean up and recover the
journal ??

so, how does a virtual disk become corrupted before it is mounted?

i’m not sure, but i think that is a question to be asked of the
virtual disk manufacturer :wink: or the administrator/owner of the
VirtualBox, or the maker of the VirtualBox…but, i’m just guessing.


DD
Caveat
openSUSE®, the “German Automobiles” of operating systems

No, I didn’t do that because it was a NET install - there was no media. Also, I did the installation twice and it resulted in the same result.

As far as the corrupt journal, that was because I had to power cycle the VM to test some theories. It mounted clean after the first install.

Anymore theories?

On 10/05/2011 11:16 AM, nbetcher wrote:
>
> Anymore theories?

sorry, fresh out.
(i was streaching to git where i got)

hmmmmmm…i’ve never done a net install but i guess there are some Fn
selections you can make on the first green screen…i guess you have
already tried some maybe likely variations…like maybe try a text
based install?

hmm…do you have access to any logs being generated by the vbox?

oh WAIT! not all VMs can handle a 64 bit OS (if your hosting service is
on the cheap with the free version of vbox i guess that could be the
problem, maybe)…try installing the 32 bit openSUSE 11.4…


DD
Caveat
openSUSE®, the “German Automobiles” of operating systems

On 2011-10-05 06:06, nbetcher wrote:

> Does anyone have any ideas? In the many of years that I’ve used
> openSUSE I’ve never seen anything like this. :frowning:

Any network devices mounted? Or shared devices with the host?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

It was installed with the ncurses version of YaST.

I do not have any access to the VB logs, although if this 32-bit install doesn’t work then I’ll try to get some logs.

Using 32-bit fixed it. :frowning:

VPS Admin says Ubuntu 64-bit works for him.

On 2011-10-06 00:36, nbetcher wrote:
>
> Using 32-bit fixed it. :frowning:
>
> VPS Admin says Ubuntu 64-bit works for him.

Maybe there is some incompatibility with that VPS version.
Or, perhaps you could try the 12.1 beta.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

With init hanging so early in the boot process, I can’t help but wonder if there is an issue with the virtual disk image, or with VB.

Specifically, it hung when running /etc/init.d/boot, and the next steps after displaying that message are:


echo  -n "mounting mandatory file systems ..."
test -c /dev/null    || /bin/mknod -m 666 /dev/null c 1 3
test -e /proc/mounts || /bin/mount -n -t proc proc   /proc >/dev/null 2>&1
test -e /sys/class   || /bin/mount -n -t sysfs sysfs /sys  >/dev/null 2>&1

If there were any issue with the virtual disk file system, it might prevent mknod from creating the /dev/null device or from mounting sysfs, etc. (Or perhaps there is an issue with the underlying file system the VPS is on?)

One way you could verify this is to boot the VM to a live environment, something very light weight is all you need - RIP Linux, or Puppy, etc. You can of course is the OpenSuse install media, and even the netboot media should get you to a minimal recovery environment.

From there you could fsck the file systems, mount them, and see if anything is weird. You chould also chroot into your install and test drive it a bit more.

If you can’t do the above, that will still help reveal what may be going on.

Cheers,
Lews Therin

On 10/06/2011 12:36 AM, nbetcher wrote:
>
> Using 32-bit fixed it. :frowning:
>
> VPS Admin says Ubuntu 64-bit works for him.

why the frown? VPS admin’s Ubuntu is probably using an older kernel than
openSUSE 11.4, one which is compatible with the older VM in use
[openSUSE 11.4 ships with VirtualBox version 4.0.12 while your service
is using 4.0.8]…

if 64 bit is actually necessary for your application (seldom is that the
case) then i’d use my Rule One: Use what works. (ask VPS Admin the
specific version of Ubuntu/kernel which works, and install it)

probably the next VBox version, or the next openSUSE version (12.1) will
work…you could try 12.1 Beta now…


DD
iSad
openSUSE®, the “German Automobiles” of operating systems

Well, I don’t think it’s the VB disk image issue because 32-bit works perfectly, but 64-bit does not. I’m not saying I’m ruling that out completely, but it’s unlikely. I appreciate the comments on that though - I may look into it at a later date.

Exactly, I am using what works for me (32-bit) and it’ll probably remain that way, but ideally this is something that I would like to track down and fix in openSUSE so it is more Enterprise Ready (for example).

I did boot into Recovery at one point (64-bit recovery) and it worked fine, although I didn’t fsck the partition. Because of the amount of effort (and the delay) to get the admin to download and mount a different ISO, I am hesitant to pursue much more. The way I see it, if 32-bit works, then I don’t think it’s an image issue.

On 2011-10-07 01:36, nbetcher wrote:
> I did boot into Recovery at one point (64-bit recovery) and it worked
> fine, although I didn’t fsck the partition.

Did you try failsafe?

If that works, then you might find which one is the setting that makes it work.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Failsafe, ironically, failed as well.

On 2011-10-07 02:06, nbetcher wrote:
> Failsafe, ironically, failed as well.

Pity.
Ok… then use what works, the 32 bit version.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 10/07/2011 01:36 AM, nbetcher wrote:

> Exactly, I am using what works for me (32-bit)

i’m happy you got to that quickly (rather than losing days trying to
force 64 to work)!!

> this is something that I would like to
> track down and fix in openSUSE so it is more Enterprise Ready (for
> example).

agree!! and therefore suggest you log the bug you found, here:
http://tinyurl.com/nzhq7j

and, ask you to return to this thread with the bug number (so the next
who googles into this thread can find it, and any work around or
progress noted there…

btw, be sure and check: there may already be a bug on this…

thanks, in advance, for your bug report and its contribution to making
free and open software better…


DD
openSUSE®, the “German Automobiles” of operating systems