opensuse 11.4 64-bits . virtual kvm qemu machines with networking issues.

Hello

In the past we have successfully used opensuse distros to run virtual hosts. One of the main applications was to run virtual gateway appliances.

We have been doing that by installing opensuse 11.1 plus vmware server. We have now turned into opensuse 11.4 plus kvm/qemu virtual guest machines.

What we are seeing is that after a few days of usage, sometimes the virtual guests loose network connectivity. Sometimes restarting the guest works and this works most of the times, but some other times it doesn’t (this happens less, but still happens). When that happens, it seems that the only solution so far is to shut down all guests using that bridge in order for the guest to regain use of the network. Other guests keep working, but mostly gateway guests (joining one customer network to other customer’s networks) quit working. As of now, we didn’t have to reboot the opensuse 11.4 / x86_64 kvm - qemu host.

The gateways are the same installs we are still using on the opensuse 11.1/vmware server builds.

We have tried all sorts of virtual nic cards on the guests, same results.

Is this a known bug?

Mora data:

kvmhost1:~ # qemu --version
QEMU emulator version 0.13.91, Copyright (c) 2003-2008 Fabrice Bellard
kvmhost1:~ # libvirtd --version
libvirtd (libvirt) 0.8.8

seems similar to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/633392

Am 28.11.2011 14:46, schrieb un yorugua:
>
> Mora data:
>
> kvmhost1:~ # qemu --version
> QEMU emulator version 0.13.91, Copyright (c) 2003-2008 Fabrice Bellard
> kvmhost1:~ # libvirtd --version
> libvirtd (libvirt) 0.8.8
>
> seems similar to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/633392
>
>
I cannot help you with that problem, but if you have some evidence that
it is a bug and it looks like you have report it here
https://bugzilla.novell.com/ (you can login with the same user
credentials you use for the forum).
The developers can probably even point you to a workaround.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

I have just started all the systems again. Will check in the MAC thing as explained on that other thread. So far it is up and running, but the behavior looks similar.

Is there any useful information in the logs on the host ? It will be hard to nail it down without that I think.

Best regards,
Greg

Well, it happened something sort of related to this. I built an opensuse firewall/nat-router on a guest. It worked fine, until the internal interface started to give erratic ping times to both the kvm host server, other kvm guests, and pc’s in general in the local network.

Other guests kept working ok, and the server itself didn’t need to be rebooted. After rebooting the opensuse firewall, everything came back to normal.

Have you seen such a behavior? dmesg didn’t contain any errors.

I’ll try to define Erratic times

problematic guest -> system on the network : pings somewhere between 1000ms and 0.5ms, mostly > 100 ms

problematic guest -> other guest : same as above

kvm host -> problematic guest -> same as above

non-problematic guest -> kvm host : ok
non-problematic guest -> problematic guest : not ok, similar to first example.
non problematic guest -> other system on the network: ok.

rebooting the problematic guest solved the issue.