[openSUSE 11.3] vmware bridged networking doesn't work with wireless adapter

I’m trying the new openSUSE 11.3 and I got a problem:

vmware workstation bridged networking (vmnet0) doesn’t work with the wifi connetion (wlan0) both with linux and windows guest vm; if I use a wired connection (eth0) all work fine; with vmware nat networking (vmnet8) everything is ok both with eth0 and wlan0.
This issue is new to the 11.3 version, in fact with 11.2 bridged networking with a wireless adapter works correctly.
My system is a thinkpad T500, with intel 5300 bgn adapter (module iwlagn, firmware 5000), the kernel is 2.6.34-12 desktop x86_64, I use the latest vmware workstation version available (7.1) on both 11.3 and 11.2 opensuse distributions.

If someone got the same problem and found a solution let me know.

Kind Regards,

Same problem here. 64Bit OpenSuse 11.3, Vmware Workstation 7.1.0 build-261024. Running Win XP Virtual Machine. NAT works, Bridge to eth0 works, but bridge to wlan0 does not work. If anyone has a solution it would be appreciated. Thanks!

I have the same problem, but my system was Opensuse 11.2, kernel-2.6.34 and vmware workstation 7.1. Solution: I used kernel- from kernel.org site.
Now, it’s ok.

Good luck

Juliano Schneider dos Santos

I have the same bug working on VirtualBox if someone find the solution please post it! i’ll do the same! Regards!

From what I’ve seen/read, this is an issue with wireless network cards in general. They don’t have the proper mode to support bridging or something like that. I’ve never been able to make bridged work with wireless, but wired works fine. Not very convenient, I know.

I cannot tell anything about statistics but as I said with openSUSE 11.1 and 11.2 bridged networking works flawlessly with my wireless adapter (intel 5300, module iwlagn).
I hope that a new version of kernel, driver or vmware is able to solve this issue, sooner or later.

I hope vmware fixes this issue really really fast. With 11.0, 11.1, 11.2 everything worked fine with WiFi bridging ! Now with 11.3 im tied to my LAN cable upstairs in the stydu and not able to VPN with my customers network from the living room.
Now my wife and me are fighting over who can sit at the desk.

Updating to vmware 7.1.3 solved the problem.