OpenSuse 11.3 Startup options

Hello

I’m somewhat new to the Linux world (I have worked on Win since 95), but I’m looking to learn. I am reading through the Linux Bible 2010 right now.

I have a question. I had some issues with my system hanging on the automatic configuration of the install so I searched the web for the issue. After reading this thread:
Hangs at end of SuSe 11 install
I used acpi=off apm=off nolapci as the install options and it worked. My question is, do I need to add those options to the /grub/menu.lst or will the install do that?

Thank you.

Install and report back, lets see what you get first…

I used acpi=off apm=off nolapci as the install options and it worked

Is it installed then ?

Yes it is installed. Sorry, I went to bed after I saw the login screen.

Problem now is I’m getting the “Error loading operating system” if I try to boot without the openSuse CD. I left default to install grub instead of MBR. This was once a Win XP system.

Did the media/firmware/memory test with no issues. My bios has a memory/hard disk test and that passed…

well Nevermind. I had used the openSuse CD to boot, I ejected the CD and restarted and it boots with no problems. Odd occurence. I was searching for this error and found:
SUCCESS STORY: “Error loading Operating System” at end of BIOS bootup
only thing I did was change from bit-shift to LBA-assist in bios for HD.

Anyways, yes DVHenry. OpenSuse is installed, and seems to boot just fine. Looking at boot loader settings in Yast, it does show acpi=off apm=off for default(first) kernel image section(pardon if I don’t have the correct terminology).

So…no issues. I’m starting to love linux. The power of it is more than anything Windows can give.

I’m pleased you got it going, I think you will enjoy openSUSE.

On 2010-08-22 20:36, mpezzell wrote:

> Anyways, yes DVHenry. OpenSuse is installed, and seems to boot just
> fine. Looking at boot loader settings in Yast, it does show acpi=off
> apm=off for default(first) kernel image section(pardon if I don’t have
> the correct terminology).

Well, it works, but having those two options active is not a good thing, except for solving a
problem, temporarily. You loose features.

I would try 11.2 instead.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Well, it works, but having those two options active is not a good thing, except for solving a
problem, temporarily. You loose features.

I would try 11.2 instead.

Another option may be to try removing one of these options at a time "acpi=off’ , ‘apm=off’ and ‘noapci’.

To see which ones realy need to be used.

The last option above sould have been ‘nolapci’.

I used acpi=off apm=off nolapci
, or is this last option ‘nolacpi’?

Since a change in the BIOS solved other matters, I’d rather remove all three options from the boot line. Then apply them one by one if the problem returns, my guess is it won’t.

Carlos,

I started with 11.2 but it had the same issue.

dvhenry,

I also did that, well for the install only anyways. Went through all three, took a good couple of hours since it would freeze on the automatic config of the install (even tried manual config but no luck)

I’ll try your and Knurpht suggestion once I get home, (since the install is finished and the “error loading OS” was LBA related) and boot through iterations of options, none first.

oh btw, it is an HP 530 notebook, 2 GB RAM, and 300 GB hd
HP 530 Notebook PC (KD097AT) specifications - HP Products and Services Products
with latest BIOS firmware F.07. There is no option in the bios to specify, I think I have seen this on other bioses, ACPI version support, or really there is not many options in regards to power.

Thank you all for your help.

OK. I removed those startup options from the kernel image, and no problems. I can shutdown, restart, standby, and hibernate without any issues.

Thanks for the help. I’m wondering if that was the source(bios HD setting) for my initial problem.

I’m wondering if that was the source(bios HD setting) for my initial problem.

To me it very much looks that way.

Well, out of curiosity I went through the install again. I mean, of course it is so obvious if it can go through the install with acpi=off apm=off for install options it is a power configuration/management issue, and absolutely nothing to do with BIOS hard drive setting. The BIOS HD setting was the source for the failure to boot Linux. Though, one thing mathematics and working helpdesk / tech support for 10 years taught me is that you can not dismiss any variable until the source element that is causing the problem is isolated.

“There is nothing as deceptive as an obvious fact”
“When you have eliminated the impossible, whatever remains, however improbable, must be the truth.”
~ Sir Arthur Conan Doyle

Oh to add to my post a very significant piece of information: “But of course I remove acpi=off apm=off from the startup options after the install completes I have no problems. So it is interesting to say the least. I guess it is caused by a hardware probe during install?”

On 09/24/2010 10:06 AM, mpezzell wrote:
>
> Oh to add to my post a very significant piece of information: “But of
> course I remove acpi=off apm=off from the startup options after the
> install completes I have no problems. So it is interesting to say the
> least. I guess it is caused by a hardware probe during install?”

Well, perhaps there has been an update that solved that problem. The installed system would get the
update, but the CD/DVD no.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)