openSUSE 11.3 seemed great but with ATI drivers....

Just do not know anywhere else to post this. :slight_smile:

Lattest version (as of date of post) openSUSE Gnome 11.3 64 ATI radeon 5850 card = fail

After 2 days of reading numerous ATI radeon driver threads and guides, doing several install versions and encountering numerous problems (like black screens) I am going back to Ubuntu hard drive. I am so glad I tested openSUSE with ATI drivers on its own hard drive.

I really loved the way openSUSE presented Linux and the features of the system are great. Also very nice people posting so many suggestions and ideas to fix the ATI driver issues and also addressing virtualzation. I see it has been going on for months and months.

I require 3d graphics and Virtualbox. However these two requirements appear to be a challenge for openSUSE where Ubuntu handles them just fine.

This thread illustrates the frustrations one can go through for ATI drivers and openSUSE.

please_try_again had a great script however it came up asking for a missing kernel I had no idea how to resolve.

the wiki method for fglrx gave me another black screen as with the radeonhd. radeon driver just will not run desktop effects.

oldcpu put a lot of effort]( into helping however I am not sure it works with openSuse 11.3 and ATI.

vince4Amy’s]( and similar guides/suggestions for ATI drivers did not work either.

My point here that it just really should be easier then all the posts above to run ATI graphic cards on openSUSE without spending hours and hours attempting to get it to work in 3d mode.

I want to also add that caf4926 is about the most helpful administrator I have seen on a linux forum. I really am not trying to be pissy here I am just frustrated and do not like failing with computer systems which I think this is the very first time.

Pehaps 11.4 will fix all this! :slight_smile:

This is the way I install fglrx drivers on my Dell Studio 1555 with ATi Radeon HD4570 (works for me) :

  1. Install dependencies. Do this as root (by first doing su -):

zypper in -t pattern devel_basis devel_kernel devel_c_c++

  1. Download fglrx driver to somewhere on computer from ATi website. I downloaded mine to /home/andrew/Downloads

  2. Compile the driver for openSUSE 11.3 Notice this is for 64 bit because I have a 64 bit laptop:

cd /home/andrew/Downloads
chmod +x
./ --buildpkg SuSE/SUSE113-AMD64

  1. Install the driver (run as root by doing su -):

zypper in fglrx*.rpm

  1. run aticonfig (run as root by doing su -):
aticonfig --initial
  1. Reboot, then you have fglrx installed and running :slight_smile:

My experience with Ubuntu ATi was quite the opposite. Last version I tried Ubuntu (Ubuntu 10.04) I installed fglrx through “Hardware drivers” under System->Administration and whenever I closed my laptop lid the laptop would just freeze. But I think it was fixed in a later version of fglrx I just haven’t tried the later version on Ubuntu though.

Soapbox is as good an area as any.

Welcome to openSUSE forums and to openSUSE.

On the forums we are a bunch of openSUSE users, enthusiasts, and pretty much all volunteers. We are not paid for our contributions, but in the true spirit of open source software we like to contribute a bit back to Linux, in this case contribute some of our time to help others and to share the knowledge (however feeble) that we may have.

I recommend you start a specific thread of your own (don’t tag on to someone else’s thead) and ask for help with your ATI hardware under openSUSE.

I am confident we will help you to get it to work. Spending hours without starting your own thread is a time wasting approach. While we do like to read that users have put some research into a subject, spending more than 1/2 an hour is IMHO a complete waste of time.

Simply ask in the appropriate forum area IN YOUR OWN THREAD, and I hope we can help.

Good luck !

You can learn a lot by researching a subject on your own. Other resources, for example. Besides, some people hate asking for directions. It’s a guy thing, y’know. :wink:

Thank you.

*( for ATI driver install and it worked the best so far. My terminal screen is garbled though however at least I have 3d on desktop.

I have done a lot of searching btw :wink:

Thanks again.*

Maybe I’ll see Ubuntu one day when they learn how to implement Plymouth :slight_smile:

nomodset setting fixed my terminal graphics. All is running fine now. VirtualBox is working fine too.

OpenSUSE definitely runs faster then Ubuntu it just seems to have a steeper learning curve for installation and setup.

I hear you on Plymouth. :slight_smile:

Thank you ah7803. Worked perfectly

No problem. Glad it worked for you :wink: