openSuse 11.3 RC1 Yast bug

I just installed RC1, and when I opened Yast, I found that the icons on the right were broken - badly pixellated, much too big and overlapping each other:](

Also, during install, I told it to install Grub into its root partition, rather than into the Mbr. It ignored that though and still installed Grub into the Mbr.

Finally, the new user faq link doesn’t work. I tried the link at the very top of the forum:
but only got an “Invalid link” error.

Welcome to the forum. I haven’t experienced your icon problem, however I can think of a possible reason for your partition installation problem.

I assume that during installation on the summary screen, in the grub section, you had the mbr line disabled and you enabled the line for root partition. That’s not enough, and I can understand how easy it is for new users to miss the additional changes required.

You have to click on the Grub section heading to enable further changes. It then puts you into the normal YaST>System>Boot Loader which you can now access from the installed system to have a look at what comes next. Under Boot Loader Settings, click on the tab labelled “Boot Loader Installation”, then click on the “Boot Loader Options” button. You need to remove the tick marks against these two options:

  • Set active Flag in Partition Table for Boot Partition
  • Write generic Boot Code to MBR

Click OK button on each screen to apply and exit. Use the help button on bottom left of each screen for explanation if needed.

That avoids changing the mbr, but assumes you will manually edit your existing Grub boot loader to re-start from the new installation partition, at first reboot part way through the install. :wink:

No? Any idea why the icons are messed up like that, and what I could do about it?
It’s a fresh install with Kde from the 11.3 RC1 installation Dvd.

Not enough? Then it’s pretty misleading, and I’d consider it a bug.
It should either tell people of the additional changes neccessary, or better, perform them itself.
I’ve added my main distro now (currently Mandriva 2010.1) and set it as the default boot option (by editing /boot/grub/menu.lst), that works as well.
It’s just that, should I complete trying out openSuse and find I don’t want to keep it, I’ll have to restore the Mbr again. That’s why I prefer for new distros that I try out to have their boot loader installed into their root partition.

Also, what’s the proper link for the new users faq?

Did you do a media check
Like this

New User How To/FAQ (read only) - openSUSE Forums

Yes, that’s always the first thing I do before installing a new distro, to make sure everything’s alright.
I also always turn on verification of written data when burning a CD or Dvd.
Both (verification and media check) told me the disc is fine.

Thanks, will take a look.
You should change the broken link at the very top of the forum, so new users can find it.

There’s no guide for 11.3. Should I just take the repositories for 11.2?

No, never seen that before, and I try to avoid guesswork on other user’s problems.

Then you probably don’t understand the difference between a software bug and a program design issue. Yast’s boot loader utility is set up with defaults suitable for the more common requirement of booting from the mbr. However, if you are so confident it’s a bug, you can submit a bug report via the website. Good luck with that. :\

I tripped over this one myself the first time I installed openSUSE. I suppose that, in one sense, this is indeed a design issue rather than a bug, since the installer appears to be working in the way that the developers intended. However, I would be inclined to go ahead and report it as a bug. Developers (and more experienced users) can sometimes overlook interface ambiguities that give new users a misleading initial impression of the system, and they are more likely to respond to bug reports than to pick up a discussion on the forums.

Indeed. It also caught me the first time, some releases back, with that particular usage. This problem and solution was posted in the forum before, not that long ago, and there is a search facility. I suspect the problem is caused by the installer executing Yast’s existing utility, and the designer/programmer assuming it already worked for all legitimate use cases. I don’t believe it has been overlooked, because I think I saw a warning on an installer screen about dealing with those two options, while installing a previous 11.3 Milestone (M5-7) but didn’t notice it with RC1.