openSuse 11.3 RC1 testing

Did some more testing, still using Kde 4.4.3, nothing new added so far - it’s better to see which bugs are there right now before I add something new so I know where the bugs come from.

So far I found the following bugs:

openSuse Installer bug

  • installer always installs grub into the Mbr, even if it pretends it won’t do that in the summary. Extra configuration is neccessary to prevent this. New users won’t catch this and will end up having their Mbr overwritten.
    Users should at least be adverted that the Mbr is always overwritten unless they do extra configuration.

Yast bug

Networking

  • setup for Dsl internet connection using Yast is rather longwinded and doesn’t work.
    After going through the configuration again and again, not seeing any errors, I eventually see a mention of “QInternet”. After hunting down this “QInternet”, installing it and then manually launching it, it places an ugly Kde3 icon in my tray, but at least internet works.
    Sum-up: poorly done Yast configuration, which requires the manual installation of an additional vintage Kde3 program to work at all.

I tried using NetworkManager (nm-applet) instead, but that doesn’t work. After installing network-manager-gnome and manually running nm-applet, nothing happens.
Dsl support in knetworkmanager is broken, so I can’t use that one.

Dolphin issues (none of which I found in other distros)

  • Dolphin tends to show graphical artifacting, with parts of the window not being drawn properly
  • if you set the icon size bigge than 64 pixels, you end up with ugly, mushy icons
  • Dolphin isn’t set-up properly. None of the mounted devices (partitions etc.) appear under “Places”, as is usually the case.

Yast software installer

  • The installer prevented me from removing that Java garbage. When I selected “java-openjdk” to uninstall, it forced “java-sun” and some other stuff on me in “Automatic changes”, without me being able to disable it. When I then tried to uninstall “java-sun”, it forced “java-opensdk” and some other stuff on me, again without being able to deselect anything.
    An installer which dictates what I have to keep installed, and which automatically installs additional packages right over my head without asking me if I want them and giving me the ability to deselect any of them is a serious no-go >:(

After such a short testing only, I already noticed serious design flaws in various parts, right from the installation of the OS and especially in the Yast app which is supposed to be so good… this doesn’t bode well.

Any solutions as to how to get at least the Yast installer to behave properly, so I can uninstall apps I don’t want and preventing from installing additional packages over my head?

I experience none of the issues you describe. Although I have not tried removing java.

It’s possible to remove java no problem, I just tried.

@Kameleon1

Have you ever installed and used the released version on your undisclosed hardware i.e. openSUSE 11.2?

same here - none of the issues mentioned are on my rc install (using the 64 bit version)

caf4926 wrote:

>
> It’s possible to remove java no problem, I just tried.

What he describes is also not new to 11.3 - I need the Sun version for
stability in a couple of apps and was surprised when deleting the openJDK
from 11.2 - the Sun version was automagically selected for installation. I
haven’t tried to remove Java completely but just for grins I then tried to
delete the Sun java - and had the openJDK auto-selected for installation.
Not an issue for me and I had already assumed 11.3 did the same thing.

So far, the only real problem I’ve see n with 11.3 is an even worse response
to the nVidia cards I have to test on. At least 11.2 responded to the
hardware with a useable basic video and X started to the point I could
proceed where 11.3 rolls over and dies. Hoping to get time this week to
play with some of the workarounds as this will be a show stopper here until
fixed. Us poor, ignorant elderly folks can’t afford to upgrade to make the
software happy :wink:

Is it my imagination or is the installation somewhat slower than 11.2? Some
of the steps seem to really drag, even if I skip the network test and
online update until I can kill IPV6. Again, not a problem but an
observation with no real actual timing tests.


Will Honea

was surprised when deleting the openJDK
from 11.2 - the Sun version was automagically selected for installation
This did NOT happen for me…

Is it my imagination or is the installation somewhat slower than 11.2? Some
of the steps seem to really drag, even if I skip the network test and
online update until I can kill IPV6. Again, not a problem but an
observation with no real actual timing tests.
Not timed, but I get the same feeling…
With boot time too…it feels about the same or factionally slower

Did a clean install last night, none of the issues mentioned. Java can be removed and reinstalled, no problem.
About boottime: I clock the boottime every once in a while, don’t see any difference with 11.2, same services started, always around 24 secs from GRUB to network connected KDE4 desktop with autologin. I expected some speeding up here, but it’s not there. *buntu boots faster, but looses time on the KDE4 desktop start, so the result is about the same.

Now why would I want to install the old 11.2 now that the new 11.3 is about to come out? :sarcastic:

I see, so the inability to remove Java, where it’s always installing the other version if you remove one, isn’t new in 11.3.

To those who pretend tha Java can be completely removed: just tell me how you keep the Yast installer from automatically installing another version of Java once you remove one version of it before I believe you that you actually can remove it completely.

Another bug I found:
Input system for Chinese/Japanese/Korean (keyboard in system tray) only work for apps run as root. For apps run as normal user, it’s broken and doesn’t appear in the system tray, so you can’t use it.
As this is crucial for me - I need East Asian language input for work - I’d say this is the last straw, and I’ll ditch it for now.
Perhaps I’ll pick up the final later on and see if all the bugs I mentioned have been fixed.

I note the sarcasm icon/smilie. :slight_smile:

Still for those who don’t understand the sarcasm, … if I may comment here ?

… You do make a good point (even if sarcastic). 11.3 should have a LOT of neat things that 11.2 does not have.

But in my experience, all is NOT gold when any new release comes out. Typically the first 2 to 3 months when a new release hits the street are rough. When a new release hits the street, as opposed to maybe a hundred or two hundred testers of the milestone releases, the distribution is exposed to tens of thousand users, who find all sorts of bugs that were never discovered in the testing. Bugs that do NOT exist in the older version. ie 11.3 for the first few months after the GM version is released, will have bugs that probably are not in 11.2. Hence for less bugs, 11.2 makes sence. 11.2 will be more stable for a brief time frame (until 11.3 catches up).

Plus as newer applications, libraries, drivers are released, compromises are made, and sometimes older hardware suffers. For example there is one PC in our family (of six) where 11.1 is superior to 11.2 and 11.3. A bug was introduced in the kernel immediately after 11.1 was released, and the bug has not yet been fixed. Neither 11.2 nor 11.3 run on that PC well. Yet 11.1 runs well.

I have another PC of our six, where 11.1 is just as good as 11.2 and 11.3 after one balances the pros and cons. …

Only in 4 of our six PCs is 11.3 superior.

So the expression YMMV (your mileage may vary) is very true here. … :slight_smile:

To those who pretend tha Java can be completely removed
You have to be kidding right. Pretend!

As stated though YMMV
But my install is well cluttered now and I can still remove it, so all I can assume is you installed something that makes Java a must have. Which might mean, even if we told you how to force the removal it might bork your system.

When I removed java jdk java sun was marked for installation
then after java sun was marked for deletion yast wanted to install java jdk.

as a side note isn,t open office based on java?

Forbidding installation of java jdk and removing java sun i get

YaST2 conflicts list - generated 2010-06-21 17:03:10

OpenOffice_org-LanguageTool-1.0.0-4.30.noarch requires jre >= 1.6, but this requirement cannot be provided
uninstallable providers: java-1_6_0-openjdk-1.6.0.0_b17-6.12.i586[11.3_Factory]
java-1_6_0-openjdk-1.6.0.0_b17-3.2.i586[openSUSE-11.3 11.3-1.59]
java-1_6_0-openjdk-1.6.0.0_b17-6.10.i586[repo-oss]
] Following actions will be done:
deinstallation of OpenOffice_org-LanguageTool-1.0.0-4.30.noarch
deinstallation of OpenOffice_org-LanguageTool-en-1.0.0-4.30.noarch
] do not forbid installation of java-1_6_0-openjdk-1.6.0.0_b17-6.10.i586[repo-oss]

 ] do not forbid installation of java-1_6_0-openjdk-1.6.0.0_b17-3.2.i586[openSUSE-11.3 11.3-1.59]

 ] break OpenOffice_org-LanguageTool by ignoring some of its dependencies

 ] do not forbid installation of java-1_6_0-openjdk-1.6.0.0_b17-6.12.i586[11.3_Factory]

 ] keep java-1_6_0-sun-1.6.0.u20-1.15.i586

YaST2 conflicts list END

I have an old test machine with a slightly borked install of Enlightenment. So, I decided to give 11.3 RC1 a whirl. The Live KDE is running nicely. Firefox beta is giving warnings about plugins but no useful info. I’ll try sorting that out in a bit. Next comes an attempt at an install from the running CD. Almost forgot to show you my identification papers :wink:

Celeron (Coppermine) 946.70 MHz
512 MB total RAM
Video: Intel i815 intel 2D driver, Unknown Classic 3D driver
Linux 2.6.34.9-default i686
KDE 4.4.3

I like the new artwork.

This is weird…I had to reinstall on the laptop, to have the spare SSD as a copy of the install. Updated from factory repos and guess what? I can’t remove java, caused by the OpenOffice Language tool…The first install on the laptop allowed me to remove java, could this be changed in the last couple of days?

The database component of OpenOffice relies on Java. The other components do not. For example, the LiveCD of Linux Mint 9 ships without OOBase or Java, and the remaining OO components work just fine (you can also download and install from a somewhat larger LiveDVD if you really need OOBase).

I suspect, though, that you might have to remove the whole OO package, then remove Java, and finally reinstall just OO Writer, Calc, Impress and Drawing in order to replicate that situation.

So the answer appears to be NO, you haven’t installed and used the released version. Why would you want to? I have no idea, but I can think of a couple of reasons why someone might benefit from it.

Strange eh!
I knew about OpenOffice and Java. But I can still remove Java on my 11.3. I’ll run updates and check again later.

Kameleon1 wrote:

> To those who pretend tha Java can be completely removed: just tell me
> how you keep the Yast installer from automatically installing another
> version of Java once you remove one version of it before I believe you
> that you actually can remove it completely.

When in doubt, cheat. Remove the package with zypper or rpm - never met a
cat that could only be skinned one way (yet).


Will Honea

I installed RC1 side by side with 11.2 to give it a try and I have come across some things not working. This is all on a very fresh and clean install, nothing extra added or changed, all options during install is “default”.

  1. Video performance is lousy. Even scrolling in Firefox is sluggish and redrawing slowly. I tested glxgears and it seems to be ok with fps just above 200, abt the same as I have in 11.2. I’m not using any desktop effects.
  2. KNetworkManager-applet isn’t showing the “connected” icon, always the “Activating” icon.
  3. No suspend or hibernate options available in power management, neither when I click the “Leave” button. They are just blank.
  4. Occasional inconsistency in Task Panel with invisible (no) windows taking up space, like Firefox to the far left and Terminal far off to the right when they should be next to each other. I tried to take a screen dump but whenever a new window is started this inconsistency goes away.
  5. Touchpad tapping was deactivated at first, there is an option to activate it but it doesn’t work during install either. Nothing big but a bit annoying.
  6. I’m a bit worried about the fan going in high speed almost all the time which I’m not used to from 11.2. This might have something to do with the lousy video performance. Also 11.3 seems to use a lot more RAM, normally when I start 11.2 I can see: Total memory 2.6, Free memory 2.2. In 11.3 Free memory is just 1.8 after a fresh start with only Konqueror sysinfo started.

Video:
Vendor: ATI Technologies Inc
Model: Radeon X1200
2D driver: radeon
3D driver: swrast (No 3D Acceleration) (7.8.1))

CPU:
Processor (CPU): AMD Athlon™ 64 X2 Dual-Core Processor TK-57
Speed: 1,894.98 MHz

This is a PackardBell laptop 3GB RAM, 1280x800 screen resoultion. I’m running the 64-bit version of 11.3. Hope I choosed the right thread, otherwise feel free to move my post.

Yes, that’s exactly what I’m talking about.

No. There’s just a small part of OO which uses Java (OO Base), but OO as a whole runs fine without Java.

No, thaht’s not neccessary at all - never had to do that. You only have to remove the OO Base part which requires Java, the rest is not affected and thus doesn’t need to be uninstalled to get rid of Java.
If something else besides OO Base is marked as requiring Java (and thus marked to be uninstalled when you remove Java), it’s the fault of the packager wrongly marking dependencies where there are none.

  1. Yes, I have lousy video performance as well, along with artifacts in Dolphin from the window not being drawn properly. This is on a very recent Radeon 4800 series card, mind you!
  2. KNetworkManager has been problematic for me for some time already, so I’m using whatever alternatives a distro offers, or the Gnome applet.
  3. Not using either.
  4. Also had that at one time, where I had an entry sitting in the middle of the taskbar, with a good amount of empty space to either side. Opening a new window made the entry slide to the left. Very strange.
  5. Not using a touchpad.
  6. As I have a custom fan on my graphics card which isn’t controlled by the card, I can’t judge this.