opensuse 11.3 need to restart autofs for NIS automounts to work

Hello all,
I have searched and not found any answers.
We have a few systems running 11.3 and we use NIS and autofs for mounting home directories as well as other nfs mounts.
When these systems boot we are unable to access any of the automount directories.
If I restart autofs everything looks great.

We are NOT using ldap and it is disabled.
I tried setting autofs to start last in the boot sequence by changing the symlinks in /etc/init.d/rc3.d and /etc/init.d/rc5.d/ from S09autofs to S20autofs and that did not help.

Before that I tried adding a sleep 10 to the autofs init script and that did not help either.

Can someone point me to the issue or how to fix it.

my /etc/auto.master file looks like the following.

/net -hosts -nosuid
/amd yp:auto_direct_linux
/h yp:auto_home
/home yp:auto_home
/tools yp:auto_tools_linux
/project yp:auto_project
/scratch yp:auto_scratch
/archive yp:auto_archive
/service yp:auto_service
/dept yp:auto_dept