OpenSuse 11.3 / Mysql / akonadi / nepomuk

I have successfully installed OS 11.3 and it worked first time almost perfectly. Great work, and thanks to all concerned!!!

I am having difficulty, though, connecting to mysql on localhost. I am wondering if it has anything to do with the akonadi service which apparently uses mysql as well. By the way the nepomuk indexing has been running for several hours now. Is that normal? And does that have anything to do with my mysql problems?

Does anyone have an idea?

On a clean install of mysql you can connect by

opening a terminal and running

mysql -u root

This will log you straight in as there is no password for the mysql root user. To set a password run the following queries

use mysql;
update user set password=password(‘YOUR_PASSWORD_HERE’) where user = ‘root’;
flush privileges;

If your server isn’t running you can start it by running

rcmysql start

and to start at boot

insserv rcmysql


hope this helps

Thanks for the quick reply!

It was not a fresh installation, only an update to from 11.2 to 11.3

This is what I get with rcmysql start:

linux-qj38:/home/harvey # rcmysql start
Will update MySQL now, if you encounter any problems, please read following file:
Running protected MySQL…

error: /var/tmp/mysql-protected.1Gfn7W/mysql.sock file didn’t appeared…
Try checking “/var/log/mysql/mysqld-upgrade-run.log”…

But I think I have it. I use the ‘federated’ option to start mysql, and that is unknown according to the log above. Something else is missing, but what?

Can you post the relevant bit of the log?

Here is a bit of the mysqld-upgrade-run.log

100717 18:45:30 mysqld_safe mysqld from pid file /var/tmp/mysql-protected.5NL4mO/ ended
100717 19:59:44 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
100717 19:59:44 [Warning] ‘–skip-locking’ is deprecated and will be removed in a future release. Please use ‘–skip-external-locking’ instead.
100717 19:59:44 [Note] Plugin ‘ndbcluster’ is disabled.
100717 19:59:45 InnoDB: Started; log sequence number 0 114064514
100717 19:59:45 [ERROR] /usr/sbin/mysqld: unknown option ‘–federated’
100717 19:59:45 [ERROR] Aborting

OK, I’m kind of making this up as I go with the help of Google as before this thread I hadn’t heard of the federated storage engine :slight_smile:

What does mysqld --verbose --help | grep federated show?

Also have a look in your my.cnf file and see if there is a line that says skip-federated
If there is comment it out and try again.

The FEDERATED option allows you to access the tables from another server without the extra complications of database replication. You have to create identical tables on your local instance with the ‘federated’ engine option set just as they are defined on the remote server. When you connect to the remote serve the corresponding remote tables are then visible. The only limitation is that you cannot use the ALTER TABLE command to change either table structure.