OpenSuSe 11.3 Multiboot remember last boot

I dd a search on this forum but nothing useful.
I’ve installed 11.3 x64. I multiboot to 11.3 and ExPee

Once upon a time I could set grub to remember which OS I last booted by using “DEFAULT SAVED” along with “SAVEDEFAULT” in each entry. Apparently this no longer works. A file error occurs. After googling it I find that a file similar to /boot/grub/default is supposed to exist but can’t be found or created or whatever. The solution recommended is to use “grub-set-default 0”
The command doesn’t exist. It did with previous versions of OpenSuSe.

Another recommendation was to shell to grub and use the savedefault command.

Possible commands are: blocklist boot cat chainloader cmp color configfile debug device displayapm displaymem dump embed find fstest geometry halt help hi
de impsprobe initrd install ioprobe kernel lock makeactive map md5crypt module modulenounzip pager partnew parttype password pause quit read reboot root ro
otnoverify savedefault serial setkey setup terminal terminfo testload testvbe unhide uppermem vbeprobe

grub> savedefault

Error 27: Unrecognized command

So there appears to be no way to use SAVEDEFAULT and DEFAULT SAVED in OpenSuSe 11.3

Any ideas how I can make grub remember what OS I last booted? Or am I going to have to switch back to XOSL.

Thanks for reading.

This grub command still works, but there appears to be several things required to make it work. First and for most, there must be a file called default that exists in the /boot/grub folder. It must be longer than 10 bytes with the first line including a single digit number that indicated the default that was last saved. You can create this file by using the menu Run Command:

kdesu kwrite /boot/grub/default (enter root password)


(0 then press enter 11 times and then Save - Close - Quit kwrite)

Next you need to add some commands to your grub menu.lst file. These commands include “default saved”, “updatedefaultentry=true”, “savedefault=true” and the “savedefault X” where X is the value of the grub option to save. Here is a copy of my menu.lst file as an example using the menu Run Command:

kdesu kwrite /boot/grub/menu.lst (enter root password)

# Modified by YaST2. Last modification on Sat Jul  3 19:04:53 CDT 2010
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default saved
fallback 0
timeout 30
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title Windows XP Professional
    savedefault 0
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.3 - 2.6.34-12
    savedefault 1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Maxtor_7H500F0_H81AGJDH-part2 resume=/dev/disk/by-id/ata-Maxtor_7H500F0_H81AGJDH-part1 splash=silent quiet nomodeset showopts vga=0x346
    initrd /boot/initrd-2.6.34-12-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34-12
    savedefault 2
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Maxtor_7H500F0_H81AGJDH-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x346
    initrd /boot/initrd-2.6.34-12-desktop

Now consider I had to reboot my computer a dozen times or so to make this work and I looked up more than a dozen sites to find the solution and so it is hard to say if all of the entries shown here are required, but you can not argue with success and it is working for me.

Thank You,

/usr/sbin/grub-set-default is where it is. Perhaps you used sudo without -i or su without - so /usr/sbin wasn’t in the path.