OpenSUSE 11.3 Lenovo T410 Brightness Control Not Working

I have read through other posts on this subject of screen brightness control not working and have not yet found a solution.

I have a new Lenovo T410, fresh load of OpenSUSE 11.3 (dual boot WinXP), Desktop is KDE. Brightness control keys do work with Windows XP.

Pressing the keyboard brightness keys shows xev receiving XF86MonBrightnessUp/Down events, and the following values change from 0-15 :

However the physical brightness of the backlight does not change.

Help in resolving this will be appreciated.


Have you tried setting the keyboard
When I just looked though (IBM) - It’s only showing the T60 range. Might be worth trying?

My R61 is in the list and I use it
My G550 isn’t, but it all works with the default generic layout.

Where does one set the keyboard? I didn’t see an option in yast for setting the model.

Are you using KDE or Gnome?
Either way it’s in the System Settings (kde)
or Control Centre (Gnome)

I forgot to mention the T410 has Nvidia NVS 3100M graphics, driver version

You are telling me this…because…?
Is it not working well. There have been some issues with the 260.version driver and I know many rolled back.
But it shouldn’t have any bearing on the Brightness control.

Sorry, I should have been clear regarding the nvidia driver. I read a post that suggested to add
Option “RegistryDwords” “EnableBrightnessControl=1” be added to xorg.conf for nvidia cards, which didn’t help in my case.

I also tried setting the keyboard as you suggest. Using system settings via yast or the KDE application launcher, I see System Keyboard Configuration with options for language, and Expert Settings with settings for repeat rate, num-lock etc. I didn’t see options for setting a specific keyboard type such as ibm etc. I did select english and saved. But it didn’t fix the brightness problem. Is there another keyboard configuration setting applet I am not finding?

Thanks for your suggestions.

This is where I mean. But your layout in the initial UI may be different, I’m running a new version of KDE probably than you.
If your multi-media is not set up and you can’t watch this just by clicking, then right click and save as
Then play it with VLC or Smplayer

Multi-media help FYI
Multi-media and Restricted Format Installation Guide

I read an Ubuntu thread on the same topic. A Feodra thread too. So, its clear that this is directly related to the use of the nvidia driver (as you have already alluded to), hence this issue should be be taken up with nvidia.

FWIW, I include this wiki page concerning the T410 model and Fedora 14. It mentions

ThinkPad keys are handled by a mixture of the thinkpad_acpi, acpi button, acpi dock and acpi video drivers.

Do you have the thinkpad_acpi driver loaded?

Caf2946, Thanks for the movie. It is now clear that my install does not have the keyboard options you show.
I only have options for keyboard repeat rate and language. Nowhere do I see a place to select a keyboard type.
Is there an update to the utilities? I installed this system from a fresh 11.3 download last week.
Below is the release and uname info if that provides a clue.

cat /etc/release

openSUSE 11.3 (x86_64)
VERSION = 11.3

uname -a

Linux 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

Thanks again for your time on this.


I tried adding the option as mentioned in the Ubuntu and Fedora threads and X would not start and /var/log/Xorg.0.log pointed to the RegistryDwords as the problem.
Option “RegistryDwords” “EnableBrightnessControl=1”

lsmod does show thinkpad_acpi

lsmod | grep think
thinkpad_acpi 83674 0
snd 84348 17 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_nvhdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer,thinkpad_acpi
rfkill 21863 4 thinkpad_acpi,cfg80211,bluetooth


I just installed the latest updates and now keyboard type selections exist in the gui. I tried all of the IBM thinkpad types which did not make a difference. Another symptom is when I set the brightness with winxp it is preserved when I boot opensuse, however if the screen saver kicks in the brightness is set to maximum when the saver is terminated by a keyboard or mouse event.

My post to the nvidia forum thus far has gone unanswered.

I know you were pointed here already, but did you check this
Category:T410 - ThinkWiki
The acpi section may have something on settings