opensuse 11.3 intel hd graphics dual monitor problem with latest kernel

i’m going to assume it was the kernel update that did this. i’m still googling about how to possibly roll back a kernel update so i can be sure.

i use dual monitors, and extend my desktop onto the 2nd one. today it looks like this

the left monitor works fine. everything is in the right position, and the mouse tracks stuff fine

on the right monitor, it’s almost like part of hte left monitor has wrapped around. additionally, all my mouse clicks are off position by a few inches, much like the image is off position

the screenshot i originally took looked fine, so i guess that means X is outputting it fine but the driver is mucking it up. i had to doctor the screenshot to show what it actually looks like on the screen

How does a person like me has a bit of trouble explaining the problem file a proper bug report?

laptop is a dell latitude e4300 with a Intel Arrandale Integrated Graphics Controller

confirmed kernel issue. rolling back today’s to the previous
kernel 2.6.34-12-desktop fixed the issue. btw this is 64bit. where should i go from here?

I hear that several people have had problems with the latest openSUSE 11.3 kernel security update. I see another user here saying they can’t log in, unless they use the failsafe kernel anymore.

Cannot log in after kernel update

Why don’t you give them help on how to downgrade their kernel while using the failsafe mode. I have already switched to kernel and bypassed the latest update and so it is hard for me to give exact directions on the required kernel downgrade you just performed.

Thank You,

I think I may be having issues with the same kernel. I installed a new one today, and I don’t dual boot, but I plug a monitor into my laptop and disable the laptop display. Now the monitor will only work if the desktop effects aren’t enabled. If I enable them, the computer freezes. Could you please post instructions on how to bypass the latest kernel?

So I used “zypper in --force kernel-desktop=2.6.34” to restore the old kernel which seemed to work fine, but then when I tried to turn the desktop effects on my computer froze and when I tried to restart it there was a kernel panic. I have no clue what that means and am hoping that I did not lose all of my data.

Any help would be much appreciated.

Have the same problem too, even updating the Kernel to 2.6.36 did not fix the problem. I also noticed that when i switch of the laptop (HP) and restart/ reboot it hangs at the bios level the bootloader (2 OS installed) does start, i have to remove the battery a few seconds and put it back to have it start normally.

Also I can confirm this also on a:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])

    Subsystem: Dell Device 040a
    Flags: bus master, fast devsel, latency 0, IRQ 29
    Memory at 90000000 (64-bit, non-prefetchable) [size=4]
    Memory at 80000000 (64-bit, prefetchable) [size=256]
    I/O ports at 70b0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915

Also I am now getting a black screen on bootup . Problem here is that I have some encrypted volumes since this is a company notebook :frowning: This issue and others are forcing me to add all factory repos and see if some problems are fixed . Will report back if so.

something else, curious what model HP ? My wife had the same issue and eventually worsened had to get the Motherboard replaced (was still under warranty). just fyi.[/size][/size][/size]

If a kernel update caused a problem that was not there before and dropping back or even moving way up in kernel versions does not provide a fix, then one must assume some sort of configuration setting was lost. For instance, some graphic cards require the kernel load option “nomodeset”, without the quotes. One can type in this command just before selecting the openSUSE kernel version you want to load at boot time. You type in nomodeset, within 8 seconds and press enter. If adding in this option helps, you can edit your /boot/grub/menu.lst file and add this kernel load option as a permanent setting. This is just an example kernel setting though as I don’t know for sure just what was lost. The kernel has hundreds of possible load options and when a new kernel version is installed, it is hoped that the old options would be preserved, but perhaps not in this case.

Thank You,

In my case it was not any grub settings , they are all there vga modes keymap etc etc etc. Silly me forgot to backup the older kernel, since opensuse like to remove it when updating :wink: still waiting for zypper to finish with factory taps fingers on desk lol

Well the Celadon kernel fixed the black screen while booting. Will try the dual monitor setup later, but looking better already :smiley:


oh and to the op , this is also a latitude e6410 . I had to update the bios do not know about your model but they had a recent fix for video. So you might also want to try that . Also are you using a docking station ? That also created some issue for me.(Still havent got to the dual monitor yet)

About the desktop effects: This is a known bug in 2.6.34.
It is fixed in and 2.6.35. (If you are using the i915 kernel

I have the same problems here. The kernel updated caused problems with the
dual monitor setup and the externel keyboard (see and the old kernel
freeze the system with desktop effects turned on.

My solution: I installed the kernel source, patched the graphic driver and
compiled/installed the module.
I did a lot of research and had some help in the bugzilla.

I have a 6530b, it is also a company notebook with one partition (vista OS) encrypted, I have ready downgraded to avoid uncomfortable surprises.[/size][/size][/size]

I think hers was one of those new dv2 something. Anyways back to topic after completely updating to factory kernel the problem has gotten a lot worse , not only does dual monitor not work but also the module has problem drawing applications on the screen . This really sucks :frowning: and it appears to be across a lot of distributions:

anyone tried these patches with success ?
Bug 29278 – [Arrandale] black screen on dell e6510 (eDP)

for the record:

anyways this is craziness , well Im still trying will report back any success , sucks to ssh in and export the display or have to plug in external monitor. sigh

Same happens here, even with new kernel update And my hardware is HP 2530p with Intel 4500 MHD. External monitor works in clone mode, but side-by-side it won’t work (external monitor has same “stripe” on right side).
I could not find a good bugreport for this issue yet.

When I change the display settings I see the screen does momentarily flicker into the right place, before settling down with the stripe up the side.

Fiddling around a bit more, I discovered that the effect is much lessened if I set the second screen to be inverted and physically turn it upside down. Now there is only a thin band of a few pixels.

Silly is an understatrment, but I need to get work done and I have wasted enough time with this problem already.

I am having the same issue. on a dell e5410. x86_64

I found that it is only one user profile though. I created a new user profile and it can display both screens proper. any help?

I found that turning off desktop effects and then enabling the 2nd screen corrects the issue. Turning desktop on effects breaks it again. I guess no desktop effects for me for now.