opensuse 11.3 : Headphones do not mute speakers, microphone does not work correctly

Hello,

I’m using opensuse 11.3 on Fujitsu Siemens Celsius H270. I have two possibilities, how to connect headphones and microphone

A. Connectors directly on notebook (in front part)
B. Connectors on port replicator

When connecting headphones to A, speakers are not muted.
When connecting headphones to B, speakers are muted

My codec is Realtek ALC262 and I have played with various model options, but I have never get the situation, that in both connection possibilites speakers are muted. (e.g. sony-assamd mutes connection A, but does not not mute connection B)

Another problem is, that in connection B microphone does not work.

Here required information:

http://www.alsa-project.org/db/?f=327334d59c7823c40b00f71736e0a5028116c4c7

rpm -qa ‘alsa

alsa-1.0.23-2.12.x86_64
alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
alsa-docs-1.0.23-2.12.noarch
alsa-utils-1.0.23-1.8.x86_64
alsa-oss-32bit-1.0.17-29.2.x86_64
alsa-oss-1.0.17-29.2.x86_64
java-1_6_0-sun-alsa-1.6.0.u20-1.2.x86_64
alsa-plugins-32bit-1.0.23-1.9.x86_64
alsa-plugins-1.0.23-1.9.x86_64
alsa-plugins-pulse-1.0.23-1.9.x86_64

rpm -qa ‘pulse

alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
libxine1-pulse-1.1.19-1.pm.44.3.x86_64
libao-pulse-0.9.3-181.2.x86_64
libpulse0-32bit-0.9.21-10.1.1.x86_64
pulseaudio-module-bluetooth-0.9.21-10.1.1.x86_64
libpulse-browse0-0.9.21-10.1.1.x86_64
pulseaudio-module-lirc-0.9.21-10.1.1.x86_64
libpulse0-0.9.21-10.1.1.x86_64
pulseaudio-module-zeroconf-0.9.21-10.1.1.x86_64
pulseaudio-lang-0.9.21-10.1.1.noarch
libpulse-mainloop-glib0-0.9.21-10.1.1.x86_64
pulseaudio-utils-0.9.21-10.1.1.x86_64
pulseaudio-module-x11-0.9.21-10.1.1.x86_64
alsa-plugins-pulse-1.0.23-1.9.x86_64
pulseaudio-0.9.21-10.1.1.x86_64

rpm -q libasound2

libasound2-1.0.23-2.12.x86_64

uname -a

Linux x.y.z 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.6gHZkwoFfB3:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thank you for any help.

Hey your problem is already solved in another thread.

Refer
opensuse 11.3 :Headphones wont mute speakers

No, this is not the solution. I tried everything what is described in that thread, but did not help. Looks like new module option for ALC262 is necessary (same troubles I had already in openSUSE 11.2).

According to the output you provided in your original post, you did NOT apply the solution described in the quoted thread.

In the quoted thread, the solution was to update alsa. I can tell by your PCs alsa applications that you have not done that.

Please, can you update alsa as noted in the quoted thread?

Yes, I’ve updated alsa according that thread and then output looks like this (may be not exactly this one, because I’ve tested it few days ago and this output I did now only as example, what was installed - but I’ve installed alsa update same way):

http://www.alsa-project.org/db/?f=4720a575225eca3d062eb6ea035142d8f1e7eaab

rpm -qa ‘alsa

alsa-docs-1.0.23-67.1.noarch
alsa-plugins-pulse-32bit-1.0.23-31.1.x86_64
alsa-plugins-pulse-1.0.23-31.1.x86_64
alsa-oss-1.0.17-53.1.x86_64
alsa-1.0.23-67.1.x86_64
java-1_6_0-sun-alsa-1.6.0.u20-1.2.x86_64
alsa-driver-kmp-desktop-1.0.23.20100831_k2.6.34.0_12-1.1.x86_64
alsa-utils-1.0.23-23.1.x86_64
alsa-plugins-32bit-1.0.23-31.1.x86_64
alsa-driver-kmp-default-1.0.23.20100831_k2.6.34.0_12-1.1.x86_64
alsa-oss-32bit-1.0.17-53.1.x86_64
alsa-plugins-1.0.23-31.1.x86_64

rpm -qa ‘pulse

pulseaudio-module-zeroconf-0.9.21-67.1.x86_64
alsa-plugins-pulse-32bit-1.0.23-31.1.x86_64
pulseaudio-module-x11-0.9.21-67.1.x86_64
libxine1-pulse-1.1.19-1.pm.44.3.x86_64
libao-pulse-0.9.3-181.2.x86_64
libpulse-browse0-0.9.21-67.1.x86_64
pulseaudio-lang-0.9.21-67.1.noarch
pulseaudio-module-lirc-0.9.21-67.1.x86_64
alsa-plugins-pulse-1.0.23-31.1.x86_64
libpulse0-0.9.21-67.1.x86_64
pulseaudio-0.9.21-67.1.x86_64
pulseaudio-utils-0.9.21-67.1.x86_64
pulseaudio-module-bluetooth-0.9.21-67.1.x86_64
libpulse-mainloop-glib0-0.9.21-67.1.x86_64
libpulse0-32bit-0.9.21-67.1.x86_64

rpm -q libasound2

libasound2-1.0.23-67.1.x86_64

uname -a

Linux x.y.z 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.6gHZkwoFfB3:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Conclusion of the tests: None of the model options provided for ALC262 worked 100% correctly on my notebook in described cases.

What do you recommend as next step?

You have installed 2 different drivers, and the odds are they conflict with each other. Thats not IMHO a good approach and nowhere in the alsa update guides does it say to install 2 different drivers.

I recommend you remove BOTH alsa-driver-kmp-desktop and alsa-driver-kmp-default and then AFTER that removal is complete, reinstall ONLY alsa-driver-kmp-default, then reboot and test.

OK, but in openSUSE I have installed two kernel versions (“default” server and also lighter “desktop” kernel version). I thought if these both alsa KMP are installed, one is used with default kernel and one is used with desktop kernel. OK, I install only default alsa KMP and I’ll make all tests again.

Results should be available on Monday.

Unfortunately openSUSE is not so flexible that the correct driver will be used. Indeed having both alsa-driver-kmp installed will likely means neither will work.

If you install only one, then likely you will be able to get this working on one kernel, but not on the other kernel.

Is it really necessary to have both kernels ?

OK, Monday is a little bit earlier :slight_smile:

I have installed only alsa KMP default, but results are the same: None of the model options provided for ALC262 worked 100% correctly on my notebook in described cases.

In 99% cases I use only default kernel, but I had already some troubles after 11.2->11.3 update, only desktop kernel was running and saved my life. :slight_smile: (if I good remember, both kernels were installed per default with openSUSE 11.2)

I would need to see the output of the following to make an assessment:

rpm -qa '*alsa*'
rpm -q libasound2
uname -a
/usr/sbin/alsa-info.sh

selecting share/upload with the script and providing the URL/address provided with the script.

I understand that MUST be irritating to constantly provide, but I’ve lost count of the many dozens of times users have stated they updated as suggested, and in fact when they provided the answer to the above, they had misinterpreted (or my instructions were poor) and they did not update as intended.

Reference your mic not working, your mixer is totally misconfigured, which may explain why it does not work. Look at the settings I highlighted in red. I can not figure how you plan to capture audio, given the mic is either off, or capture set to 0% capture.
Simple mixer control ‘Front Mic’,0 **
Front Left: Playback 0 [0%] -34.50dB]
[off] **
Front Right: Playback 0 [0%] -34.50dB]** [off] **
**Simple mixer control ‘Front Mic’,1 **
Front Left: Playback 0 [0%] -34.50dB] **[off] **
Front Right: Playback 0 [0%] -34.50dB] **[off] **
**Simple mixer control ‘Front Mic 2 Boost’,0 **
Front Left: 0 **[0%] **
Front Right: 0 **[0%] **
**Simple mixer control ‘Front Mic Boost’,0 **
Front Left: 0 **[0%] **
Front Right: 0 **[0%] **
**Simple mixer control ‘Mic’,0 **
Front Left: Playback 0 [0%] -34.50dB] **[off] **
Front Right: Playback 0 [0%] -34.50dB] **[off] **
**Simple mixer control ‘Mic Boost’,0 **
Front Left: 0 **[0%] **
Front Right: 0 **[0%] **
**Simple mixer control ‘Capture’,0 **
Front Left: Capture 31 [100%] [34.50dB] **[off] **
Front Right: Capture 31 [100%] [34.50dB] **[off] **
**Simple mixer control ‘Capture’,1 **
Front Left: Capture 0 **[0%] ** -12.00dB] [on]
Front Right: Capture 0 **[0%] **-12.00dB] [on]
**Simple mixer control ‘Capture’,2 **
Front Left: Capture 0 **[0%] ** -12.00dB] [on]
Front Right: Capture 0 **[0%] **-12.00dB] [on]
**Simple mixer control ‘Input Source’,0 **
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’
**Simple mixer control ‘Input Source’,1 **
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’
**Simple mixer control ‘Input Source’,2 **
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’

Here it is:

http://www.alsa-project.org/db/?f=bb94f5d6f5b8f667638bd7af711a92ec59237065

rpm -qa ‘alsa

alsa-driver-kmp-default-1.0.23.20100903_k2.6.34.0_12-1.1.x86_64
alsa-oss-1.0.17-53.1.x86_64
alsa-plugins-32bit-1.0.23-31.1.x86_64
alsa-1.0.23-67.1.x86_64
alsa-plugins-pulse-32bit-1.0.23-31.1.x86_64
java-1_6_0-sun-alsa-1.6.0.u20-1.2.x86_64
alsa-plugins-1.0.23-31.1.x86_64
alsa-docs-1.0.23-67.1.noarch
alsa-plugins-pulse-1.0.23-31.1.x86_64
alsa-oss-32bit-1.0.17-53.1.x86_64
alsa-utils-1.0.23-23.1.x86_64

rpm -q libasound2

libasound2-1.0.23-67.1.x86_64

uname -a

Linux x.y.z 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

For update I use YaST and switching all packages from multimedia repository + installing kernel module from multimedia kernel modules repository.

Simple mixer control ‘Front Mic’,0
Front Left: Playback 0 [0%] -34.50dB] [off]
Front Right: Playback 0 [0%] -34.50dB] [off]
Simple mixer control ‘Front Mic’,1
Front Left: Playback 0 [0%] -34.50dB] [off]
Front Right: Playback 0 [0%] -34.50dB] [off]
Simple mixer control ‘Front Mic 2 Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Front Mic Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Mic’,0
Front Left: Playback 0 [0%] -34.50dB] [off]
Front Right: Playback 0 [0%] -34.50dB] [off]
Simple mixer control ‘Mic Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Capture’,0
Front Left: Capture 31 [100%] [34.50dB] [off]
Front Right: Capture 31 [100%] [34.50dB] [off]
Simple mixer control ‘Capture’,1
Front Left: Capture 0 [0%] -12.00dB] [on]
Front Right: Capture 0 [0%] -12.00dB] [on]
Simple mixer control ‘Capture’,2
Front Left: Capture 0 [0%] -12.00dB] [on]
Front Right: Capture 0 [0%] -12.00dB] [on]
Simple mixer control ‘Input Source’,0
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’
Simple mixer control ‘Input Source’,2
Items: ‘Front Mic’ ‘Front Mic 2’ ‘Mic’
Item0: ‘Mic’

Prio 1 test is speakers muting, if some speakers muting test passes, then I plan also test microphone deeper. But no module option passes Prio 1 test, so I did not test microphone yet.

Capturing of voice (microphone) is per default disabled with various model options. I only tested little bit capturing voice from built-in microphone for models hp-bpc (with this module option built-in speakers does not work at all (but headphones are working), capturing voice from built-in microphone does not work too) and hp-bpc-d7000 (with this module option built-in speakers does not work at all (but headphones are working), capturing voice from built-in microphone works)

>> Simple mixer control ‘Capture’,0

With various model options is see in mixer window only channel ‘Capture’ Other capture channels are available too, but are invisible (they appear in channel settings as available, but I dont know how to select them as visible)

I dont know where the problem is, for me it looks like alsa/kmix does not map my sound devices correctly and this notebook needs probably new model option. But maybe this view is totally wrong and e.g. only some services should be properly configured.

Problem with microphone connected to port replicator reported to me my colleague - he has the same notebook (the same HW configuration) with openSUSE 11.3 installed, I’ve merged it with my post. Capturing was enabled and when connected directly to notebook, external microphone worked.

If there will be solution for mentioned problems, we both will test this solution :slight_smile:

I do not understand this. One can add as many channel controls as they like in kmix under Kmix > Settings > configure channels.

If worst comes to worst one can use alsamixer or amixer to do this, but I’ve never had a problem adding the controls in kmix.

I note it is an ALC262 in this FUJITSU SIEMENS CELSIUS H270 laptop. If one assumes that the audio configuration is not properly setup by automatically by alsa upon boot, then one can instead force a model option.

When I look at the HD-Audio-Models.txt file for 1.0.23 of alsa, I note that there are many different model options one can try, one at a time (only one at a time):

The list is here:

ALC262
======
  fujitsu	Fujitsu Laptop
  hp-bpc	HP xw4400/6400/8400/9400 laptops
  hp-bpc-d7000	HP BPC D7000
  hp-tc-t5735	HP Thin Client T5735
  hp-rp5700	HP RP5700
  benq		Benq ED8
  benq-t31	Benq T31
  hippo		Hippo (ATI) with jack detection, Sony UX-90s
  hippo_1	Hippo (Benq) with jack detection
  sony-assamd	Sony ASSAMD
  toshiba-s06	Toshiba S06
  toshiba-rx1	Toshiba RX1
  tyan		Tyan Thunder n6650W (S2915-E)
  ultra		Samsung Q1 Ultra Vista model
  lenovo-3000	Lenovo 3000 y410
  nec		NEC Versa S9100
  basic		fixed pin assignment w/o SPDIF
  auto		auto-config reading BIOS (default)

Now just because most of the above do NOT list your laptop, does not mean one of them might not work. One thing you could do is try each one, one at a time, until you find the one that works best. Some will completely stop your sound, others will have no difference, but one may make it better.

So try each option, one at a time. Lets say you wish to start with the “fujitsu” option (at the top of the list). To do that, simply add a line to the start of your /etc/modprobe.d/50-sound.conf file so that the file looks like this:

options snd-hda-intel model=fujitsu
options snd slots=snd-hda-intel
# u1Nb.6gHZkwoFfB3:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

save the change, and then restart your sound system by typing:

su -c 'rcalsasound restart'

and enter your root password when prompted for a password, then restart kmix (type ‘kmix’ ) and then test your headphones/mic.

If ‘fujitsu’ does not work, then try the next item in the list. i.e. save the name (replacing ‘fujitsu’ in the file edit I provided), save the change, restart alsa, restart your mixer, and test.

Do that for each item until you find the one you like best.

Edit - I know your first post stated you played with model options, but your alsa config was wrong before breaking any hope of previous efforts working.

Good luck !

I did these tests for all mentioned modules … therefore I always say, that none of these model options are 100% correctly working on my notebook.

Did you try those models BEFORE or AFTER you fixed the driver mistake I pointed out. Because doing it before was sadly a waste of time.

Hm, I dont know how to attach my local snapshot. I’ll try to explain. When selecting Kmix > Settings > configure channels it appears windows with 2 columns and OK/Cancel button. In left column are “available” channels (these are not visible in main Kmix window). In right column are “visible” channels, which are visible in main Kmix window. I dont know, how to move channels from column “available” to column visible in order to configure these channels in main Kmix window. When selecting some item from left column, pressing OK button just closes this “view”, main Kmix window refreshes, but nothing is changed.

External mic worked ?? Ok, so that is good.

So now the effort is focused on an internal mic ?