OpenSuse 11.3 does not support ip_pnp?

In OpenSuse 11.2 it was possible to pass the ip configuration on the kernel command line and the kernel would configure the interface (eth0 in my case) properly. The ifcfg-eth0 needed to be configured as ‘static’ and ‘auto’ with the other parameters absent. The kernel arg would look like: ip=<client-ip>:<server-ip>:<gw-ip>:etc:etc

This no longer works or works differently in OpenSuse 11.3, despite the fact that ip_pnp seems to be compiled into the kernel. Is there some way to enable this in 11.3? I just want to do basic static routing with the parameters passed directly to the kernel instead of hard-coded in the ifcfg-eth0.

Thanks

p.s. in 11.3 when I try to do the ip_pnp method the eth0 does come up but none of the routing is correct. There is no default gateway and no ip is assigned even though I am passing the kernel args properly.

slet wrote:

> In OpenSuse 11.2 it was possible to pass the ip configuration on the
> kernel command line and the kernel would configure the interface (eth0
> in my case) properly. The ifcfg-eth0 needed to be configured as
> ‘static’ and ‘auto’ with the other parameters absent. The kernel arg
> would look like: ip=<client-ip>:<server-ip>:<gw-ip>:etc:etc
>
> This no longer works or works differently in OpenSuse 11.3, despite
> the
> fact that ip_pnp seems to be compiled into the kernel. Is there some
> way to enable this in 11.3? I just want to do basic static routing
> with the parameters passed directly to the kernel instead of
> hard-coded in the ifcfg-eth0.
>
> Thanks
>
> p.s. in 11.3 when I try to do the ip_pnp method the eth0 does come up
> but none of the routing is correct. There is no default gateway and
> no ip is assigned even though I am passing the kernel args properly.

Have you had a chance to looks through the logs to see what happens to
eth0? It sounds like openSUSE is fiddling with the interface despite
having been told not too. When you configure the interface from the
command line, you should also not need ifcfg-eth0.


Per Jessen, Zürich (20.6°C)
http://en.opensuse.org/User:Pjessen

I haven’t looked in the logs yet. In my testing if I remove the ifcfg-eth0 altogether the eth0 interface is not configured at all even if you pass the ip= parms. That seems to be the case in 11.2 and 11.3.

I decided to update boot.local to parse the kernel command line and setup the interface myself. In essence reimplementing ip_pnp for static routing.

Not sure if I should report a bug on this or not – it definitely seems to be a regression from 11.2

slet wrote:

>
> I haven’t looked in the logs yet. In my testing if I remove the
> ifcfg-eth0 altogether the eth0 interface is not configured at all even
> if you pass the ip= parms. That seems to be the case in 11.2 and
> 11.3.

It would be interesting to see the boot log when that happens.

> I decided to update boot.local to parse the kernel command line and
> setup the interface myself. In essence reimplementing ip_pnp for
> static routing.
>
> Not sure if I should report a bug on this or not – it definitely
> seems to be a regression from 11.2

I would report it - “ip=” is a kernel parameter, it’s not
openSUSE-specific.


Per Jessen, Zürich (18.6°C)
http://en.opensuse.org/User:pjessen