OpenSUSE 11.3 branded Firefox cannot download Tweetdeck

This gets better and better. First I find out the branded version of Firefox can’t do a right click “save page as” (although it can with CTRL-S), now I discover it can’t download TweetDeck from that program’s Web site. Click on the button to download TweetDeck, it says “Installing TweetDeck” but nothing happens.

I’m going to dropkick the branded Firefox to the curb and install the regular Mozilla version. It’s more up to date anyway. I ran the Mozilla version for some time on 11.0 until I installed 11.3 the other day, so I’ll live without “integration” that doesn’t work worth a ****.

Forget it, problem wasn’t Firefox, it was that I hadn’t installed Adobe AIR yet. Of course, it only took two hours to locate a HOWTO on installing Adobe AIR on openSUSE 11.3. This - SDB:AdobeAir installation - openSUSE - worked. All the rest of the attempts using the Adobe binary installer failed miserably. I wouldn’t waste my time with ANY Adobe product - it’s all garbage - but I need a desktop client for Twitter and TweetDeck is one of the best. I now have it installed again.

Thanks for the legwork, richardstevenhack! Worked like a charm.

FWIW, this method also works on 11.4, both i586 and x86_64.