OpenSUSE 11.3 and mounting Buffalo NAS

Hello folks. :slight_smile:

I am running openSUSE 11.3 and I have a Buffalo LS-CH1.0TL NAS (it doesn’t support NFS) that has all of my media and backup files stored on it. I can access the NAS just fine in Dolphin, but when I try to setup a music folder in any of the media programs (Amarok, Banshee, Rhythm Box) I am confined only to the drive on my computer. There are no options to browse a network share.

So, I guess I have to mount the drive. How do I do this? Is there a GUI I can use to do this, or is this something I need the command line to do? If so, what’s the code I need to input to my fstab?

Thanks for your help?

mwdowns wrote:

> I am running openSUSE 11.3 and I have a Buffalo LS-CH1.0TL NAS (it
> doesn’t support NFS) that has all of my media and backup files stored
> on it. I can access the NAS just fine in Dolphin, but when I try to
> setup a music folder in any of the media programs (Amarok, Banshee,
> Rhythm Box) I am confined only to the drive on my computer. There are
> no options to browse a network share.
>
> So, I guess I have to mount the drive. How do I do this?

I guess your NAS is accessed/shared via SMB/CIFS - maybe Dolphin has a
more direct interface, but you mount it pretty much like any other
filesystem -

mount -t cifs \server\etc e\ra /mountpoint

I don’t use samba very much, so this might not be 100% correct.


Per Jessen, Zürich (19.2°C)
http://en.opensuse.org/User:Pjessen

The mounting I figured out how to do.

But how can I get openSUSE to mount it ever time it boots up? What should my fstab look like?

mwdowns wrote:

>
> The mounting I figured out how to do.
>
> But how can I get openSUSE to mount it ever time it boots up? What
> should my fstab look like?
>

Well, fstab is just a repeat of the options you mount with manually.
See “man 5 fstab”


Per Jessen, Zürich (24.1°C)
http://en.opensuse.org/User:Pjessen

What does “man 5 fstab” mean?

I am using Samba.

These are the lines I’m using in my fstab and their not working:

//192.168.3.2/usbdisk1						/mnt/Music 	     smbfs 	user,defaults 	      0 0
//192.168.3.2/Movies						/mnt/Movies 	     smbfs 	user,defaults 	      0 0
//192.168.3.2/TV						/mnt/TV 	     smbfs 	user,defaults 	      0 0

The NAS is name Socrates but I put the network address in the fstab, should I use the name instead? There are directories in the /mnt folder named Music, Movies, and TV.

mwdowns wrote:

>
> pjessen;2191923 Wrote:
>> mwdowns wrote:
>>
>> >
>> > The mounting I figured out how to do.
>> >
>> > But how can I get openSUSE to mount it ever time it boots up? What
>> > should my fstab look like?
>> >
>>
>> Well, fstab is just a repeat of the options you mount with manually.
>> See “man 5 fstab”
>>
>>
>
> What does “man 5 fstab” mean?

That is what you type in a shell prompt to read the man page.
Alternatively, bring up Konqueror and enter ‘#fstab

> I am using Samba.
>
> These are the lines I’m using in my fstab and their not working:
> Code:
> --------------------
> //192.168.3.2/usbdisk1 /mnt/Music smbfs user,defaults 0 0
> //192.168.3.2/Movies /mnt/Movies smbfs user,defaults 0 0
> //192.168.3.2/TV /mnt/TV smbfs user,defaults 0 0
> --------------------

Looks good, but don’t you need userid and password to get access to a
Samba share?

> The NAS is name Socrates but I put the network address in the fstab,
> should I use the name instead? There are directories in the /mnt
> folder named Music, Movies, and TV.

Use the hostname if you have a running DNS, otherwise IP-address will
suffice.


Per Jessen, Zürich (25.8°C)
http://en.opensuse.org/User:Pjessen

Try instead of :

//192.168.3.2/usbdisk1						/mnt/Music 	     smbfs 	user,defaults 	      0 0
//192.168.3.2/Movies						/mnt/Movies 	     smbfs 	user,defaults 	      0 0
//192.168.3.2/TV						/mnt/TV 	     smbfs 	user,defaults 	      0 0

this:

//192.168.3.2/usbdisk1						/mnt/Music 	     cifs 	user,defaults 	      0 0
//192.168.3.2/Movies						/mnt/Movies 	     cifs 	user,defaults 	      0 0
//192.168.3.2/TV						/mnt/TV 	     cifs 	user,defaults 	      0 0

So, replace smbfs with cifs

Also have a look at this document, Samba HowTo: Mount a CIFS Network Share [Mapped Drive] in openSUSE

Flark, you got it. Changing the fstab to read cifs rather than smbfs worked. Thanks for the help guys.

Now off to find other idiosyncrasies with openSUSE! :smiley: Expect to see me back on the forums asking questions soon!

Welcome anytime mwdowns!

If at first you don’t succeed, redefine success.

zypper in fortune
fortune