OpenSuse 11.3 64-bit on Macbook Pro 5,4

Hi,

I am trying to install OpenSuse 11.3 64-bit version on a Macbook Pro (5,4 firmware 1.8). The laptop will only run Linux and no OSX so I want to use the entire disk for OpenSuse. With that in mind, during install I switch to expert mode:

  1. Delete all partitions
  2. Create a new “msdos” partition table
  3. Create sda1 as ext4, format and mount “/” on it
  4. Create sda2 and assign it as swap partition
  5. Continue the remaining install as normal.

After reboot, grub loads up but boot hangs at:
Error 13: Invalid or unsupported executable format

For context, I have tried Fedora and Ubuntu on this laptop and both hang at “Uncompression Error – System halted” error. I ran memtest on the laptop and all LiveCDs run fine on it so that rules out hardware issues.

My guess is that with Fedora and Ubuntu, both use grub2 and there is some complication with grub2. CentOS and OpenSuse seem to use grub and that gets me as far as loading the kernel but then boot hangs after initrd loading at the error above. Any help or pointers to troubleshoot will be greatly appreciated.

I don’t think you can just throw in a dos disklabel on a x86 Mac. You need to use either elilo or refit to go from efi to normal mbr partitioning system and boot your OS, also you’ll likelly need an OSX partition to do firmware updates.

have a look at Apple Macbook Pro - Gentoo Linux Wiki

in any case more info