OpenSUSE 11.3/11.4 in new Macbook Pro 8,2

I just bought a new macbook pro 8,2 having in mind installing OpenSUSE. I already had some macbooks and had no problems dual booting with refit.

Now the surprise is that apparently the CD-DVD drive is not supported so after booting the LiveCD and going to install it basically says that the DVD is not available with no other choice than a reboot. This is happening with 11.3 and 11.4 too. Ubuntu 10 and 11 as well.

Any clue? I have tried with the “Universal USB Installer” to create a USB with the iso but it gets stuck after booting?

Any idea? Thanks in advance

On 05/29/2011 11:36 AM, g redondo wrote:
> after booting the LiveCD and going to install it basically says that
> the DVD is not available with no other choice than a reboot.

don’t boot the CD and then on the desktop click to install, instead
select install from the first green screen…but FIRST, do this to make sure you have a perfect install disk…

anyway, if you boot from the CD it should not ask for the DVD, so may be
right…maybe Apple crippled that hardware…you do know, don’t you that
Steve is not too hot on ‘his’ hardware being used in ways he has not
authorized…in fact i guess you void the warranty if you install Linux…

but, you need to ask all those questions (crippled hardware? warranty?)
not in an openSUSE forum, but rather a forum where lots of
linux-on-apple users hang out

> This is
> happening with 11.3 and 11.4 too. Ubuntu 10 and 11 as well.

sure sounds like Steve has taken steps to make his hardware stay
original…ask elsewhere on that…

> Any clue?

not me, i’ve seen Apples on TV and actually touched my first one about
three months ago…but, it wasn’t running…cute though.

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

Your Mac would use EFI instead of BIOS, hang around for another mac user to reply, For the rest of us, where we see EFI we tend to see a total PITA! good luck.

My self I have no idea about mac’s, but did you look at this
It may contain something that helps.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

Booting a Linux live cd does not work with a Macbook Pro 8,2. You need to use the installation DVD. By default, unless you use efi boot through grub/grub2, you will be using BIOS emulation.

guys, anybody found something!!! …kindly let us know asap. cheers.

Same problem here!

Can you tell me if you at least get a graphical installation screen? or just the text installation screen?

I have tried live CD 12.1 32 bits and DVD 12.1 64 bits, both graphic installation and cdrom wont work.

Seems that its something about the chipset (sata controller?)

If you have anything else to share about your trying please post it, may be we can get it work joining dark forces :sarcastic: on this macbook pro 8.2

Could you test brynstntn suggestion about bios emulation and using grub? (dont know how to but I will google some)


PD: if you go to the expert settings there you can select some drivers to load… but still dont know really what I am doing.

FWIW, I have been very happy with the 12.1 performance under VB on my MBP 2.4Ghz I5. So far, I don’t see a reason to install natively.

I found a solution… I think. You have to copy the DVD to a USB pendrive, then insert the DVD and the pendrive. I have refit installed and I have already resized the partitions.

So start the mac presing the C key, then select to boot from the 12.1 opensuse DVD. Then when you come to the first page (the one that appears as soon as you boot with the CD. There the splashscreen lets you select the installation source, there you select Hard Disk (then let it start)

You will have booted from the CD(because USB boot seems not to work yet) and then you tell the installer to look into every hard disk (this will also scan the USB pendrive :slight_smile:

Then the installation goes smooth, now I am seting the mac bookpro 8.2 with KDE as I wanted!!!

I have a lot to test but at least the MAC OS X works fine and the openSUSE too.



I have the same problem with openSUSE 10.4 and MacBookPro8,3

I found the following so far.

DVD drive doesn’t work on MacBookPro8,2/3

The DVD drive is not detected by the kernel and is therefore not useable.
roposed release note:
Currently DVD support for the Macbook Pro (8,1) , (8,2) ,and (8,3) is unavailable in 11.10. We intend to correct this with a post-release update.


See: Cd&Dvd

works fine out-of-the-box. Be sure to have at least kernel 3.0.0-14, otherwise on 8,2 the cd/dvd drive is not functioning

Problem with HCI
When MacBook uses BIOS compatibility mode, it switches the SATA controller to IDE mode, making hdd/ssd operations slower since kernel will use ata_piix module insetead of ahci. It seems there are couple of ways to change this, but this one I find to be the easiest, and actually it is the only that worked for me. I have tested this with MacBook Pro 6.2.
Read above link further for systems that are already installed.
Problem installing openSUSE 11.3/4**
Still searching for setting HCI at install time with openSUSE, perhaps a kernel option ….

Unfortunately (long ago I know :-p) I couldnt get to good ends with macbook pro 8.2 and opensuse 12.1, after I installed it as I told before… I have several drivers to search for and test, and I need the notebook for my work. So I couldnt try, I am waiting to have some free time to come back to my opensuse!

In the meantime if anyone is trying the same… I should recommend that when you are asked for the CD/DVD (as the drive is not detected right) you should try the network installation! is will install if you have internet online (it may take some time…)

Another thing I noticed is that the macbook pro temperature goes to hell, I can hear the fan spin but not fast enough… so be careful about the temperature!

Thanks OpenSuse, “I’ll be back” (**** macos x lion its lovely, I need some problems to solve! :frowning: